Missing libasound.so link in /lib

Forum Forums Orphaned Posts antiX-17 “Heather Heyer, Helen Keller” Missing libasound.so link in /lib

Tagged: 

  • This topic has 1 reply, 2 voices, and was last updated May 23-3:34 am by anticapitalista.
Viewing 2 posts - 1 through 2 (of 2 total)
  • Author
    Posts
  • #10452
    Anonymous

      Hi – Kalimera apo Kypro!

      I am trying out antiX-17.1, coming from Void-Linux, which unfortunately seems to be going <void> because the project leader has dissapeared, taking with him all the resources, especially the github repo.

      Anyhow, I have to work hard to “convert” to antix becasue there are so many differences from distro to distro these days. One problem that I came across though may be a bug:

      I could not compile some of my own applications that use alsa sound, because autoconf did not link the object files to libasound2. The cause appeared to be the absence of a link to:
      /usr/lib/x86_64-linux-gnu/libasound.so in /lib/x86_64-linux-gnu/. I added such a link and autoconf checks libasound and links the application to it. Other required libraries link OK.

      There are other issues preventing full compilation of my apps but they seem to be incompatibilities of my internationalization setup with possibly gettext or something else.

      Best regards

      Neoklis
      Ham Radio callsign 5B4AZ
      Web: http://www.5b4az.org/

      #10457
      Forum Admin
      anticapitalista

        Welcome to antiX and thanks for the feedback.

        Philosophers have interpreted the world in many ways; the point is to change it.

        antiX with runit - leaner and meaner.

      Viewing 2 posts - 1 through 2 (of 2 total)
      • You must be logged in to reply to this topic.