mount drives pcmanfm

Forum Forums General Software mount drives pcmanfm

  • This topic has 2 replies, 3 voices, and was last updated May 2-2:31 pm by skidoo.
Viewing 3 posts - 1 through 3 (of 3 total)
  • Author
    Posts
  • #58433
    Member
    Avatarnewuser

    hi, I can’t mount/unmount external drives from pcmanfm. I would like to mount devices through network (like ftp for transfer files) as well.
    when I try to do so, a pop up appears to the warning operation not supported

    • This topic was modified 1 week, 3 days ago by newuser.
    #58437
    Member
    XecureXecure

    First, see if launching pcmanfm with this command enables proper mount/unmount behavior:
    dbus-launch pcmanfm

    If this works, you can add this line to startup and restart the session
    dbus-launch --exit-with-x11 pcmanfm -d &
    See if this enables proper network and mount device behavior when launching pcmanfm normally.

    If the first command didn’t hlp, you may need to install udiskie.

    See this post to see if this is relevant: https://www.antixforum.com/forums/topic/pcmanfm-wont-see-media-volumes/#post-37439

    #58440
    Member
    Avatarskidoo

    sudo apt install gvfs-backend gvfs-fuse

    Installing these will solve it.
    FWIW, they are listed by pcmanfm package as “Recommends:” (not “Depends:”)
    so, per antiX default apt policy, are not auto-installed when pcmanfm package is installed

    $ apt-config dump | grep Recommends
    APT::Install-Recommends "0";

    https://en.wikipedia.org/wiki/PCMan_File_Manager

    • Volume management (mount/unmount/eject, requires gvfs)

    https://wiki.lxde.org/en/PCManFM

    • Full gvfs support with seamless access to remote filesystems (Able to handle sftp://, webdav://, smb://, …etc when related backends of gvfs are installed.)

    • Volume management (mount/unmount/eject, requires gvfs) with optional automounting

    [..]

    Known GTK issues
    Non-mountable entries in /etc/fstab may cause 100% CPU load on mount attempt. The bug is reported to GNOME. Workaround: disable option ‘Mount mountable volumes automatically on program startup’ in Preferences or (better) remove those devices from /etc/fstab.

    pcmanfm users are advised to bookmark (and develop the habit of searching) the following links:
    https://forum.lxde.org/viewforum.php?f=22
    https://sourceforge.net/p/pcmanfm/bugs/
    https://bugs.debian.org/cgi-bin/pkgreport.cgi?pkg=pcmanfm;dist=unstable

Viewing 3 posts - 1 through 3 (of 3 total)
  • You must be logged in to reply to this topic.