Mouse Cursor Assign Not Universal

Forum Forums New users New Users and General Questions Mouse Cursor Assign Not Universal

This topic contains 7 replies, has 4 voices, and was last updated by codger Oct 22-6:19 am.

Viewing 8 posts - 1 through 8 (of 8 total)
  • Author
    Posts
  • #12697
    Member
    codger
    codger

    My eyesight is not good, so I need a large mouse cursor. I have a cursor set called Large Mouse Cursors (!), and I installed it and selected it with the Control Center. The change shows up in some applications (Chromium, Geany), but not others (SapceFM). It also does not show up on the desktop.

    Please tell me how can I get my cursor selection to show up everywhere.

    #12700
    Moderator
    fatmac
    fatmac

    Looks like you want

    Menu > Applications > Preferences > Mouse Configuration

    Linux (& BSD) since 1999

    #12702
    Member
    caprea
    caprea

    Where did you put the mouse cursor set, mouse cursors are in usr/share/icons.

    #12704
    Member
    codger
    codger

    Thanks for the replies. Yes, I used the menu path that led to the Mouse Cursor setting, and it is showing Large Mouse Cursors selected. Yes, I put my cursor set in /usr/share/icons.

    Well, good grief! I just reselected Large Mouse Cursors and this time the change is applied everywhere! Go Figure.

    #12709
    Moderator
    fatmac
    fatmac

    Glad you got it working. 🙂

    Linux (& BSD) since 1999

    #12717
    Member
    codger
    codger

    It turns out there’s more to the story. The new cursor assignment does not stick through a reboot. It goes back to what I reported originally: big cursors some places, but not everywhere. I have to bring up the theme changer again to get the big ones everywhere.

    What makes it even more strange is the fact that I moved the two DMZ* folders to /opt, and the behavior was not changed. I checked, and there are no other instances of those folders. So where is the system finding those little cursors?

    #12737
    Member

    736b69646f6f

    “I moved the two DMZ* folders to /opt”
    That’s a new one on me. I’ve never heard of anything cursor related ever being sourced from /opt

    ls -d /usr/share/icons/*/cursors
    That should show you, from commandline, where the assets of the “known cursor sets” reside.
    If you moved folders (ouch), sounds like you’ve already found them. Browse using rox-filer or spacefm file manager /usr/share/icons and move or copy them back into place.
    I don’t know why the setting for selected cursorset would not stick across reboots. This wiki page mentions editing ~/.Xresources ~/.xinitrc but I’ve never found it necessary to do so
    https://wiki.archlinux.org/index.php/Cursor_themes#Environment_variable

    #12744
    Member
    codger
    codger

    I moved the DMZs to /opt so the system wouldn’t see them. I left only my desired Large Mouse Cursors in /usr/share/icons. But the little black DMZ cursor still shows up on the desktop after every boot.

    I did a search for the cursor files, and there are none unaccounted for. So I don’t know where the system is finding those little icons.

    I have a workaround that I can tolerate. I put antixcc.sh (the Control Center script) in .fluxbox/startup, so it comes up after every boot. It takes only three clicks to get universal large cursors:
    1. Change GTK2 and icon themes.
    2. Close in the Customize look and feel window that comes up.
    3. X to close the Control Center.

    It’s interesting to me that the cursors actually change after click #1.

Viewing 8 posts - 1 through 8 (of 8 total)

You must be logged in to reply to this topic.