Mouse problems on antiX 19.1[solved]

Forum Forums New users New Users and General Questions Mouse problems on antiX 19.1[solved]

  • This topic has 32 replies, 7 voices, and was last updated Feb 23-8:36 am by gerrygk.
Viewing 15 posts - 16 through 30 (of 33 total)
  • Author
    Posts
  • #32683
    Forum Admin
    anticapitalistaanticapitalista

    Your first post suggests you plug in the mouse via the PS/2 port.
    Can you try a usb port instead? Or another mouse?

    Philosophers have interpreted the world in many ways; the point is to change it.

    antiX with runit - leaner and meaner.

    #32705
    Member
    Avatargerrygk

    @caprea:
    The mouse works fine on the same machine / hardware and with Win7 x64. I remember trying a different mouse via both USB and USB-PS/2 adapted port, with the same difficulties with respect to antiX. So the mouse hardware very likely doesn’t seem to be the problem.

    Thus, the plan is changing the kernel on the live USB system. I’ll keep you informed. Thanks so far for your patience and analytics.

    • This reply was modified 3 months, 2 weeks ago by gerrygk.
    #32706
    Member
    Avatargerrygk

    @anticapitalista:
    Already did that. Unfortunately that’s not the solution.

    #32710
    Member
    capreacaprea

    There should be no USB interference at all. The devices are all plugged at separate ports.

    Sorry, for completeness I have to ask this again. Which devices ? Is there eg. a joystick?

    #32767
    Member
    Avatargerrygk

    @caprea:
    Yes, other USB devices in usage are a Logitech Joystick, and 2 external HDD’s. I also use a hub for the JS and one of the ext. HDD’s.
    I have to say that I never got interference problems with any OS so far.

    #32768
    Member
    capreacaprea

    It’s a problem if the joystick acts like a mouse.If the problems go away when you unplug the joystick, you can try to create a /etc/X11/xorg.conf.d/50-joystick.conf
    like here
    https://forum.manjaro.org/t/solved-kde-joystick-acting-like-a-mouse/5032

    #32782
    Member
    Avatargerrygk

    Thx caprea, this could be a very valuable hint. Happy for all the good ideas… Tomorrow I’ll try the live OS with a non-plugged joystick.
    Btw, this is a Standard 4-axis 12-button js with hat switch.

    #32869
    Member
    Avatargerrygk

    The js indeed was the problem. While unplugged, the mouse behaves like normal. Thumbs up, prob solved!

    But /etc/X11/xorg.conf.d/50-joystick.conf didn’t work as expected: While booting up antiX with this config file established, the Xsession could not be started, so the system stopped with the text console (prompt).

    Instructions in 50-joystick.conf are:

    Section “InputClass”
    Identifier “joystick catchall”
    MatchIsJoystick “on”
    MatchDevicePath “/dev/input/event*”
    Driver “joystick”
    Option “StartKeysEnabled” “False” #Disable mouse
    Option “StartMouseEnabled” “False” #support
    EndSection

    #32870
    Forum Admin
    anticapitalistaanticapitalista

    There is a file called 50-joystick.conf already in /usr/share/X11/xorg.conf.d.

    Copy it to /etc/X11/xorg.conf.d (just in case there was a typo) and see if it works.

    Philosophers have interpreted the world in many ways; the point is to change it.

    antiX with runit - leaner and meaner.

    #32874
    Member
    Avatargerrygk

    @anticapitalista:
    OK thx, I’ll try that soon.

    #32875
    Member
    capreacaprea

    In fact the 50-joystick.conf from the manjaro forum causes the xsession not to start anymore, I just tried it.
    Here’s one that works well(under Disable joystick from controlling mouse)
    https://wiki.archlinux.org/index.php/Gamepad#Disable_joystick_from_controlling_mouse

    And if all this won’t help,if your games or applications can handle the joystick by itself, you could try to deinstall
    xserver-xorg-input-joystick.

    #32887
    Member
    Avatargerrygk

    @caprea:
    The content of this one (51-joystick.conf) looks exactly like that of 50-joystick.conf.
    Anyway, I’m going to try it in case anticapitalista’s tip won’t lead to success.

    #32890
    Member
    capreacaprea

    looks exactly like

    Yes it does but nevertheless one of them boots to x and the other one doesn’t.
    Hm, the word #support in the manjaro-forum is a link.

    #32891
    Member
    christophechristophe

    FWIW, I’ve been using this version of that file for quite a while now, and it boots to X, working as expected (no interference of moving the cursor with the joystick/gamepad). I found it somewhere on the internet, perhaps it’s the same as you found:

    #/etc/X11/xorg.conf.d/51-joystick.conf 
    Section "InputClass" 
         Identifier "joystick catchall" 
         MatchIsJoystick "on" 
         MatchDevicePath "/dev/input/event*" 
         Driver "joystick" 
         Option "StartKeysEnabled" "False" 
    #Disable mouse 
         Option "StartMouseEnabled" "False" 
    #support 
    EndSection

    Prohibit gamepad from moving mouse cursor in games

    (I had no idea, until now, that antiX had that file in /usr/share/X11/xorg.conf.d. I’ve been using this other one for many months now successfully.)

    #32942
    Member
    Avatargerrygk

    Looks the same except for the comment in line 1, and the “disable mouse” and “support” comments / headings in own lines. I’ve now copied this content to my 51-joystick.conf file. The test will be executed shortly…

Viewing 15 posts - 16 through 30 (of 33 total)
  • You must be logged in to reply to this topic.