mpv & external subs (antiX-base)

Forum Forums New users New Users and General Questions mpv & external subs (antiX-base)

This topic contains 50 replies, has 3 voices, and was last updated by andfree Mar 16-12:20 am.

Viewing 15 posts - 16 through 30 (of 51 total)
  • Author
    Posts
  • #7592
    Member
    linuxdaddy
    linuxdaddy

    I’m glad the codepage did the trick on that for mpv. As for lighter weight than vlc,?…I
    know that totem and xine can play subtitles but not sure how many dependencies they pull
    or the performance. I do know that xine-console and libxine2-console packages let you
    watch videos in a terminal.

    Linux = Many kinds, shapes, and sizes of computers to come
    together to create the ultimate cure for curiosity, boredom,
    creativity, and asylum. 🙂
    Whether new, used, young, or ancient.

    #7609
    Member

    andfree

    As regards the second laptop (the one with the higher version of gl), there are not dependency problems, “suggests”, missing dependencies or recommends.
    The already installed libegl package is the latest version (13.0.6-1+b2) of libegl1-mesa.
    I don’t know about xvideo, but I see already installed the latest libxv1 & libxmc1.
    I installed libvdpau-va-gl1 & liblavfile-2.1-0.

    There’s not a xorg.conf file in the /etc/X11/ folder. There’s a xorg.conf.in file, containing this entry:

    Section "DRI"
        Mode 0666
    EndSection

    The terminal output:

    $ mpv --sub-codepage=cp1253 Stranger-Than-Paradise-1984.mp4
    Playing: Stranger-Than-Paradise-1984.mp4
    [lavf] Using subtitle charset: cp1253
     (+) Video --vid=1 (*) (h264)
     (+) Audio --aid=1 --alang=eng (*) (aac)
     (+) Subs  --sid=1 'Stranger-Than-Paradise-1984.srt' (subrip) (external)
    libEGL warning: DRI2: failed to authenticate
    [vo/opengl] Suspected software renderer or indirect context.
    [vo/opengl] Suspected software renderer or indirect context.
    Failed to open VDPAU backend libvdpau_nvidia.so: cannot open shared object file: No such file or directory
    [vo/vdpau] Error when calling vdp_device_create_x11: 1
    [vo/xv] No Xvideo support found.
    [vo/sdl] Using opengl
    [lavf] Edit lists are not correctly supported (FFmpeg issue).
    AO: [alsa] 48000Hz stereo 2ch float
    VO: [sdl] 1280x720 yuv420p
    AV: 00:00:00 / 01:29:03 (0%) A-V:  0.223
    
    Audio/Video desynchronisation detected! Possible reasons include too slow
    hardware, temporary CPU spikes, broken drivers, and broken files. Audio
    position will not match to the video (see A-V status field).

    Thanks for the help. If I haven’t luck with mpv at the end, I’ll perhaps give a try to xine or totem.

    #7622
    Member
    linuxdaddy
    linuxdaddy

    ok. /etc/X11/xorg.conf don’t exist in modern distros, but it will get used if you create one
    I’m not sure why your output is showing nvidia module “Failed to open VDPAU backend libvdpau_nvidia.so:”
    since you have ATI video chip, if the noveau or nvidia vdpau packages are installed…get rid of them on
    your second laptop they will interfere with ati on the libvdpau-va-gl1.

    Linux = Many kinds, shapes, and sizes of computers to come
    together to create the ultimate cure for curiosity, boredom,
    creativity, and asylum. 🙂
    Whether new, used, young, or ancient.

    #7628
    Member

    andfree

    Do you mean to remove both libvdpau-va-gl1 & libvdpau1?
    And what I should write in the xorg.conf file that I’ll create?

    #7641
    Member

    andfree

    About the first laptop (older gl):

    1) I gave a try to xine. I installed xine-console and all the dependencies (libaa1, libc6, libcaca0, libxine2, libxine2-console), but:

    $ xine Stranger-Than-Paradise-1984.mp4
    bash: xine: command not found
    
    $ xine-console Stranger-Than-Paradise-1984.mp4
    bash: xine-console: command not found
    
    $ xine
    bash: xine: command not found
    
    $ xine-console
    bash: xine-console: command not found

    2) I also tried with totem, but:

    $ totem Stranger-Than-Paradise-1984.mp4
    
    (totem:4186): Cogl-WARNING **: driver/gl/cogl-pipeline-opengl.c:932: GL error (1280): Invalid enumeration value
    
    ** Message: Missing plugin: gstreamer|1.0|totem|H.264 (High Profile) decoder|decoder-video/x-h264, level=(string)4.1, profile=(string)high (H.264 (High Profile) decoder)
    ** Message: Automatic missing codec installation not supported (helper script missing)
    • This reply was modified 11 months, 2 weeks ago by andfree.
    #7647
    Member
    linuxdaddy
    linuxdaddy

    “libvdpau-va-gl1 & libvdpau1” are the right ones..I meant make sure that none of the -nvidia packages
    are installed on the ati one for the vdpau and gl or egl.
    console xine installs
    /usr/bin/aaxine
    /usr/bin/cacaxine
    /usr/bin/fbxine
    so you would type aaxine or cacaxine not xine-console.

    in xorg.conf you could copy the xorg.conf.in as a template and edit that one, making sure that
    the Driver “@@XMODULE@@” line has the right driver listed.
    It would say Driver “radeon” or Driver “ati” for your second one. otherwise

    If your able to open a root session in “ctrl-alt-f2 or f3” log in as root and
    type “init 3” to shutdown X and then run “X -configure” and that will create a /etc/xorg.conf file.
    then you would type “init 5” to restart X. or could type reboot.
    X will restart on “ctrl-alt-f7”
    Your out of luck on Totem…it saying not high enough gl version just like mpv did.

    Linux = Many kinds, shapes, and sizes of computers to come
    together to create the ultimate cure for curiosity, boredom,
    creativity, and asylum. 🙂
    Whether new, used, young, or ancient.

    #7652
    Member

    andfree

    No luck with aaxine & cacaxine commands on the first laptop:

    $ aaxine Stranger-Than-Paradise-1984.mp4
    This is xine (aalib ui) - a free video player v0.99.9
    (c) 2000-2004 by G. Bartsch and the xine project team.
    Built with xine library 1.2.6 (1.2.6).
    Found xine library version: 1.2.6 (1.2.6).
    dlopen() failed: libX11.so: cannot open shared object file: No such file or directory
    main: audio driver oss failed
    XIO:  fatal IO error 11 (Resource temporarily unavailable) on X server ":0.0"
          after 753 requests (753 known processed) with 0 events remaining.


    $ cacaxine Stranger-Than-Paradise-1984.mp4
    This is xine (caca ui) – a free video player v0.99.9
    (c) 2000-2004 The xine Team.
    Built with xine library 1.2.6 (1.2.6).
    Found xine library version: 1.2.6 (1.2.6).
    dlopen() failed: libX11.so: cannot open shared object file: No such file or directory
    main: audio driver oss failed
    [xcb] Unknown sequence number while processing queue
    [xcb] Most likely this is a multi-threaded client and XInitThreads has not been called
    [xcb] Aborting, sorry about that.
    cacaxine: ../. ./src/xcb_io.c:259: poll_for_event: Assertion `!xcb_xlib_threads_sequence_lost’ failed.
    Aborted

    xorg.conf.in for the first laptop says:

    Section "Device"
        Identifier  "Card0"
        Driver "@@XMODULE@@"
        BoardName "unknown"
    Section "Device"
        Identifier  "Card1"
        Driver "@@XMODULE@@"
        BoardName "unknown"

    I’ll write about the second laptop later.

    • This reply was modified 11 months, 2 weeks ago by andfree.
    • This reply was modified 11 months, 2 weeks ago by andfree.
    • This reply was modified 11 months, 2 weeks ago by andfree.
    #7664
    Member
    linuxdaddy
    linuxdaddy

    you had an extra spce in there before the /src there should be
    no space between the dots.

    Linux = Many kinds, shapes, and sizes of computers to come
    together to create the ultimate cure for curiosity, boredom,
    creativity, and asylum. 🙂
    Whether new, used, young, or ancient.

    #7665
    Member

    andfree

    Yes, I couldn’t post it without space, as I wrote here.

    #7666
    Member
    linuxdaddy
    linuxdaddy

    I’m not sure why libX11.so and xcb failed.
    I think the spam filter blocks the dot dot backslash

    Linux = Many kinds, shapes, and sizes of computers to come
    together to create the ultimate cure for curiosity, boredom,
    creativity, and asylum. 🙂
    Whether new, used, young, or ancient.

    #7674
    Member

    andfree

    Now, about the second laptop (ati):

    The latest nvidia-detect is the only nvidia relevant package that seems to be installed. Should I remove it?

    xorg.conf.in for the second laptop says the same with what I’ve posted above for the first laptop. Should I rename the driver for Card0 or Card1 in xorg.conf?

    #7675
    Member

    andfree

    xine failed on the second laptop, too:

    $ aaxine Stranger-Than-Paradise-1984.mp4
    This is xine (aalib ui) - a free video player v0.99.9
    (c) 2000-2004 by G. Bartsch and the xine project team.
    Built with xine library 1.2.6 (1.2.6).
    Found xine library version: 1.2.6 (1.2.6).
    dlopen() failed: libX11.so: cannot open shared object file: No such file or directory
    main: audio driver oss failed
    XIO:  fatal IO error 11 (Resource temporarily unavailable) on X server ":0.0"
          after 405 requests (405 known processed) with 0 events remaining.


    $ cacaxine Stranger-Than-Paradise-1984.mp4
    This is xine (caca ui) – a free video player v0.99.9
    (c) 2000-2004 The xine Team.
    Built with xine library 1.2.6 (1.2.6).
    Found xine library version: 1.2.6 (1.2.6).
    dlopen() failed: libX11.so: cannot open shared object file: No such file or directory
    main: audio driver oss failed
    [xcb] Unknown sequence number while processing queue
    [xcb] Most likely this is a multi-threaded client and XInitThreads has not been called
    [xcb] Aborting, sorry about that.
    cacaxine: ../. ./src/xcb_io.c:259: poll_for_event: Assertion `!xcb_xlib_threads_sequence_lost’ failed.
    Aborted

    The packages I’ve installed:

    libaa1 (version 1.4p5-44+b1)
    libgraphicsmagick-q16-3 (version 1.3.25-8)
    libmng1 (version 1.0.10+dfsg-3.1+b5)
    libvcdinfo0 (version 0.7.24+dfsg-0.2)
    libxine2 (version 1.2.6-1.3)
    libxine2-bin (version 1.2.6-1.3)
    libxine2-console (version 1.2.6-1.3)
    libxine2-ffmpeg (version 1.2.6-1.3)
    libxine2-misc-plugins (version 1.2.6-1.3)
    libxine2-plugins (version 1.2.6-1.3)
    xine-console (version 0.99.9-1.3)
    #7676
    Member

    andfree

    Totem on the second laptop: The audio seems to be OK, but the video player screen is all black.

    $ totem Stranger-Than-Paradise-1984.mp4
    
    ** (totem:4022): WARNING **: Couldn't register with accessibility bus: Did not receive a reply. Possible causes include: the remote application did not send a reply, the message bus security policy blocked the reply, the reply timeout expired, or the network connection was broken.
    ** Message: Missing plugin: gstreamer|1.0|totem|H.264 (High Profile) decoder|decoder-video/x-h264, level=(string)4.1, profile=(string)high (H.264 (High Profile) decoder)
    ** Message: Automatic missing codec installation not supported (helper script missing)
    
    (totem:4022): Gtk-WARNING **: Drawing a gadget with negative dimensions. Did you forget to allocate a size? (node slider owner GtkScale)
    #7685
    Member
    linuxdaddy
    linuxdaddy

    no leave nvidia-detect because it’ll try removing other things. Totem is missing plugins for h264/mp4
    video which I believe is handled by “gstreamer1.0-libav”
    as far as xorg.conf goes as long as card0 is in both sections it works.

    Linux = Many kinds, shapes, and sizes of computers to come
    together to create the ultimate cure for curiosity, boredom,
    creativity, and asylum. 🙂
    Whether new, used, young, or ancient.

    #7688
    Member
    linuxdaddy
    linuxdaddy

    update … from earlier when I wrote init 3 to shutdown X.
    It sould have been init 1. then X -configure will run

    Linux = Many kinds, shapes, and sizes of computers to come
    together to create the ultimate cure for curiosity, boredom,
    creativity, and asylum. 🙂
    Whether new, used, young, or ancient.

Viewing 15 posts - 16 through 30 (of 51 total)

You must be logged in to reply to this topic.