muted sound is not muted altogether

  • This topic has 4 replies, 3 voices, and was last updated Feb 1-2:26 pm by uxer.
Viewing 5 posts - 1 through 5 (of 5 total)
  • Author
    Posts
  • #38974
    Member
    uxer

    Whenever I mute my sound and system tray volume indicator turns crossed I still hear weak sound.

    Bonus question: Linux Mint distinguishes volumes for speakers and for headphones, while antiX has one level for both. How to get it separate?

    #38978
    Moderator
    ModdIt
    Helpful
    Up
    0
    :D

    Sound is controlled by the mixer, right click applet and set volumes as you wish.
    in the mixer.

    Bonus question, why ask things which are so simple, if you read a couple of minutes
    that is.

    #38999
    Forum Admin
    Dave
    Helpful
    Up
    0
    :D

    The weak sound is likely due to the volumeicon app only working with the master channel but the preamp channel still has an active value.
    For separation between speaker and headphones… this is probably due to antiX using alsa and Mint using pulse audio.
    I think it is possible to separate them in alsa as well. I have not idea how though.

    Computers are like air conditioners. They work fine until you start opening Windows. ~Author Unknown

    #39011
    Moderator
    ModdIt
    Helpful
    Up
    0
    :D

    Hi guys, this thread is not exactly inspiring.
    The sound applet included in AntiX calls “desktop-defaults-run -t alsamixer”, no rocket science or demands for
    sound distorting crappy Pulse audio involved.

    Alsamixer or alsamixer GUI allow full control of all available channels
    including headphones. Even with multiple soundcards.

    A right click on the task bar volume applet brings up a menu, select open mixer.
    You will not see all possibility’s unless you resize the window which comes up.

    In preferences of said applet you can map open mixer to the middle mouse button, setup hotkey for mute
    if your keyboard allows. Set mute to a mouse button.

    If you are not using the applet in taskbar Menu will have in most cases visible entrys for Alsamixer and/or alsamixergui.

    In short AntiX has all you need, in a full installation. Just have to use it.

    #51280
    Member
    uxer
    Helpful
    Up
    0
    :D

    Clarification: while muted, weak sound is present via headphones, whereas speakers are silent.

    The weak sound is likely due to the volumeicon app only working with the master channel but the preamp channel still has an active value.

    I need at least 1 pre-amp value to have sound — with 0 nothing is produced, even with full volume.
    While muted, the more pre-amp, the louder and dirtier is the sound from headphones.
    So you are right, Dave, and thank you for the hint.
    But again, headphones have this problem, speakers don’t.
    On Linux Mint headphones had not this problem.

    Probably, my initial question was not clear enough, but I insist that it is a bug (or a misconfiguration). It may be not antiX’ fault but Alsa’s or my hardware’s. Yet, the issue is there.

    Bonus question, why ask things which are so simple, if you read a couple of minutes
    that is.

    Hi guys, this thread is not exactly inspiring.
    The sound applet included in AntiX calls “desktop-defaults-run -t alsamixer”, no rocket science or demands for
    sound distorting crappy Pulse audio involved.

    Alsamixer or alsamixer GUI allow full control of all available channels
    including headphones. Even with multiple soundcards.

    A right click on the task bar volume applet brings up a menu, select open mixer.
    You will not see all possibility’s unless you resize the window which comes up.

    In preferences of said applet you can map open mixer to the middle mouse button, setup hotkey for mute
    if your keyboard allows. Set mute to a mouse button.

    If you are not using the applet in taskbar Menu will have in most cases visible entrys for Alsamixer and/or alsamixergui.

    In short AntiX has all you need, in a full installation. Just have to use it.

    Let me disagree. “desktop-defaults-run -t alsamixer” was much harder for me to understand than whatever I have had experience with in other distros. And I consider myself an advanced user (yet lazy one). I believe an average user would be scared away by “desktop-defaults-run -t alsamixer”, and since sound is crucial for a PC, that average user would be scared away from antiX.
    Yes, there are separate bars for Headphone and Speaker, but you need to adjust them manually each time or to adjusting Master channel each time.
    In Linux Mint it is done automatically: you plug your headphones, the volume switches to headphone-volume from the last headphone-time; you unplug headphones, the volume switches back to speakers-volume. Convenient. I miss it in antiX.

    Recap:
    1. muted sound is not muted altogether when using headphones
    2. speakers and headphones are different use-cases and their volumes should be automatically treated separately
    3. “desktop-defaults-run -t alsamixer” is far from being user-friendly

Viewing 5 posts - 1 through 5 (of 5 total)
  • You must be logged in to reply to this topic.