My video Camera has stopped working SOLVED

Forum Forums Official Releases antiX-21 “Grup Yorum” My video Camera has stopped working SOLVED

  • This topic has 28 replies, 7 voices, and was last updated May 18-6:55 am by caprea.
Viewing 15 posts - 1 through 15 (of 29 total)
  • Author
    Posts
  • #70549
    Member
    namida12

    Marked solved on posters request. Root cause of issue unknown. (Moddit)

    Logitech C0920 Camera has been my Sunday night video chat tool with family in Japan, Oregon, Colorado from here in Las Vegas. Video works but we can not set the unit as the sound card. I was able to hear them speak but had no sound in MX 21 and I Moved the camera and could not set the sound card in antix,

    C920:USB-Audio – HD Pro Webcam C920 – Works well in antiX 19.4-64 or MX 19.4-64

    I can see the device in antiX 21. Choosing the device it returns a message:
    Test failed
    (Could not connect to the selected device)
    Do you want to set the card again)

    Going to computer with Antix 19.4_64 it still works, never though to test with antix 21-b2 As we always used Ladies computer running MX-19.4_64, but I upgraded her machine on Tuesday. Did not have a working computer-setup to do our weekly family chat. I had to bring one from the storage room that still has antix-19.4 installed quickly to attach the Camera and have both audio and video…

    Was an interesting night going to dark storage room with no light and several bicycles to move to find the right computer… Would have made a grand movie event trying to chat with family in computers tonight…

    Does not work with antiX-21-b2-runit_x64-full Grup Yorum 21 August 2021 either. Found that computer quickly, had to go back and find another computer in the dark…

    We use Google video meet…

    JR

    • This topic was modified 7 months, 4 weeks ago by namida12.
    • This topic was modified 7 months, 4 weeks ago by namida12.
    • This topic was modified 1 month, 2 weeks ago by ModdIt.
    #70556
    Member
    ModdIt
    Helpful
    Up
    0
    ::

    Hi namida,
    no comparable device,
    on a victure action cam used as webcam I needed
    modprobe snd_usb_audio

    • This reply was modified 7 months, 4 weeks ago by ModdIt.
    #70879
    Member
    namida12
    Helpful
    Up
    0
    ::

    modprobe snd_usb_audio is this what was suggested?

    JR

    #70883
    Member
    ModdIt
    Helpful
    Up
    0
    ::

    modprobe snd_usb_audio

    Gave no response in console, i also did it with sudo as unsure but thought needed.

    The victure camers now works, set pc cam on device.
    I may be able to check a LogitechWebcam later, older model, need to borrow it.

    #70961
    Member
    namida12
    Helpful
    Up
    0
    ::

    I tried the solution mention for antix in this mx thread: https://forum.mxlinux.org/viewtopic.php?p=655875&hilit=Logitech+camera#p655875
    Run guvcview first do set up of camera and audio then quit. and then open video chat…

    Antix it fixed the last week problem family could not hear me speaking, but after running guvcview and setting up audio then I could not hear audio from any family connection.

    MX computer my lady is using it would not allow guvcview to run properly in a terminal and both camera and audio were never working correctly…

    Finished video on phone, but what a poor excuse compared to using a 34 inch computer screen. Phone only allows one connection/image at a time. Was sad as japan was displaying a picture album containing 30 year old images. At the same time 3 year old granddaughter was telling us about her adventure today, then cousin in UK was trying to explain the cold and phone is just to small for any type of a group chat…

    Need to fix antiX: the camera works, but no mic working from camera. Running guvcview first and then quitting allowed the microphone function to work, but I had no sound from others on my end… I have never used guvcview and do not know if it has separate microphone control and a sound control but did not see a separate controls while trying to connect during the video chat.

    $ guvcview
    GUVCVIEW: version 2.0.6
    V4L2_CORE: (UVCIOC_CTRL_MAP) Error: No such file or directory
    V4L2_CORE: (UVCIOC_CTRL_MAP) Error: No such file or directory
    V4L2_CORE: (UVCIOC_CTRL_MAP) Error: No such file or directory
    V4L2_CORE: (UVCIOC_CTRL_MAP) Error: No such file or directory
    V4L2_CORE: (UVCIOC_CTRL_MAP) Error: No such file or directory
    V4L2_CORE: (UVCIOC_CTRL_MAP) Error: No such file or directory
    V4L2_CORE: (UVCIOC_CTRL_MAP) Error: No such file or directory
    V4L2_CORE: (UVCIOC_CTRL_MAP) Error: No such file or directory
    V4L2_CORE: (UVCIOC_CTRL_MAP) Error: No such file or directory
    ALSA lib pcm_dmix.c:1108:(snd_pcm_dmix_open) unable to open slave
    ALSA lib pcm.c:2565:(snd_pcm_open_noupdate) Unknown PCM cards.pcm.rear
    ALSA lib pcm.c:2565:(snd_pcm_open_noupdate) Unknown PCM cards.pcm.center_lfe
    ALSA lib pcm.c:2565:(snd_pcm_open_noupdate) Unknown PCM cards.pcm.side
    ALSA lib confmisc.c:1281:(snd_func_refer) Unable to find definition 'cards.USB-Audio.pcm.hdmi.0:CARD=C920,AES0=4,AES1=130,AES2=0,AES3=2'
    ALSA lib conf.c:4568:(_snd_config_evaluate) function snd_func_refer returned error: No such file or directory
    ALSA lib conf.c:5047:(snd_config_expand) Evaluate error: No such file or directory
    ALSA lib pcm.c:2565:(snd_pcm_open_noupdate) Unknown PCM hdmi
    ALSA lib confmisc.c:1281:(snd_func_refer) Unable to find definition 'cards.USB-Audio.pcm.hdmi.0:CARD=C920,AES0=4,AES1=130,AES2=0,AES3=2'
    ALSA lib conf.c:4568:(_snd_config_evaluate) function snd_func_refer returned error: No such file or directory
    ALSA lib conf.c:5047:(snd_config_expand) Evaluate error: No such file or directory
    ALSA lib pcm.c:2565:(snd_pcm_open_noupdate) Unknown PCM hdmi
    ALSA lib confmisc.c:1281:(snd_func_refer) Unable to find definition 'cards.USB-Audio.pcm.modem.0:CARD=C920'
    ALSA lib conf.c:4568:(_snd_config_evaluate) function snd_func_refer returned error: No such file or directory
    ALSA lib conf.c:5047:(snd_config_expand) Evaluate error: No such file or directory
    ALSA lib pcm.c:2565:(snd_pcm_open_noupdate) Unknown PCM cards.pcm.phoneline:CARD=C920,DEV=0
    ALSA lib confmisc.c:1281:(snd_func_refer) Unable to find definition 'cards.USB-Audio.pcm.modem.0:CARD=C920'
    ALSA lib conf.c:4568:(_snd_config_evaluate) function snd_func_refer returned error: No such file or directory
    ALSA lib conf.c:5047:(snd_config_expand) Evaluate error: No such file or directory
    ALSA lib pcm.c:2565:(snd_pcm_open_noupdate) Unknown PCM cards.pcm.phoneline:CARD=C920,DEV=0
    ALSA lib confmisc.c:1281:(snd_func_refer) Unable to find definition 'cards.USB-Audio.pcm.modem.0:CARD=C920'
    ALSA lib conf.c:4568:(_snd_config_evaluate) function snd_func_refer returned error: No such file or directory
    ALSA lib conf.c:5047:(snd_config_expand) Evaluate error: No such file or directory
    ALSA lib pcm.c:2565:(snd_pcm_open_noupdate) Unknown PCM phoneline
    ALSA lib confmisc.c:1281:(snd_func_refer) Unable to find definition 'cards.USB-Audio.pcm.modem.0:CARD=C920'
    ALSA lib conf.c:4568:(_snd_config_evaluate) function snd_func_refer returned error: No such file or directory
    ALSA lib conf.c:5047:(snd_config_expand) Evaluate error: No such file or directory
    ALSA lib pcm.c:2565:(snd_pcm_open_noupdate) Unknown PCM phoneline
    ALSA lib pcm_dmix.c:1108:(snd_pcm_dmix_open) unable to open slave
    ALSA lib pcm_dmix.c:1108:(snd_pcm_dmix_open) unable to open slave
    ALSA lib pcm_dmix.c:1108:(snd_pcm_dmix_open) unable to open slave
    ALSA lib pcm_dmix.c:1108:(snd_pcm_dmix_open) unable to open slave
    ALSA lib pcm_dmix.c:1108:(snd_pcm_dmix_open) unable to open slave
    Cannot connect to server socket err = No such file or directory
    Cannot connect to server request channel
    jack server is not running or cannot be started
    JackShmReadWritePtr::~JackShmReadWritePtr - Init not done for -1, skipping unlock
    JackShmReadWritePtr::~JackShmReadWritePtr - Init not done for -1, skipping unlock
    demo@antix1:~
    

    modprobe snd_usb_audio <this did nothing tonight, or last week…

    Need some help…

    JR

    • This reply was modified 7 months, 3 weeks ago by namida12.
    • This reply was modified 7 months, 3 weeks ago by namida12.
    #71022
    Member
    namida12
    Helpful
    Up
    0
    ::

    Live Media – Trying to install again…

    $ inxi -F
    System:    Host: antix1 Kernel: 5.10.57-antix.1-amd64-smp x86_64 bits: 64 Desktop: IceWM 2.8.0 
               Distro: antiX-21-runit_x64-full Grup Yorum 30 October 2021 
    Machine:   Type: Desktop Mobo: ASRock model: B450M Pro4 serial: <superuser required> UEFI-[Legacy]: American Megatrends 
               v: P3.50 date: 07/18/2019 
    CPU:       Info: Quad Core model: AMD Ryzen 3 3200G with Radeon Vega Graphics bits: 64 type: MCP cache: L2: 2 MiB 
               Speed: 2534 MHz min/max: 1400/3600 MHz Core speeds (MHz): 1: 2534 2: 2940 3: 2952 4: 2940 
    Graphics:  Device-1: Advanced Micro Devices [AMD/ATI] Picasso driver: amdgpu v: kernel 
               Device-2: Logitech HD Pro Webcam C920 type: USB driver: snd-usb-audio,uvcvideo 
               Display: x11 server: X.Org 1.20.11 driver: loaded: amdgpu,ati unloaded: fbdev,modesetting,vesa 
               resolution: 2560x1440~60Hz 
               OpenGL: renderer: AMD Radeon Vega 8 Graphics (RAVEN DRM 3.40.0 5.10.57-antix.1-amd64-smp LLVM 11.0.1) 
               v: 4.6 Mesa 20.3.5 
    Audio:     Device-1: Advanced Micro Devices [AMD/ATI] Raven/Raven2/Fenghuang HDMI/DP Audio driver: snd_hda_intel 
               Device-2: Advanced Micro Devices [AMD] Family 17h HD Audio driver: snd_hda_intel 
               Device-3: Logitech HD Pro Webcam C920 type: USB driver: snd-usb-audio,uvcvideo 
               Sound Server-1: ALSA v: k5.10.57-antix.1-amd64-smp running: yes 
    Network:   Device-1: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet driver: r8169 
               IF: eth0 state: up speed: 1000 Mbps duplex: full mac: 70:85:c2:a3:6e:27 
    Drives:    Local Storage: total: 480.22 GiB used: 1.4 GiB (0.3%) 
               ID-1: /dev/nvme0n1 vendor: Western Digital model: WDS500G3XHC-00SJG0 size: 465.76 GiB 
               ID-2: /dev/sda type: USB vendor: PNY model: USB 2.0 FD size: 14.46 GiB 
    Swap:      ID-1: swap-1 type: partition size: 8 GiB used: 0 KiB (0.0%) dev: /dev/nvme0n1p3 
    Sensors:   System Temperatures: cpu: 37.5 C mobo: N/A gpu: amdgpu temp: 37.0 C 
               Fan Speeds (RPM): N/A 
    Info:      Processes: 182 Uptime: 1m Memory: 5.73 GiB used: 490.5 MiB (8.4%) Shell: Bash inxi: 3.3.06 
    demo@antix1:~
    
    #71065
    Moderator
    caprea
    Helpful
    Up
    0
    ::

    The drivers /modules are correct in antiX21

    Graphics:  Device-1: Advanced Micro Devices [AMD/ATI] Picasso driver: amdgpu v: kernel 
               Device-2: Logitech HD Pro Webcam C920 type: USB driver: snd-usb-audio,uvcvideo
                
    Audio:     Device-1: Advanced Micro Devices [AMD/ATI] Raven/Raven2/Fenghuang HDMI/DP Audio driver: snd_hda_intel 
               Device-2: Advanced Micro Devices [AMD] Family 17h HD Audio driver: snd_hda_intel 
               Device-3: Logitech HD Pro Webcam C920 type: USB driver: snd-usb-audio,uvcvideo 

    Do you have the same kernel installed on the working antiX19 like on the not working antiX21 ?

    #71174
    Member
    namida12
    Helpful
    Up
    0
    ::

    Sorry, that desktop went to the bay area this week. With antiX-21-runit_x64-full installed. Friend was here in Vegas and his apple died while he was here, he needed a computer when he arrived home, has large 55+ 4k TV and we got the desktop working with my 43 inch TV while he was here…
    I am charging my laptop now to see if the built in camera and Microphone will work.

    I just installed “Cheese” to see if I could record a video with sound.
    I can record video with cheese. No sound on recorded video…

    Opened mp4 video and system plays sound…
    I listen to the computer with headphones, so disconnected head phones and tried recording video again, no sound.

    Just phoned daughter and connected to google meeting I can hear her perfectly on head phones, but no audio from me… I do not have a Microphone with headset.
    I wonder if I have a ALSA volume control with USB connection?

    • This reply was modified 7 months, 2 weeks ago by namida12.
    #71180
    Member
    namida12
    Helpful
    Up
    0
    ::
    $ inxi -Fxyz
    System:
      Kernel: 5.10.57-antix.1-amd64-smp x86_64 bits: 64 compiler: gcc v: 10.2.1 
      Desktop: IceWM 2.8.0 
      Distro: antiX-21-runit_x64-full Grup Yorum 30 October 2021 
      base: Debian GNU/Linux 11 (bullseye) 
    Machine:
      Type: Desktop Mobo: ASRock model: B450M Pro4 serial: <filter> 
      UEFI-[Legacy]: American Megatrends v: P3.50 date: 07/18/2019 
    CPU:
      Info: Quad Core model: AMD Ryzen 3 3200G with Radeon Vega Graphics bits: 64 
      type: MCP arch: Zen rev: 1 cache: L2: 2 MiB 
      flags: avx avx2 lm nx pae sse sse2 sse3 sse4_1 sse4_2 sse4a ssse3 svm 
      bogomips: 28744 
      Speed: 2184 MHz min/max: 1400/3600 MHz boost: enabled Core speeds (MHz): 
      1: 2184 2: 2924 3: 2932 4: 2886 
    Graphics:
      Device-1: AMD Picasso driver: amdgpu v: kernel bus-ID: 07:00.0 
      Device-2: Logitech HD Pro Webcam C920 type: USB 
      driver: snd-usb-audio,uvcvideo bus-ID: 1-10:4 
      Display: x11 server: X.Org 1.20.11 driver: loaded: amdgpu,ati 
      unloaded: fbdev,modesetting,vesa resolution: 2560x1440~60Hz 
      OpenGL: renderer: AMD Radeon Vega 8 Graphics (RAVEN DRM 3.40.0 
      5.10.57-antix.1-amd64-smp LLVM 11.0.1) 
      v: 4.6 Mesa 20.3.5 direct render: Yes 
    Audio:
      Device-1: AMD Raven/Raven2/Fenghuang HDMI/DP Audio driver: snd_hda_intel 
      v: kernel bus-ID: 07:00.1 
      Device-2: AMD Family 17h HD Audio vendor: ASRock driver: snd_hda_intel 
      v: kernel bus-ID: 07:00.6 
      Device-3: Logitech HD Pro Webcam C920 type: USB 
      driver: snd-usb-audio,uvcvideo bus-ID: 1-10:4 
      Sound Server-1: ALSA v: k5.10.57-antix.1-amd64-smp running: yes 
    Network:
      Device-1: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet 
      vendor: ASRock driver: r8169 v: kernel port: f000 bus-ID: 04:00.0 
      IF: eth0 state: up speed: 1000 Mbps duplex: full mac: <filter> 
    Drives:
      Local Storage: total: 465.76 GiB used: 171.46 GiB (36.8%) 
      ID-1: /dev/nvme0n1 vendor: Western Digital model: WDS500G3XHC-00SJG0 
      size: 465.76 GiB temp: 31.9 C 
    Partition:
      ID-1: / size: 14.66 GiB used: 5.34 GiB (36.4%) fs: ext4 dev: /dev/nvme0n1p2 
      ID-2: /home size: 434.06 GiB used: 166.12 GiB (38.3%) fs: ext4 
      dev: /dev/nvme0n1p4 
    Swap:
      ID-1: swap-1 type: partition size: 8 GiB used: 0 KiB (0.0%) 
      dev: /dev/nvme0n1p3 
    Sensors:
      System Temperatures: cpu: 30.2 C mobo: N/A gpu: amdgpu temp: 30.0 C 
      Fan Speeds (RPM): N/A 
    Info:
      Processes: 217 Uptime: 1d 13h 59m Memory: 5.73 GiB used: 996.2 MiB (17.0%) 
      Init: runit runlevel: 2 Compilers: gcc: 10.2.1 Packages: 1696 Shell: Bash 
      v: 5.1.4 inxi: 3.3.06 
    green621@antix621:~
    #71203
    Member
    Xecure
    Helpful
    Up
    0
    ::

    It is not the antiX way, but you may be interested in installing pipewire (https://www.antixforum.com/forums/topic/pipewire-to-manage-audio-in-antix-21/), instead of fighting ALSA. ALSA is great for efficient, lightweight and better audio quality, but pulseaudio, pipewire or jack make it easier to manage audio input/output.

    antiX Live system enthusiast.
    General Live Boot Parameters for antiX.

    #71230
    Member
    ModdIt
    Helpful
    Up
    0
    ::

    Hi Namida, you could also try wire on linux.

    As a backup many modern TV can show the phone screen as is often possible with computer or laptop.

    Below may be of use to you, I think this howto came from PPC,

    How to mirror your android device’s on your antiX computer screen:
    Note: this does not require the android device to be rooted

    1- There’s an application, available in the Repository: scrcpy (that requires “adb” to work). You’ll have to install it, using Synaptic or the terminal:

    sudo apt install scrcpy adb android-sdk-platform-tools-common
    #android-sdk-platform-tools-common provides udev rules, without that you will need to have root rights to use adb.
    2- Make sure your Android device has “USB debugging” activated ( You have to first activate the “Developer mode”- Example, in Android 10: Settings > About Phone > Software Information > Tap 7 times in “Android Build”; To activate “USB debugging”: Settings > Developer Settings “USB debugging”.
    3- Connect your Android device to your computer, using a USB cable.
    4- Launch, from menu > Accessories , from the terminal or from a “run” window: command: scrcpy
    5- If needed, authorise access on your android device’s screen, if you haven’t done so to that particular computer. After doing that, run following commands
    in terminal: adb kill-server && scrcpy

    Now, after the initial configuration (steps 1 and 2), every time you want to mirror your android device, simply do steps 3 and 4 (and also 5, if needed).

    Note: you can use your mouse and keyboard as android input devices, while using scrcpy!

    Tips: there are many command line options. Very useful ones:
    “scrcpy -S” – mirrors your android device on your computer screen with the device’s screen off
    “scrcpy -f” – mirrors the android device on full screen.

    OT Info for all readers:
    ADB is also very useful allowing to to debloat a non rooted phone. Just be careful which packages you choose,
    make a major mistake and you might have to factory reset the phone. On a non rooted phone you are just making applications unavailable for user0
    not actually removing them. You can also reinstall for user0, as long as you can accesss the device using adb shell that is.

    You can really brick a rooted phone so be especially cautios if you debloat one. XDA Developers site is your friend :-).

    • This reply was modified 7 months, 2 weeks ago by ModdIt.
    • This reply was modified 7 months, 2 weeks ago by ModdIt.
    #71624
    Member
    namida12
    Helpful
    Up
    0
    ::

    Latest up date: I pulled my HP envy 17 with an Intel cpu out of case charged it up, and it would not boot Antix 21 runit_x64, but it boots easily with MX 21 full. I ran from Flash drive for video chat with family tonight using mx-21, and wired internet connection but I will burn a standard antiX 64 bit version and see if that will boot, tomorrow…

    Crazy, first time for me to have trouble with antiX in my Ryzen desktop computer. Not booting Antix 21 runit_x64 in the laptop was also a surprise…

    I will search and see if I can find another logitech webcam, I can borrow and test, to see if it is my microphone that has gone bad, or if it is the runit verson that has the problem with the Logitech C920 version. The runit version is perceivable faster on Ryzen 3 3200G desktop, reason I have been running that version…

    JR

    #72050
    Member
    namida12
    Helpful
    Up
    0
    ::

    Could not find a neighbor that had an external camera to see if it was my unit and not the computer or camera that had gone bad.
    Nothing cheap to purchase on Craigslist or eBay.

    Since the sound on the logitech camera is not great any way, is anyone using a podcast set up in antix that might solve the microphone loss I am experiencing with the C920?

    Blue Yeti and Nano model – seem to be popular does anyone have this set-up?

    JR

    #82627
    Member
    namida12
    Helpful
    Up
    0
    ::

    Update: Ordered another Logitech C920 Camera and discovered the microphone does not work does not work either.

    Windows 10 test on both (my old one, and newly arrived Logitech HD Pro Webcam C920) both worked well in Zoom, Google Meet, and I was able to make a video with sound. Came home and can not get sound working with antiX-21-runit_x64-full Grup Yorum 30 October 2021,

    Have tried all USB connectors on this desktop system, thinking maybe a hardware problem…

    Attention: ModdI: Have not tried line as Google Meet is what everyone uses for the family video…

    #82700
    Member
    marcelocripe
    Helpful
    Up
    0
    ::

    Windows 10 test on both (my old one, and newly arrived Logitech HD Pro Webcam C920) both worked well in Zoom, Google Meet, and I was able to make a video with sound. Came home and can not get sound working with antiX-21-runit_x64-full Grup Yorum 30 October 2021

    Namida12, have you tried installing pulseaudio in antiX to get the sound from the microphone?
    Some devices or programs start working after pulseaudio is installed.

    To enable pulseaudio, open the terminal and apply the command:

    pulseaudio -D &

    To disable pulseaudio, open the terminal and apply the command:

    pulseaudio -k

    These PPC teachings can work with the camera microphone.

    marcelocripe
    (Original text in Brazilian Portuguese language)

    – – – – –

    Namida12, você tentou instalar o pulseaudio no antiX para obter o som do microfone?
    Alguns dispositivos ou programas começam a funcionar após a instalação do pulseaudio.

    Para ativar o pulseaudio, abra o terminal e apliquei o comando:

    pulseaudio -D &

    Para desativar o pulseaudio, abra o terminal e apliquei o comando:

    pulseaudio -k

    Estes ensinamentos do PPC podem funcionar com o microfone da câmera.

    marcelocripe
    (Texto original em idioma Português do Brasil)

Viewing 15 posts - 1 through 15 (of 29 total)
  • You must be logged in to reply to this topic.