[Solved] need help with HP LaserJet Printer

Forum Forums General Hardware [Solved] need help with HP LaserJet Printer

This topic contains 3 replies, has 2 voices, and was last updated by delix02 Feb 13-3:53 am.

Viewing 4 posts - 1 through 4 (of 4 total)
  • Author
    Posts
  • #6479
    Member

    delix02

    Hi !
    At the moment I have some problems with the installation of a HP LaserJet 2100 printer. The system here is an antiX-17 with testing repos. The printer is connect with the PC via WLAN.
    So, this is what I did and what I got :
    1. I opened the ControlCentre and then the hardware section. The screenshot shows the printer section with a missing icon. Clicking on the icon or the text opens nothing.
    2. So I started Firefox and with the URL localhost:631 the CUPS administration interface. I logged in as root and started the search for a new printer. Here I got a PDF printer and the HP LaserJet2100. That means the printer is connected and identified correctly. I select HP as manufacturer and then I get a FULL list of HP printers (see 2nd screenshot). I select one of the many (sub-)models of the LaserJet 2100 series. Then I click the “add printer” button and get returned to the main printer administration page of CUPS. However, when I checked the added printers, the LaserJet is not listed at all.
    The error log of CUPS shows a single line (see screenshot 3) :
    [cups-deviced] PID 4052 (gutenprint52+usb) stopped with status 1!

    3. I reinstalled all printer-driver- packages, hplip and all system-config-printer- packages but saw no changes. Same after a reboot.
    4. I started an antiX live session from an usb stick with a freshly downloaded iso file. Here I do have the icon of the printer section in the ControlCentre and when I use the browser interface for the CUPS administration I get a PRESELECTED list of the HP printers with those matching the 2100 series on top. When I click the “add printer” button I get the printer in the list of available printers and it is working perfectly.

    So, I guess there is something broken or missing in the installed system.
    Any hints and tricks ?

    • This topic was modified 8 months, 1 week ago by delix02.
    #6492
    Member
    caprea
    caprea

    What happens if you type in terminal

    system-config-printer

    Hmm,you are also missing backlight-control in control-centre under hardware.

    • This reply was modified 8 months, 1 week ago by caprea.
    #6508
    Member

    delix02

    thx for the help!

    Traceback (most recent call last):
      File "/usr/share/system-config-printer/system-config-printer.py", line 84, in <module>
        import jobviewer
      File "/usr/share/system-config-printer/jobviewer.py", line 57, in <module>
        gi.require_version('GnomeKeyring', '1.0')
      File "/usr/lib/python3/dist-packages/gi/__init__.py", line 130, in require_version
        raise ValueError('Namespace %s not available' % namespace)
    ValueError: Namespace GnomeKeyring not available

    I checked with Synaptic for GnomeKeyring packages.
    libgnome-keyring0 and libgnome-keyring-common are installed.

    I run apt-get autoremove several weeks ago and a lot of python2.7 packages were deleted then…..
    Maybe not all of them are replaced by python3 packages ?

    • This reply was modified 8 months, 1 week ago by delix02.
    • This reply was modified 8 months, 1 week ago by delix02.
    #6511
    Member

    delix02

    I found an ArchLinux solution for this error
    https://bugs.archlinux.org/task/52607

    I’ll give it a try and report the result then.
    However, don’t know whether it is safe……

    EDIT : the workaroud solves the system-config-printer issue.

    Ignore the attached screenshot – this error came form a handling error….

    I don’t know why — but the problem seems to be solved now. The printer driver is installed and printig works !!!

    • This reply was modified 8 months, 1 week ago by delix02.
    • This reply was modified 8 months, 1 week ago by delix02.
    Attachments:
Viewing 4 posts - 1 through 4 (of 4 total)

You must be logged in to reply to this topic.