Nicotine-plus soulseek client

Forum Forums Official Releases antiX-21/22 “Grup Yorum” Nicotine-plus soulseek client

  • This topic has 0 replies, 1 voice, and was last updated Nov 23-3:16 pm by dirkd.
Viewing 1 post (of 1 total)
  • Author
    Posts
  • #71585
    Member
    dirkd

      This package has been removed from the debian bullseye repos, presumably because of unmet dependencies. Fortunately it can also be installed as a python package with pip3. A minor drawback is that has a Qt-look, in stead of GTK. All it takes are the following commands (with sudo!)

      sudo apt install gir1.2-gtk-3.0 python3-gi python3-gdbm
      sudo pip3 install nicotine-plus

      You may have to install the pip package first, if you don’t have it already. On my first try I forgot the sudo in the second command, and although it’s not strictly necessary, I found it rather difficult to start the program. Using sudo is definitely the way to do it.

      On the github page of Nicotine-plus you can find instructions to add a custom PPA (extra repository, outside of debian) or to download a .deb package. I’m not to keen on adding PPA’s (bad experiences in the past), and I didn’t test the .deb package.

    Viewing 1 post (of 1 total)
    • You must be logged in to reply to this topic.