No GUI in antiX 19

  • This topic has 14 replies, 7 voices, and was last updated Dec 1-2:03 pm by Xecure.
Viewing 15 posts - 1 through 15 (of 15 total)
  • Author
    Posts
  • #46160
    Member
    Avatarjijojosephk

    I’m trying to install antiX in a pretty old system. Compaq Presario 5000 to be precise. It is almost 20 years old and having 256 MB RAM and Pentium 3 processor on board. It’s having Windows XP running currently. During the boot from the installation medium, I’m not getting GUI installer but CLI. I still completed the installation. Upon reboot after installation it still shows only command line interface. During boot up there is a failed step which is related to X11. Is it really possible to install antiX on this system? I was curious when I found antiX can run on 256 MB machines as well. Any suggestions are greatly appreciated.

    Log: http://paste.debian.net/1174813

    #46162
    Moderator
    AvatarBobC

    The graphics card is no longer supported by Xorg. If you try antiX 16 or 17 it might work with one of those. You might find a way around that, but not without a big effort.

    #46163
    Member
    Avatarseaken64

    Yes, antiX will work on such a system. I have it running on similar equipment. But BobC is likely correct in that the video graphics is not supported in the current Debian on which antiX is based. You may be able to get past that with a little effort.

    If I were you I would at least temporarily try installing antiX-17.4, and if that does the same as version 19.3 then try antiX-16.3. You may get antiX-16 or 17 working but you may want to work at getting version 19 working since support will expire for those older versions (antiX-16 is already EOL)

    In antiX-19 try the Safe Graphics option to see if the Vesa driver will work for you.

    You can also use cheat codes on the boot instructions for Grub to load different modules/drivers that may work, along with generating an Xorg.conf file to direct the system to what driver and specs to use.

    You could also try other distros to see if they work better. Try Puppy for instance. If they work you can get some clues as to how to set up antiX/Debian.

    If you can add some RAM it would be helpful. But I do have a couple of systems running 256MB of RAM. 512MB would be better.

    Seaken64

    #46164
    Member
    Avatarseaken64

    Please share your system info. At the console you can use the command “sudo inxi -Fxz” (no quotes). It will ask for your password. Supply it and you will see the output to screen. You can save the output to a text file or take a picture, or type the relevant info. We need to see your graphics card info.

    to save output to a text file do this:
    sudo inxi -Fxz -> inxi.txt
    Oops, that was from my DOS memory. We may need help from someone else if you can’t figure out how to copy the output to a file. Anyone?

    OK, try this command instead
    sudo inxi -Fxz -c 0 > inxi_inf.txt

    You can use mc to copy it to a floppy or USB to transfer to another machine. mc is a text based file manager and should be installed in your console system already.

    Seaken64

    • This reply was modified 4 months, 2 weeks ago by seaken64.
    • This reply was modified 4 months, 2 weeks ago by seaken64.
    • This reply was modified 4 months, 2 weeks ago by seaken64.
    #46168
    Moderator
    AvatarBobC

    If the machine is unaltered, the standard video card is an nVidia NV11. An ATI Radeon AGP 4x card would likely work in it and is supported. Realistically, if he is going to use the machine the memory should also be upgraded to 768 mb.

    https://www.elhvb.com/mobokive/archive/compaq/Presario/Presario%2050xxUS/5000us/5000USQuickSpecs.html

    Just my guess

    #46169
    Member
    linuxdaddylinuxdaddy

    hi jijojosephk,

    you could try xecure iso from the sis/via thread as it has the older xorg on it
    next beta2 iso

    also you are might be in luck as I have some older intel boards but I think they
    are 845 not 810 ones like yours. I have one 815 but not sure it even works.

    • This reply was modified 4 months, 2 weeks ago by linuxdaddy. Reason: corrected it
    • This reply was modified 4 months, 2 weeks ago by linuxdaddy.

    Normal == 🙂
    depends on the surrounding crowd ?!

    #46176
    Member
    Avatarjijojosephk

    Thanks everyone for the responses. For me safe graphics didn’t work either. Please find the log of inxi -Fxz -c 0 below:

    log

    Thanks in advance,
    Jijo Joseph

    #46179
    Moderator
    AvatarBobC

    Looks like linuxdaddy was right and its not nVidia. Sorry, I can’t be of any help. Did you try Xecure’s ISO?

    Graphics:
    Device-1: Intel 82810E DC-133 Graphics vendor: Compaq driver: N/A
    bus ID: 00:01.0
    Display: server: X.org 1.20.4 driver: none
    unloaded: fbdev,modesetting,vesa tty: 80×25
    Message: Advanced graphics data unavailable in console for root.

    #46192
    Moderator
    capreacaprea

    All modern kernels use the modesetting driver instead of the intel-driver. Old intel cards often go better with intel.
    If you get an old antiX-version or the iso from Xecure to boot, what you could try is to force the intel driver over the default modesetting on your installed system.

    Create this text file on the installed system
    /etc/X11/xorg.conf.d/20-intel.conf

    with content:

    Section "Device"   
       Identifier  "Intel Graphics"
       Driver      "intel"
    #  Option      "AccelMethod" "uxa"  #could also use the default "sna"
       Option      "TearFree"     "true"
    EndSection

    The acceleration method line is might needed or not.

    Here’s a link to older versions
    https://sourceforge.net/projects/antix-linux/files/old/

    antix 13.2 should definitely boot

    Edit: I totally missed that, you can get to the command-line. So you can create the file from there with
    sudo touch /etc/X11/xorg.conf.d/20-intel.conf

    • This reply was modified 4 months, 2 weeks ago by caprea.
    #46195
    Moderator
    AvatarModdIt

    Might be worth taking a look inside, if an AGP slot is available adding a graphics card would be
    a big help.

    Looks like a service manual is available here, I did not download it but the link was live.
    https://all-guidesbox.com/download/1035739/compaq-presario-5000-series-maintenance-and-service-manual-217.html

    #46232
    Member
    linuxdaddylinuxdaddy

    also check in the bios if you can increase the video memory to at least the 8mb setting
    I believe it’s the delete key when you turn it on. If not common ones are f1 f2 and f10
    keys. the older intel motherboards boards often had a setting in the bios to change it.

    Normal == 🙂
    depends on the surrounding crowd ?!

    #46234
    Member
    Avatarseaken64

    I tracked down my old threads about getting antiX-17 to work with my Compaq P-III. My video card was an AGP card, an nvidia GeForce2. But I think the solution for your P-III will be something similar. BitJam’s explanation of modules and the kernel are good clues to sorting this out. Give these a read.

    video better in v16 than in v17?


    https://forum.mxlinux.org/viewtopic.php?f=40&t=48054&p=480533&hilit=nouveau#p480533

    Seaken64

    #46246
    Member
    Avatarjijojosephk

    Thank you again. I created a xorg.conf file inside /etc/X11. Initially I gave driver as ‘i810’ without any result. But later I’ve given intel and it worked when I use startx command. slim does show the same error and every boot ends up in command line as slim fails still. I’ll have to enter ‘startx’ to have GUI session. How can I see GUI during boot without explicitly entering any commands? I’m yet to try Xecure’s ISO.

    #46250
    Moderator
    AvatarBobC

    I don’t know if this still works, but try adding a space and then
    xorg=intel
    To the end of the boot command line

    #46254
    Member
    XecureXecure

    Probably using these command (only for live system I think) will help. If this problem is related to the latest intel graphics firmware, then not even my iso will boot properly.

Viewing 15 posts - 1 through 15 (of 15 total)
  • You must be logged in to reply to this topic.