No HDMI sound, Alsa mixer stuck at volume zero (0)

Forum Forums New users New Users and General Questions No HDMI sound, Alsa mixer stuck at volume zero (0)

  • This topic has 6 replies, 4 voices, and was last updated May 29-9:52 pm by rallan.
Viewing 7 posts - 1 through 7 (of 7 total)
  • Author
    Posts
  • #60358
    Member
    rallan

      This is a fresh install. HDMI video is good.

      Here is the inxi audio info:

      $ inxi -Axxx
      Audio:
      Device-1: NVIDIA High Definition Audio vendor: eVga.com.
      driver: snd_hda_intel v: kernel bus ID: 07:00.1 chip ID: 10de:0be3
      Device-2: AMD Family 17h HD Audio vendor: ASUSTeK driver: snd_hda_intel
      v: kernel bus ID: 09:00.3 chip ID: 1022:1457
      Sound Server: ALSA v: k4.9.0-264-antix.1-amd64-smp

      Note: the HDMI audio works fine on my MXLinux AHS 5.10 with this same hardware, same driver and an Alsa server (Sound Server: ALSA v: k5.10.0-4mx-amd64 ).

      Speaker-test on antiX passed only after I made some changes to asound.conf (see jpg attachment). I set the default to: card 0, device 7, type plug, slave.pcm “hdmi”

      When I use Alsa to set my sound card to nVidia then unmute it, the S/PDIF volumes for all four channels will not budge from zero. I tried the up arrow, the page-up button, and the Q, W and E keys. I cannot type in a number either. (see jpg attachemnt)

      “apulse firefox” opens the browser, when it goes to play sound I get the same long error report both before and after I amended the asound.conf file.(see jpg attachment)

      After all this, I tried to install PulseAudio but the repositories won’t let me. Nor will they let me re-install Alsa. sudo apt-get install alsa and sudo apt-get upgrade alsa do not work either.

      I’ve run out of ideas. What should I do?

      #60372
      Forum Admin
      Dave

        There is a select sound card program in the control centre. Have you tried running it and selecting the hdmi output?
        If it works this can be used to make configurations that switch using a udev rule on hdmi insert.

        Not sure with the pulse audio installation errors, this maybe has something to do with a systemd dependency? Could you post the output from terminal and also the /var/log/apt/history.log?

        Computers are like air conditioners. They work fine until you start opening Windows. ~Author Unknown

        #60381
        Member
        techcodie

          I found this helpful earlier today when I had HDMI sound issues. The last fix worked for me.

          https://www.antixforum.com/forums/topic/sound-issues

          As far as I know, s/pdif is hardware on/off. All volume is handled elsewhere. (check that with someone smarter. it’s just off the top of my head. probably read it somewhere today.)

          #60390
          Member
          rallan

            @techcodie As you know lack of HDMI sound after antiX installation is a long-standing issue. The solution you directed me to has been around the Web in one form or another for years; it automates what you see I did manually in the asoundConfChanges.jpg.

            I have identified at least three audio issues with this installation so far:

            1) the annoying default to “mute” on Alsa, that is corrected by just hitting the M key;

            2) the necessary amendment to the asound.conf file – in earlier antiX versions it was the asound. rc file or the asound.state file -to force antiX and Alsa to engage the HDMI sound driver and my nVidia card – it has always been aware of my card as seen in alsamixer.jpg, I can select it and deselect it in Alsa, Alsa just will not engage it. Once fixed this got the HDMI speaker-test working and re-assures me my driver is okay with antiX;

            thus I isolate a remaining audio issue – I haven’t ruled out the presence of more – to:

            3) Alsa not being able to increase the starting default sound volume from zero after it is de-muted. In the past I corrected this latter issue by installing PulseAudio, but now that won’t install!? I tried both package managers. And “apulse” – which is pre-installed – doesn’t work either, fresh out of the box!? I don’t see “pavucontrol” in any repositories either.

            Note: when I dealt with these audio issues in the past it was with an entirely different computer, after much effort and time I was able to get HDMI sound working.

            The help button on Alsa – F1 – is dead on my antiX system, works fine on my MXLinux system. Same computer. All other Alsa buttons are working.

            @Dave I will dig up the history.log, I had the presence of mind to set-up persistence with the installation so the log should be around. The output from the terminal is shown in the apulseFirefox.jpg screenshot. For some reason it is a bit cut-off at the margins, I will get you a fresh one.

            Alsa is having a problem: it prints a new – and long – error message to the terminal every time it receives a HDMI audio signal – but I can’t tell what it is from the terminal read-out.

            Is there an alternative sound server for antiX?

            #60397
            Moderator
            caprea

              It’s possible to install pulseaudio on antiX without any problems.If you have any, something else is wrong .
              Could you post the output from terminal
              sudo apt install pulseaudio

              #60436
              Forum Admin
              Dave

                Sorry I was not clear on what terminal output.
                I had meant the terminal output from trying to install pulseaudio the same as what caprea is asking for.

                Computers are like air conditioners. They work fine until you start opening Windows. ~Author Unknown

                #60491
                Member
                rallan

                  @Forum Admin There is no print-out to the terminal with any app installation attempt.

                  I tried to install PulseAudio from the antiX package installer; this precipitates a full system update – strange, I know – then the checkbox next to PulseAudio becomes unchecked. The app is not grayed-out, stays black.

                  The history.log never recorded anything. It’s not a persistence issue, all the files I created myself are still there.

                  I explored further – it’s a fresh install so I am still getting around to checking things out – and discovered no apps can be installed.

                  Maybe I had a faulty OS installation. I will install antiX on a different USB stick, then see what happens. Do a thorough check over of all installers – apt-get, too – and report back.

                Viewing 7 posts - 1 through 7 (of 7 total)
                • You must be logged in to reply to this topic.