[solved] no more audio after a bad shutdown

Forum Forums New users New Users and General Questions [solved] no more audio after a bad shutdown

Tagged: ,

  • This topic has 8 replies, 5 voices, and was last updated Oct 28-7:37 am by PPC.
Viewing 9 posts - 1 through 9 (of 9 total)
  • Author
    Posts
  • #121686
    Member
    CJoshua

      one day the electricity went out and when I turned on the pc with antix linux it had no more audio.
      it is nothing of my pc, I have a dualboot with windows 10 and the audio works correctly in windows.
      I have had many problems with the audio in antix lately, for example, playing minecraft and after about 30-40 minutes of playing the audio just disappears, disappearing also from the entire computer.
      these are things that have never happened to me in windows

      I think I have tried everything, use sudo service alsa-utils stop and sudo service alsa-utils start but it doesn’t work. I also tried to see if the volume was ok in alsamixer but everything is ok, the master and headphone are at 100 and I can’t hear anything in any game/video or youtube. And it’s not my headset, I’m sure it’s something that happened with the operating system that day the electricity went out.

      if it helps, the sound of my pc comes from my Asus P8H61-M LX2 R2.0 motherboard, I have a Pentium G630 and 2GB of ram ddr3 memory.

      another thing I can mention is that when installing antix I checked the autologin option, so when I start the pc sometimes the desktop is glitched with the default wallpapper, without conky and does not let me open anything.
      so I have to do ctrl + alt + backspace to restart icewm and be able to use the pc normally.

      can someone help me?

      #121690
      Moderator
      caprea

        Please post the output from terminal
        inxi -Fxz

        #121693
        Member
        CJoshua
          CJoshua@dhcppc0:~
          $ inxi -Fxz
          System:
            Kernel: 6.1.42-antix.1-amd64-smp arch: x86_64 bits: 64 compiler: gcc
              v: 13.2.0 Desktop: IceWM v: 3.4.2 Distro: antiX-23_x64-full Arditi del
              Popolo 27 August 2023 base: Debian GNU/Linux 12 (bookworm)
          Machine:
            Type: Desktop Mobo: ASUSTeK model: P8H61-M LX2 R2.0 v: Rev X.0x
              serial: <superuser required> UEFI: American Megatrends v: 1102
              date: 11/15/2012
          Battery:
            Device-1: sony_controller_battery_06:16:61:59:63:25 model: N/A charge: N/A
              status: charging
          CPU:
            Info: dual core model: Intel Pentium G630 bits: 64 type: MCP
              arch: Sandy Bridge rev: 7 cache: L1: 128 KiB L2: 512 KiB L3: 3 MiB
            Speed (MHz): avg: 1600 min/max: 1600/2700 cores: 1: 1600 2: 1600
              bogomips: 10801
            Flags: ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx
          Graphics:
            Device-1: Intel 2nd Generation Core Processor Family Integrated Graphics
              vendor: ASUSTeK driver: i915 v: kernel arch: Gen-6 bus-ID: 00:02.0
            Display: x11 server: X.Org v: 1.21.1.7 driver: X: loaded: intel
              dri: crocus gpu: i915 resolution: 1360x768~60Hz
            API: OpenGL v: 3.3 Mesa 22.3.6 renderer: Mesa Intel HD Graphics 2000 (SNB
              GT1) direct-render: Yes
          Audio:
            Device-1: Intel 6 Series/C200 Series Family High Definition Audio
              vendor: ASUSTeK 6 driver: snd_hda_intel v: kernel bus-ID: 00:1b.0
            Sound API: ALSA v: k6.1.42-antix.1-amd64-smp running: yes
            Sound Server-1: PipeWire v: 0.3.80 running: yes
          Network:
            Device-1: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet
              vendor: ASUSTeK P8 series driver: r8169 v: kernel port: e000 bus-ID: 05:00.0
            IF: eth0 state: up speed: 100 Mbps duplex: full mac: <filter>
          Drives:
            Local Storage: total: 473.31 GiB used: 30.03 GiB (6.3%)
            ID-1: /dev/sda vendor: Seagate model: ST500DM002-1BD142 size: 465.76 GiB
            ID-2: /dev/sdb type: USB vendor: Sony model: Storage Media size: 7.54 GiB
          Partition:
            ID-1: / size: 39.07 GiB used: 25.98 GiB (66.5%) fs: ext4 dev: /dev/sda5
            ID-2: /boot/efi size: 96 MiB used: 23.6 MiB (24.6%) fs: vfat
              dev: /dev/sda2
          Swap:
            ID-1: swap-1 type: file size: 2 GiB used: 0 KiB (0.0%) file: /swap/swap
            ID-2: swap-2 type: zram size: 368.4 MiB used: 87 MiB (23.6%)
              dev: /dev/zram0
            ID-3: swap-3 type: zram size: 368.4 MiB used: 84.2 MiB (22.9%)
              dev: /dev/zram1
          Sensors:
            System Temperatures: cpu: 40.0 C mobo: N/A
            Fan Speeds (RPM): N/A
          Info:
            Processes: 146 Uptime: 56m Memory: 1.56 GiB used: 1.31 GiB (84.0%)
            Init: SysVinit runlevel: 5 Compilers: gcc: 12.2.0 Packages: 2277 Shell: Bash
            v: 5.2.15 inxi: 3.3.25
          #121706
          Anonymous

            you can try to fix your audio problems:

            Update your audio drivers. You can use the Synaptic Package Manager to check for and install any available updates for your audio drivers. To do this, open Synaptic Package Manager and search for “alsa”. Then, select all of the alsa packages and click the “Mark for Installation” button. Finally, click the “Apply” button to install the updates.

            Reset your audio configuration. To do this, open a terminal window and type the following command:

            sudo alsa force-reload

            • This reply was modified 9 months ago by caprea. Reason: changed BBCodes
            #121708
            Anonymous

              Yes, that’s true

              #121725
              Member
              abc-nix

                sudo alsa force-reload

                This no longer works.

                What I see in your system is:

                Audio:
                Device-1: Intel 6 Series/C200 Series Family High Definition Audio
                vendor: ASUSTeK 6 driver: snd_hda_intel v: kernel bus-ID: 00:1b.0
                Sound API: ALSA v: k6.1.42-antix.1-amd64-smp running: yes
                Sound Server-1: PipeWire v: 0.3.80 running: yes

                Please check what version your system has for antix-pipewire-etras
                apt policy antix-pipewire-extras
                If it is version 0.2.1, try disabling and enabling pipewire using the toggle. If it isn’t, update the system first.
                To find toggle pipewire, searhc in the menu, or in app select or run from the terminal:
                toggle_pipewire
                toggle off, test sound to see if it works, and if it does, try toggling it ON again to see if now sound works.

                If sound doesn’t work yet, we will go into the terminal for more tests.

                #121847
                Member
                CJoshua

                  AAAAAAAAAAAND I’M GON’ TO CRY THANK YOU
                  i had version 0.1.2 of antix-pipewire-extras and after updating the system i have 0.2.1, so i did what you told me and it worked, i also restarted the pc to see if the solution was only temporary but everything works ok rn

                  also thanks for reminding me to update the system, I literally haven’t done it since I upgraded to antix23 (like 1 month and something without running sudo apt update && sudo apt-get dist-upgrade)

                  #121998
                  Member
                  abc-nix

                    Great. Hopefully this issue will no longer occur for any user after the recent updates.

                    #122006
                    Member
                    PPC

                      thanks for reminding me to update the system

                      I feel your pain- when I started using antiX, years ago, a very long time went by before I noticed it did not automatically update! Thankfully, now antiX Full editions do have a one click GUI way to check for updates (and perform the update itself). Just remember to click that “update” button at least once a week or so (I recommend every other day).

                      Off Topic- this is the reason why I recommended that antiX should have a tool that reminds users to check for updates every few days… Most of the time, having an up to date system saves users some pain (you see, some updates, like this pipewire related one, solve bugs).

                      P.

                    Viewing 9 posts - 1 through 9 (of 9 total)
                    • You must be logged in to reply to this topic.