No sound from headphones/speakers, possibly from hdmi

Forum Forums General Hardware No sound from headphones/speakers, possibly from hdmi

  • This topic has 12 replies, 6 voices, and was last updated Nov 13-10:02 am by ModdIt.
Viewing 13 posts - 1 through 13 (of 13 total)
  • Author
    Posts
  • #70235
    Member
    raakken

    Hi
    Just installed antix for the first time on an old computer someone gave me. Just have to start with that i don’t know if aux/jack infront or on the back works, but i had sound from the hdmi when i ran lubuntu.
    I love antix, but i’m used to more gui and use win on work, so i’m abit rusty
    here is what aplay -lL gives:
    null
    Discard all samples (playback) or generate zero samples (capture)
    default
    plugequal
    preamp
    duplex
    hw:CARD=Generic,DEV=3
    HD-Audio Generic, HDMI 0
    Direct hardware device without any conversions
    plughw:CARD=Generic,DEV=3
    HD-Audio Generic, HDMI 0
    Hardware device with all software conversions
    hdmi:CARD=Generic,DEV=0
    HD-Audio Generic, HDMI 0
    HDMI Audio Output
    dmix:CARD=Generic,DEV=3
    HD-Audio Generic, HDMI 0
    Direct sample mixing device
    **** List of PLAYBACK Hardware Devices ****
    card 0: Generic [HD-Audio Generic], device 3: HDMI 0 [HDMI 0]
    Subdevices: 1/1
    Subdevice #0: subdevice #0
    and here is alsabat:
    aplay -lL
    null
    Discard all samples (playback) or generate zero samples (capture)
    default
    plugequal
    preamp
    duplex
    hw:CARD=Generic,DEV=3
    HD-Audio Generic, HDMI 0
    Direct hardware device without any conversions
    plughw:CARD=Generic,DEV=3
    HD-Audio Generic, HDMI 0
    Hardware device with all software conversions
    hdmi:CARD=Generic,DEV=0
    HD-Audio Generic, HDMI 0
    HDMI Audio Output
    dmix:CARD=Generic,DEV=3
    HD-Audio Generic, HDMI 0
    Direct sample mixing device
    **** List of PLAYBACK Hardware Devices ****
    card 0: Generic [HD-Audio Generic], device 3: HDMI 0 [HDMI 0]
    Subdevices: 1/1
    Subdevice #0: subdevice #0

    and

    lspci | grep Audio
    00:01.1 Audio device: Advanced Micro Devices, Inc. [AMD/ATI] Wrestler HDMI Audio

    aplay -l
    **** List of PLAYBACK Hardware Devices ****
    card 0: Generic [HD-Audio Generic], device 3: HDMI 0 [HDMI 0]
    Subdevices: 1/1
    Subdevice #0: subdevice #0
    cat /proc/asound/card0/codec* | grep Codec
    Codec: ATI R6xx HDMI

    soundcard: generic:hda-intel something

    mind you, i don’t know what i’m doing:D
    Can someone help me get sound to my speakers/headphones? And, what info do you need?
    thanks Fredrik

    • This topic was modified 3 weeks, 3 days ago by raakken. Reason: more info
    #70282
    Member
    sybok
    Helpful
    Up
    0
    ::

    Please search the forum for sound issues because similar topics have already been discussed.
    Also, you could provide more information:
    No sound from all applications, from some only etc; it is advisable to specify your system specifics further by providing output of ‘inxi -Fxz’.

    If anything fails, you could install pulseaudio + pavucontrol, start pulseaudio ‘pulseaudio –start’, uncomment similar line in ‘~/.desktop-session/startup’.
    Some people prefer ‘alsa’ over ‘pulseaudio’, hence they may be able to guide you through the issue better.

    #70769
    Member
    raakken
    Helpful
    Up
    0
    ::

    Sorry, been away on job…
    I will try to search some more, though i didn’t find anything before i posted.
    inxi -Fxz gives:
    System:
    Kernel: 5.10.57-antix.1-amd64-smp x86_64 bits: 64 compiler: gcc v: 10.2.1
    Desktop: IceWM 2.8.0 Distro: antiX-21_x64-full Grup Yorum 31 October 2021
    base: Debian GNU/Linux 11 (bullseye)
    Machine:
    Type: Desktop Mobo: SAPPHIRE model: IPC-350DM1W v: 1AOVQ055
    serial: <filter> UEFI: American Megatrends v: 4.6.4 date: 10/30/2012
    Battery:
    Device-1: hidpp_battery_0
    model: Logitech Wireless Touch Keyboard K400 Plus charge: Full
    status: Discharging
    CPU:
    Info: Dual Core model: AMD E-350 bits: 64 type: MCP arch: Bobcat rev: 0
    cache: L2: 512 KiB
    flags: lm nx pae sse sse2 sse3 sse4a ssse3 svm bogomips: 6385
    Speed: 1550 MHz min/max: 800/1600 MHz Core speeds (MHz): 1: 1550 2: 1588
    Graphics:
    Device-1: AMD Wrestler [Radeon HD 6310] vendor: PC Partner Limited
    driver: radeon v: kernel bus-ID: 00:01.0
    Display: x11 server: X.Org 1.20.11 driver: loaded: ati,radeon
    unloaded: fbdev,modesetting,vesa resolution: 1680×1050~60Hz
    OpenGL:
    renderer: AMD PALM (DRM 2.50.0 / 5.10.57-antix.1-amd64-smp LLVM 11.0.1)
    v: 3.3 Mesa 20.3.5 direct render: Yes
    Audio:
    Device-1: AMD Wrestler HDMI Audio vendor: PC Partner Limited
    driver: snd_hda_intel v: kernel bus-ID: 00:01.1
    Sound Server-1: ALSA v: k5.10.57-antix.1-amd64-smp running: yes
    Network:
    Device-1: Marvell Yukon Optima 88E8059 [PCIe Gigabit Ethernet with AVB]
    vendor: PC Partner Limited / Sapphire driver: sky2 v: 1.30 port: e000
    bus-ID: 03:00.0
    IF: eth0 state: down mac: <filter>
    Device-2: ZyDAS ZD1211B 802.11g type: USB driver: zd1211rw bus-ID: 1-5:2
    IF: wlan0 state: up mac: <filter>
    Drives:
    Local Storage: total: 298.09 GiB used: 4.84 GiB (1.6%)
    ID-1: /dev/sda vendor: Seagate model: ST3320820AS size: 298.09 GiB
    Partition:
    ID-1: / size: 286.93 GiB used: 4.84 GiB (1.7%) fs: ext4 dev: /dev/sda2
    ID-2: /boot/efi size: 252 MiB used: 274 KiB (0.1%) fs: vfat dev: /dev/sda1
    Swap:
    ID-1: swap-1 type: partition size: 5.25 GiB used: 0 KiB (0.0%)
    dev: /dev/sda3
    Sensors:
    System Temperatures: cpu: 50.2 C mobo: N/A gpu: radeon temp: 49.0 C
    Fan Speeds (RPM): N/A
    Info:
    Processes: 140 Uptime: 5m Memory: 3.45 GiB used: 730.4 MiB (20.7%)
    Init: SysVinit runlevel: 5 Compilers: gcc: 10.2.1 Packages: 1575
    Shell: Bash v: 5.1.4 inxi: 3.3.06

    No sound from any application, neither from speakers(active) or headphones. Speakers tested with chromebook with gallium os, and works fine
    thanks

    #70771
    Member
    PPC
    Helpful
    Up
    0
    ::

    It’s basic, I know, but have you really tested if the output is not muted/set to 0? Test, running alsamixer…

    P.

    #70772
    Member
    raakken
    Helpful
    Up
    0
    ::

    I’m very new to this, only used debian, ubuntu, mint and some other with a bit more userfreindly gui:D
    I tried opening it, but i could only toggle on off for spfif, which i dont have on this computer
    tried playing a mp3 file, and the app said “couldn’t open audio”

    #70773
    Member
    linuxdaddy
    Helpful
    Up
    0
    ::

    Hi raakken,

    In the control center under hardware you can run the soundcard chooser
    and try switching between generic audio and hdmi audio and see if either
    option gives you sound output.

    A few thoughts for true freedom ......
    1: Where ever there is greed and selfishness, evil will always smile upon.
    2: Wherever there is sharing of ideas and caring, good prevails and thrives.
    I'll fight for the second thought before joining or doing for the first.
    A thought, quote and belief of yours truly : from Linuxdaddy.

    #70776
    Member
    raakken
    Helpful
    Up
    0
    ::

    Thanks for the tips linuxdaddy, and hi:)
    it just says i only have one card and cannot choose

    #70779
    Moderator
    caprea
    Helpful
    Up
    0
    ::

    You can try to install pulseaudio with package installer.
    menu > control-centre > software > package installer > audio > pulseaudio

    Afterwards you have to make the pulseaudio daemon autostart
    menu > control-centre > session > configuration of the user

    In the opening startup tab there’s the line

    ## Uncomment if using pulseaudio (you need to install it). Make sure it starts before volumeicon.
    #pulseaudio -D &

    change it to

    ## Uncomment if using pulseaudio (you need to install it). Make sure it starts before volumeicon.
    pulseaudio -D &

    Reboot

    #70822
    Member
    raakken
    Helpful
    Up
    0
    ::

    Thanks for the help. I did that, but nothing changes… Could it be the outputs are faulty?
    when i click “test sound”, nothing happens, just quickly shows the terminal for half a seconds and nothing…
    the mp3 player still says “couldn’t open audio”
    No volume control at the bottom right(but that could be normal to this distro)
    I like this distro so i don’t want to change right away, but i need sound:) have ordered a cheap usb sound card, so maybe that will sort things out?
    any further help would be appreciated

    #70824
    Member
    raakken
    Helpful
    Up
    0
    ::

    updated the kernel. no error messaqge from xmms, but no sound. spdif is gone, and it now says master, so getting somewhere. But no sound, sorry to say

    #70831
    Moderator
    caprea
    Helpful
    Up
    0
    ::

    And did you try to set the sound with pavucontrol, which should be installed now together with pulseaudio ?
    Otherwise you have to install pavucontrol.
    Start some sound with xmms and open pavucontrol.

    #70855
    Member
    linuxdaddy
    Helpful
    Up
    0
    ::

    the hardware could be faulty, anyway to check that on a usb iso of another distro/os?
    screen shots of the different mixer windows would help too.

    A few thoughts for true freedom ......
    1: Where ever there is greed and selfishness, evil will always smile upon.
    2: Wherever there is sharing of ideas and caring, good prevails and thrives.
    I'll fight for the second thought before joining or doing for the first.
    A thought, quote and belief of yours truly : from Linuxdaddy.

    #70880
    Moderator
    ModdIt
    Helpful
    Up
    0
    ::

    when i click “test sound”, nothing happens, just quickly shows the terminal for half a seconds and nothing…

    Had that yesteday, removing the alsa config files in home sorted out the issue for me.

    Also have no volume icon, still trying to find out how to fix, Kids want it badly, me too
    my Teufel soundsystem remote setting feature is dead. Sad at the high price and short age.

    —————————————————————————————————————-
    Volume Icon now fixed, suggestion by LinuxDaddy in older post worked.

    Set card in Controll center, shutdown restart. That together with above was what I needed.

    • This reply was modified 2 weeks, 1 day ago by ModdIt.
Viewing 13 posts - 1 through 13 (of 13 total)
  • You must be logged in to reply to this topic.