[solved] No sound in zsnes?

Forum Forums General Software [solved] No sound in zsnes?

  • This topic has 23 replies, 9 voices, and was last updated May 19-9:27 pm by marcelocripe.
Viewing 15 posts - 1 through 15 (of 24 total)
  • Author
    Posts
  • #35373
    Member
    kaye

    Hello Friends!

    I want to play a couple of classic SNES (super nintendo entertainment system?) games via the app called zsnes, which can be installed from the terminal or from synaptic.

    The problem is I have no sound. I tried two games, no sound. I don’t believe I had this problem in the previous version of antiX (antix 17).

    My current system:

    Kernel: 4.9.200-antix.1-amd64-smp x86_64
    bits: 64
    Desktop: IceWM 1.6.3+git20191202
    Distro: antiX-19.1_x64-full Marielle Franco 23 December 2019

    Yes, I’ve looked for solutions elsewhere, nothing worked.

    Maybe it needs pulseaudio?

    Thank you!

    • This topic was modified 3 months, 3 weeks ago by christophe. Reason: two-year-old thread now has a solution
    #35375
    Forum Admin
    anticapitalista
    Helpful
    Up
    0
    ::

    Try installing libasound2-plugins:i386

    Philosophers have interpreted the world in many ways; the point is to change it.

    antiX with runit - leaner and meaner.

    #35376
    Member
    Xecure
    Helpful
    Up
    0
    ::

    If the Options/configuration window doesn’t let you select audio output, then try pulseaudio out. There is no need to ask for permission. Test it and, if it doesn’t work, you can always uninstall it. I have already posted on a different answer how to do this.

    Also, I think rokytnji wrote something about this game/console emulator on the forum somewhere.

    antiX Live system enthusiast.
    General Live Boot Parameters for antiX.

    #35383
    Member
    kaye
    Helpful
    Up
    0
    ::

    Installing libasound2-plugins:i386 did not work even after reboot.

    Maybe I’ll try with pulseaudio, thanks

    #35397
    Member
    ModdIt
    Helpful
    Up
    0
    ::

    Hi kaye, did you add an .asound.conf file to your local user, I do not use a game emulator so can not be sure, it has solved sound problems both for me and Moddit Kids, including with latest firefox, derivatives and tor browser.

    #Substitute N with a small integer, 0 for your first sound card (which is the default),
    #1 for your second, and so on. Depending on your setup you might have to modify to fit use
    case.

    pcm.!default {
    type hw
    card 0
    }

    ctl.!default {
    type hw
    card 0
    }

    #35400
    Member
    kaye
    Helpful
    Up
    0
    ::

    Hi Moddit! I’ll try that soon, I’ll get back to you. Thank you!

    #35412
    Member
    ModdIt
    Helpful
    Up
    0
    ::

    Added a bit of info for clarity, sorry been a while since I did this.

    I installed apulse as first step
    setup the config after finding my card with cat /proc/asound/cards
    some instructions say use .asoundrc I disabled that existing file
    before creating the .asound.conf in my home directory
    Prefix start command for applications as following: apulse <path/program>
    path if needed.
    This is also done in our toolbar and personal application menu

    There are a number of posts on getting sound to work with alsa in the
    depths of the forum,. Pulse makes my audio sound cheap so I never use it.

    #35420
    Member
    kaye
    Helpful
    Up
    0
    ::

    Hi Moddit.

    I disabled the file .asoundrc by renaming it. Then I created .asound.conf and put your code in it.

    Then I executed
    apulse zsnes

    Still no sound. Oh well =)

    #35421
    Member
    ModdIt
    Helpful
    Up
    0
    ::

    Assume you installed apulse
    and checked the card id with cat /proc/asound/cards to be sure it is described same as mine.

    Maybe you could take a look at
    https://wiki.archlinux.org/index.php/Advanced_Linux_Sound_Architecture/Troubleshooting
    https://www.linuxquestions.org/questions/debian-26/no-sound-with-alsa-819883/

    Those threads have really helped me on a number of occasions. Just too much to post here.

    #57092
    Member
    Gew
    Helpful
    Up
    0
    ::

    Anyone managed to resolve this?
    I’m fighting the same battle!

    Is anyone here actually getting sound from ZSNES (zsnes-dbg package) … ?
    Running latest Antix, x64.

    #57097
    Member
    ModdIt
    Helpful
    Up
    0
    ::

    I do not have ZSNES. As long as sound with antiX standard alsa is otherwise ok.
    Maybe it would help if a complete list of what has been tried is posted, including which 32 bit
    librarys have been installed.

    member kaye wrote: I don’t believe I had this problem in the previous version of antiX (antix 17).
    In older debian versions more 32 bit library and possibly kernel support was incorporated as standard.

    Worth a try to see if sound will work for znes on antiX 17 running live or installed.

    #57098
    Moderator
    caprea
    Helpful
    Up
    0
    ::

    @Gew, please give us the output if you start zsnes from terminal with command zsnes,
    I got sound to work on 64bit without pulseaudio installed. Probably there is something missing , here it was libasound2-plugin-equal:i386 first.
    The output will show what is missing, hopefully.

    #57118
    Member
    felipecardope
    Helpful
    Up
    0
    ::

    My zsnes is also without sound

    Meu zsnes tambem está sem som

    $ zsnes
    ZSNES v1.51, (c) 1997-2007, ZSNES Team
    Be sure to check http://www.zsnes.com/ for the latest version.

    ZSNES is written by the ZSNES Team (See AUTHORS.TXT)
    ZSNES comes with ABSOLUTELY NO WARRANTY. This is free software,
    and you are welcome to redistribute it under certain conditions;
    please read ‘LICENSE.TXT’ thoroughly before doing so.

    Use ZSNES -? for command line definitions.

    Starting Mouse detection.
    Unable to poll /dev/input/event8. Make sure you have read permissions to it.
    Unable to poll /dev/input/event7. Make sure you have read permissions to it.
    Unable to poll /dev/input/event6. Make sure you have read permissions to it.
    Unable to poll /dev/input/event5. Make sure you have read permissions to it.
    Unable to poll /dev/input/event4. Make sure you have read permissions to it.
    Unable to poll /dev/input/event3. Make sure you have read permissions to it.
    Unable to poll /dev/input/event2. Make sure you have read permissions to it.
    Unable to poll /dev/input/event1. Make sure you have read permissions to it.
    Unable to poll /dev/input/event0. Make sure you have read permissions to it.
    ManyMouse: 0 mice detected.
    ALSA lib dlmisc.c:287:(snd1_dlobj_cache_get) Cannot open shared library /usr/lib/i386-linux-gnu/alsa-lib/libasound_module_pcm_equal.so ((null): /usr/lib/i386-linux-gnu/alsa-lib/libasound_module_pcm_equal.so: cannot open shared object file: No such file or directory)
    ZSNES could not find any joysticks.

    #57119
    Moderator
    caprea
    Helpful
    Up
    0
    ::

    If this is on a 32bit system please try to install libasound2-plugin-equal

    On 64bit systems I unfortunately discovered a problem, it looks like you can not have both 32 and 64 bit versions of libasound2-plugin-equal and caps
    installed simultaneously.

    #79035
    Member
    felipecardope
    Helpful
    Up
    0
    ::

    Hello everybody.

    marcelocripe sent me the PPC explanations on how to use pulseaudio.

    Open Synaptic package manager, search for pulseaudio, right click to mark for installation. Click apply to install the package.

    I ran ZSNES and there was still no sound, I closed the emulator.

    Following the PPC explanation, I opened the terminal and applied the command:

    pulseaudio -D &

    I ran ZSNES again and the sound worked.

    I thank PPC for teaching marcelocripe who sent me the step by step.

    Olá a todos.

    O marcelocripe me enviou as explicações do PPC de como utilizar o pulseaudio.

    Abra o gerenciador de pacotes Synaptic, pesquise pulseaudio, clique com o botão direito para marcar para instalação. Clique em aplicar para instalar o pacote.

    Eu executei ZSNES e ainda não havia o som, fechei o emulador.

    Seguindo a explicação do PPC, eu abri o terminal e apliquei o comando:

    pulseaudio -D &

    Executei novamente o ZSNES e o som funcionou.

    Agradeço a o PPC por ensinar o marcelocripe que me enviou o passo a passo.

Viewing 15 posts - 1 through 15 (of 24 total)
  • You must be logged in to reply to this topic.