[SOLVED} Old version of Firefox refuses to run

Forum Forums Official Releases antiX-21/22 “Grup Yorum” [SOLVED} Old version of Firefox refuses to run

Tagged: 

  • This topic has 6 replies, 5 voices, and was last updated Nov 26-1:56 pm by Brian Masinick.
Viewing 7 posts - 1 through 7 (of 7 total)
  • Author
    Posts
  • #71715
    Member
    dirkd

      Because an old plugin that I still use frequently is no longer supported, I have a copy of version 52.9 that I run in parallel with the regular version from the debian repos. I just have to unzip an archive from the official firefox website in my home folder, then run the included firefox binary from a terminal, with a custom profile that forbids automatic updates.

      This worked beautifully in Antix17, and if I remember well, in Antix19. I even tested the procedure for Antix21 in a virtual machine with both Runit and SystemV versions. On my real machine however, firefox 52.9 refuses to start with an error message

      $ firefox/firefox --no-remote -p Adm
      bash: firefox/firefox: Permission denied
      

      I have checked all permissions, as thoroughly as I could, but found nothing suspicious. I also tried to run it as root, although it is well known that this doesn’t work even with regular firefox. All through no avail. My regular firefox version is working fine, as this post shows btw. I may have damaged something in copying over older configuration files from my Antix17 home folder to my Antix21 home folder. But as far as I know I didn’t touch anything Mozilla-related.

      Anyone who can help me with this? All suggestions are very wellcome. I just hope that I don’t have to go through a complete re-install to fix this silly detail.

      • This topic was modified 2 years, 6 months ago by dirkd.
      #71724
      Member
      PPC

        Unless it’s a typo- are you trying to run a firefox’s executable file called “firefox/firefox”? Could it be something so simple as a typing mistake?
        Enter the folder where you have the executable file and try running simply?
        ./firefox --no-remote -p Adm

        It’s just my dumb idea- it probably can’t be that easy…

        #71728
        Member
        Xecure

          Please, show us the information for the specific file.
          ls -l /path/to/firefox
          I suspect you copied it over from a partition that mounted without execution permissions, so all files are not executable.
          Try downloading it again and un-compressing it as normal user to a different folder in your user’s home.

          antiX Live system enthusiast.
          General Live Boot Parameters for antiX.

          #71730
          Member
          wildstar84

            It looks more like an issue with the shellscript – I presume /usr/bin/firefox. Mine’s: -rwxr-xr-x 1 root root 113 Oct 5 16:18 /usr/bin/firefox. The first line is #!/bin/sh and /bin/sh => dash (not bash). Here’s the file:

            #!/bin/sh
            FIREFOX="$(which firefox)"
            [ -x "$FIREFOX.real" ] && exec "$FIREFOX.real" "$@"
            exec firefox-esr "$@"

            which firefox
            returns /usr/bin/firefox

            Hope that helps.

            #71731
            Member
            dirkd

              The thought dawned upon me a few hours after this post. Could have saved me a whole afternoon of experimenting with virtual machines…

              For the first time in all these years of using Linux, I decided to use a separate home partition for my new Antix21 installation. As I had successfully done before, I unpacked the firefox-52.9 archive to a ~/firefox/ folder in my home subfolder (so, not a typo, @PPC 🙂 ). And that’s apparently the reason it won’t run! In my virtual machine experiments I hadn’t used a separate home partition, in order to speed up the installation procedure, and then firefox runs just fine out of my home-folder.

              So I moved the firefox folder to /opt in stead. I had to be a little more careful to be sure that the access rights were sufficient for non-root users. Then I made a link to the /opt/firefox52.9/firefox binary (I had the good sense this time to name the folder more clearly) in ~/Desktop, and all was well.

              Thank you guys, anyway, for letting your light shine on this. Do you know of any other applications, in say ~/.local/bin, that can’t be run from a separate home partition? I remember, previously this week, that I had problems to start nicotine-plus (a python application) that was installed in ~/.local/bin. I presumed something had gone wrong with the installation, but maybe it was a symptom of the same thing.

              • This reply was modified 2 years, 6 months ago by dirkd.
              #71750
              Member
              dirkd

                Yet another thought dawned upon me, late at night this time. I decided to check my fstab file, and sure enough I saw something missing. The line
                /dev/sdf3 /home ext4 auto,exec,users,rw
                was missing the two zeros at the end (dump/pass parameters). I don’t understand their purpose very well, but leaving them empty was perhaps not a good idea. So I added ‘0 0’ at the end and also changed the parameters ‘auto,exec,users,rw’ with ‘defaults’, since that’s what was used for the root folder too.

                Sure enough, after rebooting, I WAS able to run executables from my home folder, in the same way I used to in previous AntiX installations.

                Still somewhat puzzled though. As I understood it, the ‘exec’ parameter should be enough to allow execution of binaries, and the two missing zeros are not related to execution permissions. Oh well, another thing learned.

                #71757
                Moderator
                Brian Masinick

                  Yet another thought dawned upon me, late at night this time. I decided to check my fstab file, and sure enough I saw something missing. The line
                  /dev/sdf3 /home ext4 auto,exec,users,rw
                  was missing the two zeros at the end (dump/pass parameters). I don’t understand their purpose very well, but leaving them empty was perhaps not a good idea. So I added ‘0 0’ at the end and also changed the parameters ‘auto,exec,users,rw’ with ‘defaults’, since that’s what was used for the root folder too.

                  Sure enough, after rebooting, I WAS able to run executables from my home folder, in the same way I used to in previous AntiX installations.

                  Still somewhat puzzled though. As I understood it, the ‘exec’ parameter should be enough to allow execution of binaries, and the two missing zeros are not related to execution permissions. Oh well, another thing learned.

                  Nice job figuring this out. As you continue to try things out and learn, the information on manual pages may begin to make sense. These days you can find Linux and UNIX man pages on-line.

                  For example, here is a link to man 5 fstab:

                  http://www.man7.org/linux/man-pages/man5/fstab.5.html

                  --
                  Brian Masinick

                Viewing 7 posts - 1 through 7 (of 7 total)
                • You must be logged in to reply to this topic.