[SOLVED]OpenVPN troubles, partially solved

Forum Forums Official Releases antiX-19 “Marielle Franco” [SOLVED]OpenVPN troubles, partially solved

  • This topic has 2 replies, 1 voice, and was last updated Mar 26-6:03 am by lorijan.
Viewing 2 posts - 1 through 2 (of 2 total)
  • Author
    Posts
  • #33633
    Member
    Avatarlorijan

    I am trying to use OpenVPN, but I have two problems with it.

    First it can not set the default route, after connection, when connman is active. If I am disable connman service (sysv-rc-conf), and use ceni, for dhcp config, then OpenVPN works. I was writing a VPN config for connman, but the result are the some, VPN connection activating, but can not set default route, because that already exist.

    On antiX 17 I have used wicd and OpenVPN without any problem, it would be nice if somebody continues wicd development…

    The second problem, is with resolvconf, OpenVPN does not updates the DNS servers with the update-resolv-conf script. Changing to openresolv package resolved 🙂 the problem.

    • This topic was modified 1 month, 4 weeks ago by lorijan.
    #33841
    Member
    Avatarlorijan

    These “problems” not antiX specific, but we use and love antiX 🙂
    The routing problem arising because connman has a feature to restore default route, which is good. But OpenVPN changes the default route in two step, which is bad. The best solution would be if OpenVPN use the “ip route replace” command instead of “ip route del” + “ip route add” sequence.
    On the server side, if we can access it, the push "redirect-gateway" can be replaced with push "redirect-gateway def1" in the server config file. That way we will have 0.0.0.0/1, instead of 0.0.0.0/0, but the result is the some.

    The cause of the “resolver war” are the symlinks. Connman makes a symlink for /etc/resolv.conf into his own territory, but resolvconf want to make also a symlink, but into his own directory structure. Installing openresolv is one solution, the other maybe to disable connman’s DNS proxy with the “–nodnsproxy” command line parameter. through an /etc/default/connman file, with DAEMON_OPTS=”–nodnsproxy”? I chooses to install the openresolv package, it was quicker.

    These are my findings, my explanation can be wrong, but my VPN link now working stable, all day long, on my antiX HomeOffice station 😉

    • This reply was modified 2 months ago by lorijan. Reason: it was ugly like hell
    • This reply was modified 2 months ago by lorijan. Reason: it was ugly like hell
Viewing 2 posts - 1 through 2 (of 2 total)
  • You must be logged in to reply to this topic.