outdated elogind prevents full-upgrade in sid

Forum Forums News Sid Upgraders outdated elogind prevents full-upgrade in sid

This topic contains 16 replies, has 3 voices, and was last updated by caprea Dec 3-8:52 am.

Viewing 15 posts - 1 through 15 (of 17 total)
  • Author
    Posts
  • #13799
    Member
    Xaver
    Xaver

    There are new versions of elogind, libelogind0 and libpam-elogind in the debian-sid-repo – Version: 239.1+20181112+gd4a3f291e395+nosubmodule-1+debian1.
    In the antiX-sid-repo there still is version 239.1-0.1.

    This causes conflicts with libkf5auth5, libkf5configwidgets5, libkf5kiocore5 and libpolkit-qt5-1-1.
    In the consequence ‘# apt full-upgrade’ is impossible, unless you deinstall all kde related software (i.e. falkon, k3b, kexi, tellico). ‘#apt upgrade’ is still working.

    #13806
    Forum Admin
    anticapitalista
    anticapitalista

    What causes the conflict – the antiX version (which should get overwritten, it did on my sid install without issue) or the newer debian sid one?
    If it is the debian one, then you should really file a bug there.
    Do you have any packages on hold?
    I don’t use any kde packages so maybe the problem is there.

    Post the outputs of the apt-get you tried and we’ll see if anyone can replicate the issue.

    • This reply was modified 11 months, 2 weeks ago by anticapitalista.

    Philosophers have interpreted the world in many ways; the point is to change it.

    #13808
    Forum Admin
    anticapitalista
    anticapitalista

    I think the problem might be with libpolkit-qt5-1-1which wants libpam-systemd.
    I’ll rebuild a nosystemd version that depends on libpam-elogind instead

    Philosophers have interpreted the world in many ways; the point is to change it.

    #13809
    Member
    Xaver
    Xaver

    Yes, the conflict seems to be related to KDE packages only.
    If I deinstall libkf5auth5, all my KDE packages (Falkon, k3b, Kexi, Tellico) will be deinstalled too.
    Then I can run ‘#apt full-upgrade’ without problems.
    But if I then want to reinstall Falkon, k3b, Kexi and Tellico, the message is ‘unmet dependencies’.
    So I have reinstalled my backup, because I want to keep these programs.
    There is only one package on hold: impress 0.11.1-1.1 (version 0.12.0-2 does not work properly).

    The output of ‘#apt update && apt list –upgradable && apt full-upgrade’:

    # apt update && apt list --upgradable && apt full-upgrade
    Hit:1 http://ftp.halifax.rwth-aachen.de/mxlinux/packages/antix/sid sid InRelease
    Hit:2 http://ftp.de.debian.org/debian unstable InRelease                 
    Hit:3 http://ftp.spline.de/pub/siduction/extra unstable InRelease        
    Hit:4 http://ftp.spline.de/pub/siduction/fixes unstable InRelease
    Reading package lists... Done
    Building dependency tree       
    Reading state information... Done
    4 packages can be upgraded. Run 'apt list --upgradable' to see them.
    Listing... Done
    elogind/unstable 239.1+20181112+gd4a3f291e395+nosubmodule-1+debian1 amd64 [upgradable from: 239.1-0.1]
    impressive/unstable,unstable 0.12.0-2 all [upgradable from: 0.11.1-1.1]
    libelogind0/unstable 239.1+20181112+gd4a3f291e395+nosubmodule-1+debian1 amd64 [upgradable from: 239.1-0.1]
    libpam-elogind/unstable 239.1+20181112+gd4a3f291e395+nosubmodule-1+debian1 amd64 [upgradable from: 239.1-0.1]
    Reading package lists... Done
    Building dependency tree       
    Reading state information... Done
    Calculating upgrade... Error!
    Some packages could not be installed. This may mean that you have
    requested an impossible situation or if you are using the unstable
    distribution that some required packages have not yet been created
    or been moved out of Incoming.
    The following information may help to resolve the situation:
    
    The following packages have unmet dependencies:
     libkf5configwidgets5 : Depends: libkf5auth5 (>= 4.96.0) but it is not going to be installed
     libkf5kiocore5 : Depends: libkf5auth5 (>= 4.96.0) but it is not going to be installed
    E: Error, pkgProblemResolver::Resolve generated breaks, this may be caused by held packages.
    • This reply was modified 11 months, 2 weeks ago by Xaver.
    #13810
    Forum Admin
    anticapitalista
    anticapitalista

    Rebult polkit-qt package just hit the repos so see if it now works. Post the output if not.

    Philosophers have interpreted the world in many ways; the point is to change it.

    #13813
    Member
    Xaver
    Xaver

    Unfortunately the output is still the same as posted above.

    #13814
    Forum Admin
    anticapitalista
    anticapitalista

    Did you use the default antiX repo? The mirrors won’t have picked up the new debs yet.

    Philosophers have interpreted the world in many ways; the point is to change it.

    #13815
    Member
    Xaver
    Xaver

    Which one is the default antiX repo?
    I have thought ist would be
    deb http://nl.mxrepo.com/antix/ sid main nosystemd
    but I get an error message
    With ‘deb http://repo.antixlinux.com/ sid main nosystemd’ I get the same error message.

    # apt update
    Ign:1 http://nl.mxrepo.com/antix sid InRelease
    Hit:2 http://ftp.de.debian.org/debian unstable InRelease               
    Err:3 http://nl.mxrepo.com/antix sid Release                            
      404  Not Found [IP: 81.4.106.127 80]
    Hit:4 http://ftp.spline.de/pub/siduction/extra unstable InRelease       
    Hit:5 http://ftp.spline.de/pub/siduction/fixes unstable InRelease
    Reading package lists... Done
    E: The repository 'http://nl.mxrepo.com/antix sid Release' does not have a Release file.
    N: Updating from such a repository can't be done securely, and is therefore disabled by default.
    N: See apt-secure(8) manpage for repository creation and user configuration details.
    
    • This reply was modified 11 months, 2 weeks ago by Xaver.
    #13823
    Forum Admin
    anticapitalista
    anticapitalista

    Default repo is

    deb http://repo.antixlinux.com/sid sid main nosystemd nonfree

    Philosophers have interpreted the world in many ways; the point is to change it.

    #13828
    Member
    Xaver
    Xaver

    Still cannot update, because the release file of the antiX sid repo is missing.

    Ign:4 http://repo.antixlinux.com sid InRelease                                 
    Err:5 http://repo.antixlinux.com sid Release       
      404  Not Found [IP: 72.143.17.194 80]
    Reading package lists... Done                      
    E: The repository 'http://repo.antixlinux.com sid Release' does not have a Release file.
    N: Updating from such a repository can't be done securely, and is therefore disabled by default.
    
    #13829
    Forum Admin
    anticapitalista
    anticapitalista

    It’s ok here.

    `agu
    Hit:1 http://debian.otenet.gr/debian unstable InRelease
    Hit:2 http://repo.antixlinux.com/sid sid InRelease
    Reading package lists… Done `

    Anyhow, try your original repo since the debs have now populated there.

    http://ftp.halifax.rwth-aachen.de/mxlinux/packages/antix/sid/pool/nosystemd/p/polkit-qt-1/

    • This reply was modified 11 months, 2 weeks ago by anticapitalista.

    Philosophers have interpreted the world in many ways; the point is to change it.

    #13831
    Member
    Xaver
    Xaver

    Sorry, but at the moment none of the repos is working for me.
    antix-archive-keyring (2017.3.14) is installed and seems to be ok.
    So I just wait and shall try again tomorrow.
    Thank you – have a good night.

    #13843
    Member
    Xaver
    Xaver

    There are still problems with the antiX sid repo:

    Err:4 http://repo.antixlinux.com sid InRelease                                                        
      Could not connect to repo.antixlinux.com:80 (72.143.17.194), connection timed out
    Reading package lists... Done                         
    Building dependency tree       
    Reading state information... Done
    17 packages can be upgraded. Run 'apt list --upgradable' to see them.
    W: Failed to fetch http://repo.antixlinux.com/dists/sid/InRelease  Could not connect to repo.antixlinux.com:80 (72.143.17.194), connection timed out
    W: Some index files failed to download. They have been ignored, or old ones used instead.
    

    The mirrors still do not have a release file:

    Ign:4 https://ftp.fau.de/mxlinux-packages/antix sid InRelease                                
    Err:5 https://ftp.fau.de/mxlinux-packages/antix sid Release
      404  Not Found [IP: 131.188.12.211 443]
    Reading package lists... Done                      
    E: The repository 'https://ftp.fau.de/mxlinux-packages/antix sid Release' does not have a Release file.
    N: Updating from such a repository can't be done securely, and is therefore disabled by default.
    
    #13844
    Member
    caprea
    caprea

    Works here
    deb http://ftp.halifax.rwth-aachen.de/mxlinux/packages/antix/sid/ sid nonfree nosystemd main

    #13846
    Member
    Xaver
    Xaver

    @ caprea
    Thank you. Now my problem is clear.
    I have been using the repo-manager to switch repos.
    The repo-manager created
    deb http://ftp.halifax.rwth-aachen.de/mxlinux/packages/antix/ sid main nosystemd
    Your repo line is different and it is working
    deb http://ftp.halifax.rwth-aachen.de/mxlinux/packages/antix/sid/ sid nonfree nosystemd main

    So repo-manager is not working properly.
    Also there seems to be something wrong with the line of the default repo
    deb http://repo.antixlinux.com/sid sid main nosystemd nonfree
    It still does not work.

    The rebuild of polkit-qt package did help.
    ‘#apt full-upgrade’ is working again without problems.

Viewing 15 posts - 1 through 15 (of 17 total)

You must be logged in to reply to this topic.