pae-kernel and Calibre Problems

Forum Forums Official Releases antiX-23 “Arditi del Popolo pae-kernel and Calibre Problems

  • This topic has 7 replies, 2 voices, and was last updated Dec 15-5:04 am by antixjim.
Viewing 8 posts - 1 through 8 (of 8 total)
  • Author
    Posts
  • #117073
    Member
    antixjim

      I upgraded from antiX19 to antiX23 by saving all my files on another computer and doing a fresh install using antiX23-core on a CD-ROM and antiX23-full on a 4 GB usb stick. It appears the install was successful, but I ran into two problems:

      1. I tried installing the pae-kernel and several other programs using the antiX Package Installer. All (or most) of the programs installed successfully, but the kernel update to the pae-kernel failed (after several hours, the computer is really slow). Since then I found out I need the pae-kernel to use my 4 GB usb stick to move flles between my two computers. I have a 1 GB usb stick that will work, so the non-pae-kernel seems to be the definate problem. I plan to try to install the pae-kernel later this week when I have more time, but I thought you shuold know about this failure, in case it is a bug.

      2. I then tried to install Calibre. It would not open, so I tried to Uninstall Calibre. There was an error message using the Package Installer, so I tried to reinstall and got another error message. It suggested using “apt fix-broken-install’ or someing similar, but that did not work. There was also something about needing SSE3-support which was not available. I then tried to do a complete uninstall using Semantic and got a similar error message regarding SSE3. I tried installing SSE3 and got the following error message: E:/var/cache/apt/archive/SSE3-support_15.1i386deb;new SSE3-support package preinstallation script subprocess returned error exit status 2. I copied the terninal output from Semantic that contains additional information.

      At present I believe a second attempt to install the pae_kernel probably will not be successful, but I am going to try it anyway. Regarding Calibre, at present I have no idea how to do a complete uninstall, but I am willing to try any suggestions. Since both issues may be the result of bugs in antiX23 I am providing this information. Reinstalling antiX23 is possible, but I would be more inclined to install zntiX22 with a pae-kernel if I cannot get the pae-kernel installed in antiX23. Thanks in advance for any advice.

      Jim

      #117074
      Member
      antixjim

        Could not attached the file. Here is the text:

        Preconfiguring packages …
        (Reading database … 163300 files and directories currently installed.)
        Preparing to unpack …/sse3-support_15.1_i386.deb …
        This machine doesn’t support SSE3, sorry.
        Aborting.
        dpkg: error processing archive /var/cache/apt/archives/sse3-support_15.1_i386.deb (–unpack):
        new sse3-support package pre-installation script subprocess returned error exit status 2
        Errors were encountered while processing:
        /var/cache/apt/archives/sse3-support_15.1_i386.deb
        E: Sub-process /usr/bin/dpkg returned an error code (1)
        A package failed to install. Trying to recover:
        Setting up libb2-1:i386 (0.98.1-1.1) …
        Setting up python3-css-parser (1.0.8-1) …
        Setting up python3-apsw (3.40.0.0-2+b1) …
        Setting up libqt6webengine6-data (6.4.2-final+dfsg-1) …
        Setting up python3-texttable (1.6.7-1) …
        dpkg: dependency problems prevent configuration of libqt6webenginecore6:i386:
        libqt6webenginecore6:i386 depends on sse3-support; however:
        Package sse3-support is not installed.

        dpkg: error processing package libqt6webenginecore6:i386 (–configure):
        dependency problems – leaving unconfigured
        Setting up libre2-9:i386 (20220601+dfsg-1+b1) …
        Setting up python3-py7zr (0.11.3+dfsg-5) …
        Setting up libpython3.11:i386 (3.11.2-6) …
        Setting up python3-repoze.lru (0.7-3) …
        Setting up python3-speechd (0.11.4-2) …
        Setting up libminizip1:i386 (1.1-8+b1) …
        Setting up python3-html2text (2020.1.16-2) …
        update-alternatives: using /usr/bin/html2markdown.py3 to provide /usr/bin/html2markdown (html2markdown) in auto mode
        Setting up libjxr0:i386 (1.2~git20170615.f752187-5) …
        dpkg: dependency problems prevent configuration of libqt6webenginewidgets6:i386:
        libqt6webenginewidgets6:i386 depends on libqt6webenginecore6 (>= 6.4.0); however:
        Package libqt6webenginecore6:i386 is not configured yet.

        dpkg: error processing package libqt6webenginewidgets6:i386 (–configure):
        dependency problems – leaving unconfigured
        Setting up libpodofo0.9.8 (0.9.8+dfsg-3+b1) …
        Setting up libqt6core6:i386 (6.4.2+dfsg-10) …
        Setting up libturbojpeg0:i386 (1:2.1.5-2) …
        Setting up libts0:i386 (1.22-1+b1) …
        Setting up python3-webencodings (0.5.1-5) …
        Setting up libopengl0:i386 (1.6.0-1) …
        dpkg: dependency problems prevent configuration of libqt6webenginequick6:i386:
        libqt6webenginequick6:i386 depends on libqt6webenginecore6 (>= 6.4.0); however:
        Package libqt6webenginecore6:i386 is not configured yet.

        dpkg: error processing package libqt6webenginequick6:i386 (–configure):
        dependency problems – leaving unconfigured
        Setting up python3-ifaddr (0.1.7-2) …
        Setting up python3-sgmllib3k (1.0.0-4) …
        Setting up python3-async-timeout (4.0.2-1) …
        Setting up python3-pygments (2.14.0+dfsg-1) …
        Setting up python3-pyparsing (3.0.9-1) …
        Setting up libqt6xml6:i386 (6.4.2+dfsg-10) …
        Setting up libqt6sql6:i386 (6.4.2+dfsg-10) …
        Setting up fonts-liberation2 (2.1.5-1) …
        Setting up optipng (0.7.7-2+b1) …
        Setting up libchm1 (2:0.40a-8) …
        Setting up python3-markdown (3.4.1-2) …
        dpkg: dependency problems prevent configuration of python3-pyqt6.qtwebengine:
        python3-pyqt6.qtwebengine depends on libqt6webenginecore6 (>= 6.3.0); however:
        Package libqt6webenginecore6:i386 is not configured yet.
        python3-pyqt6.qtwebengine depends on libqt6webenginequick6 (>= 6.2.2); however:
        Package libqt6webenginequick6:i386 is not configured yet.
        python3-pyqt6.qtwebengine depends on libqt6webenginewidgets6 (>= 6.2.2); however:
        Package libqt6webenginewidgets6:i386 is not configured yet.

        dpkg: error processing package python3-pyqt6.qtwebengine (–configure):
        dependency problems – leaving unconfigured
        Setting up python3-regex (0.1.20221031-1+b1) …
        Setting up python3-html5-parser (0.4.10-8+b1) …
        Setting up python3-html5lib (1.1-3) …
        Setting up python3-jeepney (0.8.0-3) …
        Setting up python3-netifaces:i386 (0.11.0-2+b1) …
        Setting up libharfbuzz-subset0:i386 (6.0.0+dfsg-3) …
        Setting up python3-dateutil (2.8.2-2) …
        dpkg: dependency problems prevent configuration of libqt6webenginecore6-bin:
        libqt6webenginecore6-bin depends on libqt6webenginecore6 (>= 6.2.2); however:
        Package libqt6webenginecore6:i386 is not configured yet.

        dpkg: error processing package libqt6webenginecore6-bin (–configure):
        dependency problems – leaving unconfigured
        Setting up python3-msgpack (1.0.3-2+b1) …
        Setting up libstemmer0d:i386 (2.2.0-2) …
        Setting up libjs-jquery (3.6.1+dfsg+~3.5.14-1) …
        Setting up python3-pyqt6.sip (13.4.1-1) …
        Setting up python3-soupsieve (2.3.2-1) …
        Setting up libqt6dbus6:i386 (6.4.2+dfsg-10) …
        Setting up libjs-underscore (1.13.4~dfsg+~1.11.4-3) …
        Setting up python3-mechanize (1:0.4.8+pypi-5) …
        Setting up python3-feedparser (6.0.10-1) …
        Setting up libqt6test6:i386 (6.4.2+dfsg-10) …
        Setting up libjxr-tools (1.2~git20170615.f752187-5) …
        Setting up python3-zeroconf (0.47.3-1) …
        Setting up libqt6positioning6:i386 (6.4.2-1) …
        Setting up libjpeg-turbo-progs (1:2.1.5-2) …
        Setting up python3-chm (0.8.6-3+b4) …
        Setting up python3-bs4 (4.11.2-2) …
        Setting up libqt6gui6:i386 (6.4.2+dfsg-10) …
        dpkg: dependency problems prevent configuration of calibre:
        calibre depends on libqt6webenginecore6-bin; however:
        Package libqt6webenginecore6-bin is not configured yet.
        calibre depends on python3-pyqt6.qtwebengine; however:
        Package python3-pyqt6.qtwebengine is not configured yet.

        dpkg: error processing package calibre (–configure):
        dependency problems – leaving unconfigured
        Setting up libjs-sphinxdoc (5.3.0-4) …
        Setting up libqt6network6:i386 (6.4.2+dfsg-10) …
        Setting up libqt6qml6:i386 (6.4.2+dfsg-1) …
        Setting up libqt6opengl6:i386 (6.4.2+dfsg-10) …
        Setting up libqt6qmlmodels6:i386 (6.4.2+dfsg-1) …
        Setting up libqt6widgets6:i386 (6.4.2+dfsg-10) …
        Setting up python3-routes (2.5.1-3) …
        Setting up libqt6svg6:i386 (6.4.2-2) …
        Setting up libqt6quick6:i386 (6.4.2+dfsg-1) …
        Setting up libqt6webchannel6:i386 (6.4.2-1) …
        Setting up libqt6svgwidgets6:i386 (6.4.2-2) …
        Setting up calibre-bin (6.13.0+repack-2) …
        Setting up libqt6openglwidgets6:i386 (6.4.2+dfsg-10) …
        Setting up libqt6printsupport6:i386 (6.4.2+dfsg-10) …
        Setting up python3-pyqt6 (6.4.2-1) …
        Setting up pyqt6-dev-tools (6.4.2-1) …
        Setting up libqt6quickwidgets6:i386 (6.4.2+dfsg-1) …
        Setting up python3-pyqt6.qtwebchannel (6.4.2-1) …
        Setting up python3-pyqt6.qtsvg (6.4.2-1) …
        Setting up python3-pyqt6.qtqml (6.4.2-1) …
        Setting up python3-pyqt6.qtquick (6.4.2-1) …
        Processing triggers for desktop-file-utils (0.26-1) …
        Processing triggers for hicolor-icon-theme (0.17-2) …
        Processing triggers for libc-bin (2.36-9+deb12u1) …
        Processing triggers for man-db (2.11.2-2) …
        Processing triggers for shared-mime-info (2.2-1) …
        Processing triggers for mailcap (3.70+nmu1) …
        Processing triggers for fontconfig (2.14.1-4) …
        Errors were encountered while processing:
        libqt6webenginecore6:i386
        libqt6webenginewidgets6:i386
        libqt6webenginequick6:i386
        python3-pyqt6.qtwebengine
        libqt6webenginecore6-bin
        calibre

        Sorry it is so long. Jim

        #117075
        Member
        Xunzi_23

          Hi antixjim

          Preparing to unpack …/sse3-support_15.1_i386.deb …
          This machine doesn’t support SSE3, sorry.

          Looks interesting Would you please give us hardware information inxi-zv8

          #117337
          Member
          antixjim

            First things first. The SSE3 problem was resolved. After some difficulty I was able to delete Calibre and the aborted installation of SSE3.

            I also was able to resolve the installation of a PAE Kernel, but not in the way I hoped. I made several attempts to install a PAE Kernel on antiX-23. I tried all the kernels shown in the antiX Package Manager, but none worked I then tried installing an earlier version os antiX Linus. I found that only antiX-23 can be downloaded from antiX’s website. I went to SourceForge and downloaded ISO’s (Core and Full) for antiX-22 and antiX-21. I then discovered that the “32-bit” core version of antiX-22 was actually a 64-bit version, so I could not use it. I then tried installing antiX-21, but it stalled before getting to the live session, so I was not able to use it either. I then found my Installation CD for antiX-19-base and reinstalled that successfully. After successfully updating and upgrading the installation, I then attempted to install the same PAE Kernal that I had installed earlier and this time I was again successful. I am back where I started, but so far everything is working properly again.

            I have attached a file of my current PC Information (full) in case someone would like to look it over and make any suggestions on how I can get a PAE Kernel installed on antiX-23 with my existing hardware. There is one item of concern for me still. When I was running antiX-23 without the PAE Kernel. an Epub reader I was using (FBReader) would not run properly. When I opened my Epub book a second time, FBReader put a hyphen after every word. I do not know what caused this, but it did not happen when I was using antiX-19.4 earllier. When antiX-19 reaches end of support, I may have to look into a Debian installation or pull the WiFi out, reinstall Windows XP and run it off-line.

            For now I consider the issue closed. I am back where I started, but everything that was working properly before sould be working properly now (once I get everything reinstalled).

            My thanks to everyone for their patience with me.

            Attachments:
            #126205
            Member
            antixjim

              I goofed. I had forgotten that I had this problem installing Calibre. Attempting to find a better program to read e-books in PDF format I attempted to install Calibre, Evince, and Foliate. None will open and I cannot delete any of them. The method I used before did not work (probably because three files are involved this time. I am running antiX 23 on my 20 year old Compaq (see Full_info.7z attached above). I seem to be in an endless loop. I cannot uninstall Calibre, Evince, or Foliate because SSE3 is not installed and I cannot install SSE3 because the Comnpaq does not support it.

              My question is: Is there a way to FORCE the uninstallation of these three programs?

              The error messages I received are attached below.

              #126206
              Member
              antixjim

                Trying again to attach error messages file.

                Attachments:
                #126209
                Member
                antixjim

                  Second attempt worked attaching a file. Also, this time I am NOT using the PAE version of the antiX 23 Kernel.

                  #126305
                  Member
                  antixjim

                    I was lucky. As a last ditch effort I tried Timeshift to restore the system to an earlier date. I cannot remember when I attempted to installed calibre, evince, and foliate, but I was absolutely certain that it was after 30 November 2023, so I used Timeshift to restore the system to that date. All three programs are gone and there are no errors. I do not know what I would have done if this had not worked. I will definately be certain to have Timeshift backups current.

                  Viewing 8 posts - 1 through 8 (of 8 total)
                  • You must be logged in to reply to this topic.