Performance testing on an old Pentium II-400

Forum Forums General Tips and Tricks Performance testing on an old Pentium II-400

  • This topic has 31 replies, 8 voices, and was last updated Feb 28-3:28 am by andyprough.
Viewing 15 posts - 16 through 30 (of 32 total)
  • Author
    Posts
  • #54702
    Moderator
    christophechristophe

    Core Duo, running frugal. Posting this from badwolf.
    I thought it also worked on my other 32-bit computer, with an atom processor.

    Oh, well. If it doesn’t work, then it just doesn’t work.
    You would think it should work the same across the board (all 32-bit), but I’ve run across other situations like that in the past.

    In fact, I remember signing in ONCE on elinks, and posting to the forum.
    I was never able to do it again, though. I did it just as a curiosity. But when I tried again some weeks/months later, it wouldn’t work.
    And I know I’m not crazy… (nobody laugh!)

    Maybe it’s the capabilities of the different processors? Software quirks?

    #54720
    Member
    Avatarseaken64

    Hi BobC,

    I can’t say for sure that SeaMonkey 2.49.4 will work with the P-II. But it is the last version to run on my P-III’s. As Brian mentioned you can get to older versions of SM on their website.

    SeaMonkey is not difficult to install. It does not need to be installed with the Package Installer (and doing so will install a non-working version). But the user does need to know how to uncompress the archive and find the appropriate file to launch. The instructions are on the website and can be easily followed. Once “installed” on the system the user can create a launcher for the Personal Menu or the desktop.

    I have had good success on my P-III’s by using the Package Installer, or apt or apt-get, to go ahead and install the latest version (which will not run) and let the installer set up the menu. Then I go in and over-write the installed version with the 2.49.4, or earlier, version. This allows me to use the antiX menus. But then I put a “hold” on the SeaMonkey package so that it does not get upgraded. That might be a little too difficult for a new user. May be better to just use the method outlined on the website (uncompress the archive to a folder on your system).

    I have also used NetSurf successfully. It does login to the forum but you have to use an alternate to click on the menus. I can’t remember now exactly but I can check it out and get back to you.

    [Edit – I was able to login with Netsurf but I could not use the menu. Instead, open a message thread and at the end of the thread there is a login prompt. I enter my username and password and click submit and I’m logged in. I also can’t use the menu to click on “Recent” threads. I have to browse through the sub catagories manually. I am posting this now with Netsurf]

    Links2 is also a good option. A little different than what people are used to but quite functional and with graphics. I use it from console using the frame buffer. That runs good in 256MB or 192MB RAM.

    Seaken64

    • This reply was modified 6 days, 14 hours ago by seaken64.
    • This reply was modified 6 days, 10 hours ago by seaken64.
    #54722
    Moderator
    Brian MasinickBrian Masinick

    I am logged in now with Links2. The interface is unusual, but it actually works.

    Brian Masinick

    #54723
    Moderator
    Brian MasinickBrian Masinick

    I tried using Dillo to login; unfortunately the certificate needed to authenticate was not up to date, so unless there is an effective way to update the Dillo authentication method, Dillo is only usable on this site in read-only mode as previously noted.

    Brian Masinick

    #54724
    Moderator
    AvatarBobC

    I am on a 64 bit system at the moment, and Badwolf was able to login and post. I’ll have to try again on the P II. On the P II both Badwolf and Netsurf had problems where the screen would go black in certain areas, and that’s not happening here.

    I’ve learned the P II 400 really lets me know if any programs are at all inefficient. For example on the P II, it would make sense to normally use htop instead of lxtask as a task monitor.

    #54748
    Member
    userzerouserzero

    Those teams are said to work best with the S.O. pre-installed (Windows 95, 98, etc.). As long as the user is able to get the drivers, 🙂

    My first PC, Compaq presario 7970:
    700MHz AMD Athlon (Slot A)
    Ultra ATA-66 HDD 40GB (original)
    Diamond Stealth III 16 MB S540 Graphics Card 16 MB SDRAM
    Memory 128MB, Max. 256 per slot, total 512MB
    Audio, Sound Blaster AudioPCI 128

    Installed FreeBSD 10 or 11.
    WM, TWM.
    You need to create an xorg.conf.
    Perfect as long as you use cli apps.

    If the user needs this kind of equipment, he has to suffer a bit.

    I have not tried to install a Linux system, due to the CPU lacking CMOV.

    Does the AntiX kernel support this processor? I think not.
    A list of cli or script applications for this type of machine would be better than GUI applications.

    #54749
    Member
    userzerouserzero

    Some examples,

    Youtube script, https://github.com/pystardust/ytfzf
    file manager, https://github.com/jarun/nnn
    editor, https://nllgg.nl/Ted/
    text editor, https://www.scintilla.org/ (It worked great on a 1GHZ processor)

    cmus, moc, etc. etc. etc.

    Edito: https://github.com/agarrharr/awesome-cli-apps

    • This reply was modified 6 days, 6 hours ago by userzero.
    #54764
    Moderator
    AvatarBobC

    There are many interesting programs there, userzero. I saw a couple in that awesome cli apps one that might be nice to have on my toolbar.

    I tried nnn and it could run, but I couldn’t make it look good. I tried the antiX repository version, but it didn’t have the icons.

    I tried installing from source, but it didn’t have the icons by default, either. I was able to compile and install and run.

    I couldn’t understand the “in terminal terminal fonts” and “nerd fonts”. I found a page to help install them but spent 3 hours trying and failed on all methods. I couldn’t understand how to set it up. I tried to read all the instructions and still failed I think because I don’t use or know vi. They assume you know vi, and how to change vi fonts. It’s probably something simple, but beyond my understanding. It’s very sad because the icons on a terminal looked pretty cool.
    Icons next to files

    https://github.com/jarun/nnn/wiki/Advanced-use-cases#file-icons

    SpaceFM, Midnight Commander, and Geany work well enough, even on a P II 400. I didn’t try playing a video, though, and from experience, I’m sure the download and play separately method would do much better.

    Thanks for your suggestions and links.

    • This reply was modified 5 days, 18 hours ago by BobC.
    #54769
    Forum Admin
    anticapitalistaanticapitalista

    On very old hardware, try booting without X (3 at boot menu).
    Login as user, and see if playing a video file works via mpv

    mpv /path/to/video

    This saves 20-30 MB RAM

    Philosophers have interpreted the world in many ways; the point is to change it.

    antiX with runit - leaner and meaner.

    #54777
    Moderator
    AvatarBobC

    BTW, I also installed the antiX 19.3 386 with runit version and that was working as far as running.

    There must be something wrong with how I have grub installed, though because I don’t get a grub screen, so don’t get to choose which OS to boot. I tried boot repair and update-grub, but maybe its a graphics issue…

    #54815
    Moderator
    AvatarBobC

    The nnn font problem was due to using roxterm. That is not to say it won’t work with roxterm, it just didn’t work for me no matter what I tried. I was trying to configure it manually, but have no knowledge of the use of terminal fonts in Linux other that to know what fonts I like or dislike, and I generally am able to figure out how to install a font or change which one to use..

    It all worked in 15 minutes with a terminal called terminator. I should have thought to try that many hours ago.

    I then found out I couldn’t copy and paste, so I tried gnome-terminal, since that was also on their list.

    Anyway, the program is fast and the icons are cool looking, but I much prefer Roxterm and Midnight Commander.

    I guess I learned that what I had was good enough, even for a P II 400.

    #55078
    Member
    userzerouserzero

    Tip:
    Download, nnn-nerd-static-3.5.x86_64.tar.gz
    Use some font, https://www.nerdfonts.com/font-downloads
    Enjoy…
    Read the wiki for more details.

    I have no problem with nnn-nerd-static + tilix + {FantasqueSansMono Nerf Font, Hack Nerd Font, NotoSansMono Nerd Font}.

    I have no problem with nnn-nerd-static + st-terminal + Hack Nerd Font.

    I have no problem with nnn-nerd-static + urxvt + Hack Nerd Font.
    URxvt.font: xft: Hack Nerd Font Mono: size = 9

    #55080
    Member
    userzerouserzero

    […] There must be something wrong with how I have grub installed, though because I don’t get a grub screen, so don’t get to choose which OS to boot. I tried boot repair and update-grub, but maybe its a graphics issue […]

    If grub is there, you can press the SHIFT key to display the (BIOS) menu. Or ESC for UEFI users.
    #nano /etc/default/grub
    Change,
    GRUB_TIMEOUT_STYLE = "hidden"
    with
    GRUB_TIMEOUT_STYLE = "menu"

    By default AntiX 19.2,

    GRUB_CMDLINE_LINUX_DEFAULT = "vga=791 quiet"

    Possibly vga=791 is not supported by the graph.

    The current configuration my PC,

    GRUB_CMDLINE_LINUX_DEFAULT = "quiet"
    GRUB_GFXMODE = auto
    GRUB_GFXPAYLOAD_LINUX = keep
    # GRUB_BACKGROUND = /usr/share/wallpaper/grub/back.png
    GRUB_THEME = "/usr/share/grub/themes/vimix/theme.txt" 
    • This reply was modified 13 hours, 24 minutes ago by userzero.
    #55095
    Moderator
    AvatarBobC

    userzero, thanks, this fixed the grub, giving me a text menu and no background, which is just fine:
    GRUB_TIMEOUT_STYLE = "menu"

    The vga code is changed in 19.3, but I don’t think that caused the problem. The problem started when I hooked in the second hard drive with Windows 98 on it. It’s just a very old machine, and I’m Lucky it runs at all.

    As for nnn, I am happy with RoxTerm and Midnight Commander. I did get nnn to work and look good in the end, but I have been using Norton Commander since MSDOS when it first came out, and my fingers know what to do to use the keys in Midnight Commander without even thinking.

    I reloaded badwolf and epiphany-browser and will retry them. When I tried them before I only had 256 mb in the machine, and maybe they will do better with 768 mb.

    #55110
    Member
    userzerouserzero

    ncdu -> ~/.cache

    238.5 MiB [##########] /epiphany
    78.2 MiB [### ] /vivaldi
    21.4 MiB [ ] /mozilla

    Bear in mind that I have not used Epiphany Browser much … Manjaro Linux Gnome (x64).

    https://unix.stackexchange.com/questions/208908/is-it-safe-to-remove-cache

Viewing 15 posts - 16 through 30 (of 32 total)
  • You must be logged in to reply to this topic.