Preferred Applications not working as expected (SOLVED)

Forum Forums Official Releases antiX-21/22 “Grup Yorum” Preferred Applications not working as expected (SOLVED)

  • This topic has 7 replies, 5 voices, and was last updated Nov 11-11:36 pm by rek769.
Viewing 8 posts - 1 through 8 (of 8 total)
  • Author
    Posts
  • #70744
    Member
    rek769

      I have installed Seamonkey browser and have set it (as user and root) to be the default browser. Clicking links from within the Seamonkey email or rss clients results in links opening in Seamonkey as expected. Clicking links from within any other application results in Firefox being launched. I have set the default browser to point at a desktop file I made for Seamonkey and I have also tried setting it directly to the Seamonkey executable file with the same results. Any ideas on how to correct this so that links clicked from any application use Seamonkey? Thanks in advance.

      • This topic was modified 2 years, 6 months ago by rek769.
      Attachments:
      #70747
      Member
      PPC

        It may depend on the contents of the .desktop file you created… Don’t you already have a .desktop file for seamonkey? Sorry I’m not in a computer with seamonkey installed…

        P.

        #70751
        Moderator
        caprea

          Is seamonkey also set to the default browser in the preferences of seamonkey ?
          Give an example in which application this doesn’t work, please. I just tried it and see no problems,
          but installed seamonkey with the package installer and a desktop file was made by itself in /usr/share/applications.
          Also had to set seamonkey in the preferences to default for browser and mail.

          #70759
          Forum Admin
          Dave

            That app is mainly to set the default for antiX applications. (Ex: the menu, control centre, html help file links, etc)
            There is a small function to try and set the defaults for other apps via mimeapps.list but this does not work for all other applications and likely is outdated.
            You may be able to fix this in the alternatives configuration program, but if you find a command line way to fix the issue it likely can be added to the preferred applications program.

            Computers are like air conditioners. They work fine until you start opening Windows. ~Author Unknown

            #70765
            Member
            PPC

              @Dave- would exo-preferred-applications, available in the exo-utils package be useful, for setting a system wide preference for browser, e-mail client, terminal and file manager?

              I can try make a similar to that app, in yad, to edit ~/.config/mimeapps.list, at least for browser and e-mail client… I haven’t really checked out how that config file works…

              Edit1:
              would this work, for choosing an internet browser?

              sudo update-alternatives --config x-www-browser

              Edit2:

              If the update-alternatives works, a command to set seamonkey directly would be something like this (adjust according to the path to seamonkey’s binnary):

              sudo update-alternatives --set x-www-browser /opt/seamonkey/seamonkey

              -This seems to work. I performed that change, to be on the safe side, I logged out and back in. I created a text file with a web address example:
              https://www.antixforum.com/
              and opened that text file with nano text editor. When I right clicked the link and selected to open it in the browser, the browser I selected using update-alternatives came up.
              One exception is Mozilla Thunderbird, you have to search on-line how to manually configure the browser that is used when you click a link inside Thunderbird. By default it always uses Firefox, even when it complains that’s not the default browser (hum… it smells like something Microsoft would try to pull on users…)

              P.

              • This reply was modified 2 years, 6 months ago by PPC.
              • This reply was modified 2 years, 6 months ago by PPC.
              • This reply was modified 2 years, 6 months ago by PPC.
              #70781
              Forum Admin
              Dave

                Last time I researched it (which was for antiX 19 release IIRC) there were multiple ways to set the defaults.
                – mimeapps.list, mimeinfo.cache, (/usr/share/applications:/usr/local/share/applications/:~/:~/.config/:~/.config/xdg/:~/.local/share/applications/:~/.local/share/xdg:etc…) And not every program used the same file and/or had different priorities on the files.
                http://specifications.freedesktop.org/mime-apps-spec/mime-apps-spec-1.0.1.html
                – update alternatives (debian)
                http://wiki.debian.org/DebianAlternatives
                – exo-* (xfce)
                http://docs.xfce.org/xfce/exo/start

                Then there are/was the kde programs which utilized the kde preferred applications stack. I think they are all using the updated xdg spec at this time. Gnome apps were the same way IIRC.
                There are others that do not adhere to anything and are on their own for defaults (thunderbird was one as far as I remember).

                Computers are like air conditioners. They work fine until you start opening Windows. ~Author Unknown

                #70788
                Moderator
                Brian Masinick

                  Regarding the connection between Thunderbird and Firefox, both of them represent the Email and Web Browser components previously used in Seamonkey. I suspect they were hard coded relationships, though the ability to override this ought to be available, but they don’t tend to share it without being asked.

                  --
                  Brian Masinick

                  #70791
                  Member
                  rek769

                    Is seamonkey also set to the default browser in the preferences of seamonkey ?
                    Give an example in which application this doesn’t work, please. I just tried it and see no problems,
                    but installed seamonkey with the package installer and a desktop file was made by itself in /usr/share/applications.
                    Also had to set seamonkey in the preferences to default for browser and mail.

                    Well, that was easy…I opened Seamonkey preferences and found a little button to “Set Seamonkey as Default Browser”. I did that and problem is now solved.

                    Prior, if I clicked a link in the PDF reader or in Libreoffice, Firefox would open instead…

                    Interesting that the primary default apps chooser did not do the trick as I expected…thanks for all your replies!

                  Viewing 8 posts - 1 through 8 (of 8 total)
                  • You must be logged in to reply to this topic.