[SOLVED]Problem installing udev in 17.3.1 full 64 bit

Forum Forums New users New Users and General Questions [SOLVED]Problem installing udev in 17.3.1 full 64 bit

This topic contains 14 replies, has 5 voices, and was last updated by BobC Feb 10-1:28 am.

Viewing 15 posts - 1 through 15 (of 15 total)
  • Author
    Posts
  • #18513
    Member
    Avatar
    BobC

    I’m doing a new install, and getting an error when I try to install udev. I didn’t have any other errors. Any ideas?

    $ sudo apt-get install udev
    Reading package lists… Done
    Building dependency tree
    Reading state information… Done
    Some packages could not be installed. This may mean that you have
    requested an impossible situation or if you are using the unstable
    distribution that some required packages have not yet been created
    or been moved out of Incoming.
    The following information may help to resolve the situation:

    The following packages have unmet dependencies:
    udev : Depends: libudev1 (= 232-25+deb9u8)
    E: Unable to correct problems, you have held broken packages.

    #18516
    Member
    male
    male

    then look at this:
    apt show eudev and apt show udev

    #18517
    Forum Admin
    anticapitalista
    anticapitalista

    Why are you installing udev?

    Philosophers have interpreted the world in many ways; the point is to change it.

    #18519
    Member
    Avatar
    BobC

    I had it installed on my old system. Without it, spacefm can’t mount my other hard drive partitions. By clicking on them.

    Should I be using something else?

    #18520
    Member
    Avatar
    BobC

    Thanks for the replies. In general the reload went almost perfectly. This was the only problem I hit. LOL, I’m awake now and at the machine… It sounds like I shouldn’t have udev installed at all. The system it was on was loaded in 2017. I am trying to reload the machine from a fresh install of antiX-17.3.1 full 64 bit, and installing the same packages as I had before but not installing the special nVidia drivers, and it sounds like some instructions for one of the packages at some point in time must have told me to install udev. I put the output of the apt shows at the bottom of the post

    I will try to purge udev. Purging it went ok, but spacefm still gets an error 32 when I try to click on a partition to mount it. I found that I can get around it by manually going and creating the folder as root before mounting, but it used to do it automatically. Here is the text of the error:

    Run: mount /dev/sda10
    Status: Finished with error ( exit status 32 )

    udevil: /dev/sda10 is known to mount – running mount as current user
    udevil: warning 45: options ignored for device in fstab (or specify mount point)
    mount: mount point /media/10-antiX172Lu does not exist

    ————————————

    root@dv9917:/home/bobc# apt show eudev
    Package: eudev
    Version: 232:3.2.6
    Priority: standard
    Section: main
    Maintainer: Ivan J. <parazyd@dyne.org>
    Installed-Size: 7,664 kB
    Provides: udev (= 232:232:3.2.6)
    Pre-Depends: debconf
    Depends: libblkid1 (>= 2.19.1), libc6 (>= 2.17), libkmod2 (>= 5~), libselinux1 (>= 2.1.9), adduser, libeudev1 (= 232:3.2.6), lsb-base (>= 3.0-6), util-linux (>= 2.27.1), procps
    Conflicts: hal, udev (<< 232:232:3.2.6)
    Breaks: bash-completion (<< 1:2.1), consolekit (<< 0.4.6-1), kmod (<< 14), plymouth (<< 0.9.0-7), systemd (>> 220)
    Replaces: bash-completion (<< 1:2.1), udev (>= 232)
    Homepage: https://wiki.gentoo.org/wiki/Project:Eudev
    Download-Size: 1,016 kB
    APT-Manual-Installed: yes
    APT-Sources: http://mirrors.rit.edu/mxlinux/mx-packages/antix/stretch stretch/main amd64 Packages
    Description: /dev/ and hotplug management daemon
    eudev is a daemon which dynamically creates and removes device nodes from
    /dev/, handles hotplug events and loads drivers at boot time.

    N: There is 1 additional record. Please use the ‘-a’ switch to see it
    root@dv9917:/home/bobc# apt show udev
    Package: udev
    Version: 232-25+deb9u8
    Priority: important
    Section: admin
    Source: systemd
    Maintainer: Debian systemd Maintainers <pkg-systemd-maintainers@lists.alioth.debian.org>
    Installed-Size: 7,235 kB
    Pre-Depends: dpkg (>= 1.17.14)
    Depends: libacl1 (>= 2.2.51-8), libblkid1 (>= 2.19.1), libc6 (>= 2.17), libkmod2 (>= 5~), libselinux1 (>= 2.1.9), adduser, libudev1 (= 232-25+deb9u8), lsb-base (>= 3.0-6), util-linux (>= 2.27.1), procps
    Conflicts: hal
    Breaks: bash-completion (<< 1:2.1), consolekit (<< 0.4.6-1), ifplugd (<< 0.28-19.1~), ifupdown (<< 0.8.5~), joystick (<< 1:1.4.9-1~), kmod (<< 14), plymouth (<< 0.9.0-7), systemd (<< 232-20), usb-modeswitch (<< 2.3.0+repack0-1~)
    Replaces: bash-completion (<< 1:2.1), systemd (<< 232-20)
    Homepage: https://www.freedesktop.org/wiki/Software/systemd
    Download-Size: 1,116 kB
    APT-Sources: http://security.debian.org stretch/updates/main amd64 Packages
    Description: /dev/ and hotplug management daemon
    udev is a daemon which dynamically creates and removes device nodes from
    /dev/, handles hotplug events and loads drivers at boot time.

    N: There is 1 additional record. Please use the ‘-a’ switch to see it
    root@dv9917:/home/bobc#

    • This reply was modified 2 months, 1 week ago by BobC.
    #18521
    Forum Admin
    anticapitalista
    anticapitalista

    Have a look at this:

    remove residual udev

    Philosophers have interpreted the world in many ways; the point is to change it.

    #18523
    Member
    Avatar
    BobC

    All went ok doing that, but it still doesn’t mount the drives when I click them in spacefm. Same error. I think I will reload and not run:

    apt-get update
    apt-get upgrade

    Like I have been doing after installing

    #18525
    Member
    caprea
    caprea

    mount: mount point /media/10-antiX172Lu does not exist

    Why don’t you create the mountpoint ?
    Look at your fstab what’s the mountpoint and then create it.

    Like
    sudo mkdir /media/yourmountpoint

    Then it will be available in spacefm.

    #18528
    Member
    Avatar
    BobC

    Yes, thanks for the reply, caprea. I did know that. I created the one by hand to verify that was the case.

    The problem is that I have about 25 partitions between the 2 hard drives, and 4 more machines with many partitions, and so it was nice when it created the directories for me. I thought I had done something wrong to cause it not to work anymore. From what I read there is someplace in the Debian boot process where it is supposed to build or rebuild the directories to match partitions on the drives, but they didn’t elaborate beyond that.

    Anyway, I am sitting here seeing the same problem immediately after the initial boot after install. It worked fine when I was working from the live USB, but after I installed to the hard drive and rebooted, it lost the directories even though they are listed in fstab and I said to save live desktop changes during the install. USB drives work fine, no different than before.

    Under Debian you can use the Gnome Disks GUI from what I read to rebuild fstab, but that includes systemd0 so I didn’t try to install it. I couldn’t figure out what program I would need to run to regenerate the directories.

    I suppose I could write a program to read fstab and use what is there to go create all the /media directories for each entry, but it seems to me that must already exist, if I only knew how to run it…

    #18530
    Member
    Avatar
    BobC

    Ok, I think I found the program that is supposed to do it, and it appeared to create the folder at the same time. Maybe I can get spacefm to run that for me when I click the partition…

    # udisksctl mount -b /dev/sda10
    Mounted /dev/sda10 at /media/10-antiX172Lu.

    #18531
    Member
    caprea
    caprea

    Oh, yes 25 is a lot !

    #18533
    Member
    Avatar
    BobC

    Ok, I have it fixed

    I went into SpaceFM’s, Devices, Settings, Device Handlers, Maximized the window, clicked Default and uncommented this in the Mount box, then clicked Apply and Ok

    # # udisks v2:
    udisksctl mount -b %v -o ‘%o’

    Now it works right…

    I would suggest that it should be default be able to mount partitions when in a Root window, but this will solve it for me because my /home and other settings files will be passed on to each machine loaded, so I won’t need to worry about it on other machines.

    LOL, hopefully it won’t CAUSE me any other problems having fixed it this way.

    Thanks for the help… I love my antiX!

    • This reply was modified 2 months, 1 week ago by BobC.
    #18537
    Member
    caprea
    caprea

    Thanks for sharing.

    #18547
    Member
    Avatar
    skidoo

    I went into SpaceFM’s, Devices, Settings, Device Handlers, Maximized the window, clicked Default and uncommented

    Wow, I’ve never maximized the window to notice that ~~ although Default is “ticked”, everything is outcommented.
    Regardless how the “shipped default” is configured, this spaceFM handling will probably continue to represent a source of confusion.

    #18548
    Member
    Avatar
    BobC

    I get the impression that the unnamed default is to use udevil which was created by ignorant guru who wrote spacefm.

    I had the same problem and solved it that same way on 2 different machines, one Dell and one HP, but I’m no expert on these programs, and really like using his Spacefm, so I was happy to find a way to make it work.

Viewing 15 posts - 1 through 15 (of 15 total)

You must be logged in to reply to this topic.