Problem with ALSA Sound – No Sound After Updating anti-X

Forum Forums Official Releases antiX-19 “Marielle Franco, Hannie Schaft, Manolis Glezos, Grup Yorum” Problem with ALSA Sound – No Sound After Updating anti-X

Tagged: 

  • This topic has 21 replies, 6 voices, and was last updated May 16-8:45 am by RobK88.
Viewing 7 posts - 16 through 22 (of 22 total)
  • Author
    Posts
  • #35874
    Member
    sybok
    Helpful
    Up
    0
    :D

    To be honest, I have no idea.

    I have searched for both ‘alsa’ and ‘ucm’ on my PC:

    find / -mount -iname '*<searched term>*'

    The ‘ucm’ directory is indeed present ‘/usr/share/alsa/ucm/’ but I do not know if it messed the setting up.
    The ‘alsaucm’ utility (according to its man-pages) is expected to help setting up “complex sound cards”.
    I have never heard of it before.
    Did you try it (‘alsaucm -i’)?

    #35875
    Forum Admin
    anticapitalista
    Helpful
    Up
    0
    :D

    Some thoughts.

    Do you have libasound2-plugin-equal?

    Try deleting the ~/.asoundrc (make a backup) file, reboot.

    If you don’t have ~/.asoundrc, you might need one.

    Philosophers have interpreted the world in many ways; the point is to change it.

    antiX with runit - leaner and meaner.

    #35877
    Forum Admin
    SamK
    Helpful
    Up
    0
    :D

    I tried the antiX 19 LiveCD. The sound works fine with the LiveCD.

    That proves your hardware is OK and the shipped /etc/asound.conf is OK

    I just updating anti-X and no I cannot hear any sound.

    This can be caused by playing music/sounds while simultaneously conducting an update.

    Make sure libasound2-plugin-equal is installed
    Run this command (using sudo might not be required)
    sudo aplay /usr/share/sounds/alsa/Front_Center.wav

    If the command returns something similar to this

    ALSA lib pcm_equal.c:236:(_snd_pcm_equal_open) Problem with control file .alsaequal.bin.
    aplay: main:788: audio open error: Operation not permitted

    Try the following
    https://www.antixforum.com/forums/topic/also-lost-audio-here/#post-2538

    #35880
    Member
    RobK88
    Helpful
    Up
    0
    :D

    Where would this extra ucm directory be located? Can you give me a full path?

    #35960
    Member
    stevesr0
    Helpful
    Up
    0
    :D

    re: RobK88 – where is the /ucm directory?

    I believe it is always a subdirectory within /alsa.

    The location of alsa might depend upon the version. In my install (antix 17.4), /alsa is located within /usr/share.

    I have heard that for various reasons muting of alsa output is not uncommon.

    One particular cause was a SECOND /ucm2 directory. If that exists, the sound was regained by deleting it.

    re: sybok – the alsaucm utility I am not familiar with the use of the program you mentioned earlier to deal with complex sound cards, so I can’t offer any comment about it.

    The loss of sound in the archlinux thread involving the creation of a ucm2 directory was associated with an upgrade to alsa-lib and an earlier version (1.1.9.2) solved the problem.

    Are the problems reported here associated with an update to alsa-lib? If so, what version?

    stevesr0

    stevesr0

    #35965
    Moderator
    ModdIt
    Helpful
    Up
    0
    :D

    Hi stevesr0
    ucm is in /usr/share/alsa at least on my systems
    Finding things like this is easy using synaptic installed files tab. Just look in the directorys.

    #35989
    Member
    RobK88
    Helpful
    Up
    0
    :D

    Thanks. I can confirm that I do not have the ucm2 directory. I only have the ucm directory.

    Muting on booting does not appear to be a problem on my system.
    But I found this on the Arch forums for those who have this problem.

    Output is muted after reboot

    Run the following command:

    # alsactl restore

    If the problem persists, verify that the Auto-Mute option in alsamixer is set to Disabled.

Viewing 7 posts - 16 through 22 (of 22 total)
  • You must be logged in to reply to this topic.