Problem with IceWm tray and keys not working on fresh 17.1 install

Forum Forums Official Releases antiX-17 “Heather Heyer” Problem with IceWm tray and keys not working on fresh 17.1 install

This topic contains 10 replies, has 6 voices, and was last updated by DeepDayze Mar 31-9:42 pm.

Viewing 11 posts - 1 through 11 (of 11 total)
  • Author
    Posts
  • #8366
    Member
    Avatar
    BobC

    It’s the 64 bit full version running on the Dell XPS 15. It never gets to the login screen, but wallpaper in color and conky come up. Mouse and keyboard don’t work, generally, but if I Ctrl-Alt-Bksp, I get to a normal login. If I just login again I get the same problem. If I switch to Fluxbox or JWM everything works.

    Any ideas? I don’t have it connected to the internet yet under 17.1, as its boot is controlled by a different partition and the boot options don’t carry over.

    I thought I read where someone else couldn’t run IceWM but surprisingly JWM worked, but I can”t find the post.

    #8368
    Member
    caprea
    caprea

    Sorry, cant help you here much, but this should be the post you cant find.
    https://www.antixforum.com/forums/topic/antix-17_x64-full-freezes-on-install/
    #7886

    • This reply was modified 1 year, 6 months ago by caprea.
    #8376
    Member
    Avatar
    BobC

    Thanks, Caprea. That was the post I couldn’t find. I tried the same Kernel that is working on it with 17, (4.9.0-5 64 bit standard like debian) but with the same cheat codes it panics early in the boot. It didn’t install well, though, complaining it couldn’t understand how to build the initrd. Maybe I should try to get it running on an easier machine first…

    #8386
    Member
    fungalnet
    fungalnet

    If you locate your .ice.. stuff in ~/ and relocate it temporarily, like you had never logged in to icewm do you still have the same problem? I wonder whether it is some home configuration that is throwing it off or it is deeper into the system and icewm. I can’t remember where and how does icewm has an autostart, ~/.config/.icewm/autostart? There might be something there causing it to hang.

    #8401
    Member
    Avatar
    skidoo

    icewm is “picky”, in the sense that it demands that some of its config files must be chmod +x (else it ignores ’em).
    If you copied ’em into place from another install, although the account username might be the same… the uid of the accounts may be different and, therefore the new “bubbabob” user account lacks u+x permission for those files.
    cd ~
    sudo chown -R yourusername:yourusername *
    (and inspect the files within ~/.icewm/ and compare against the copies in /etc/skel/.icewm/ to see which should be +x)

    #8409
    Member
    Avatar
    BobC

    Skidoo, Thanks, that actually did help, but I still can’t suspend/resume. I had to reboot, and when I did the problem occurred again.

    I noticed when I go to tty1 (ctrl-alt-f1) I see lots of segfault errors from icewm.

    Different kernels do or don’t have the problem, but so far I can’t find any that can both suspend/resume and run icewm on 17.1. Next I will check the iso like I should have before installing.

    #8412
    Member
    sleekmason
    sleekmason

    Howdy Bob, Concerning the kernel part, looking at dmesg for errors and lspci -k will show the drivers in use. During a rebuild I find several options in the .config that are set for general conditions and not specifically for my setup. Your own kernel build may fix the problem if options are being applied/not applied that your kernel doesn’t support. dmesg might tell you what is up.

    #8428
    Member
    Avatar
    skidoo

    but I still can’t suspend/resume

    #8437
    Member
    Avatar
    BobC

    Just to be clear, this is on the Dell XPS I7 laptop with the dual graphics, etc

    I’m getting messages in DMESG about udevd about kvm and render, and I tracked it down to they are using new groups for them, and I’m guessing I don’t have those groups,but if I add them, who should be in them?.

    from dmesg… all errors are on udevd or icewm lines and are red

    [ 62.580097] show_signal_msg: 160 callbacks suppressed
    [ 62.580099] icewm[3943]: segfault at 5600fffffff8 ip 00007fa55dd69524 sp 00007fff106ee7d8 error 4 in libc-2.24.so[7fa55dcee000+195000]
    [ 62.609124] icewm[3944]: segfault at 5561fffffff8 ip 00007fef62c7d524 sp 00007ffea9734108 error 4 in libc-2.24.so[7fef62c02000+195000]
    [ 62.638159] icewm[3945]: segfault at 55dffffffff8 ip 00007fcb47b26524 sp 00007ffc1d6f5568 error 4 in libc-2.24.so[7fcb47aab000+195000]
    [ 62.667883] icewm[3946]: segfault at 55fbfffffff8 ip 00007f4085588524 sp 00007ffd1f5755f8 error 4 in libc-2.24.so[7f408550d000+195000]
    [ 62.697434] icewm[3947]: segfault at 55eefffffff8 ip 00007fe481565524 sp 00007fff5ba86ec8 error 4 in libc-2.24.so[7fe4814ea000+195000]
    [ 62.726533] icewm[3948]: segfault at 55a1fffffff8 ip 00007f123ad86524 sp 00007ffd91a86e58 error 4 in libc-2.24.so[7f123ad0b000+195000]
    [ 62.756312] icewm[3949]: segfault at 55fcfffffff8 ip 00007f5ffc674524 sp 00007ffdd706a138 error 4 in libc-2.24.so[7f5ffc5f9000+195000]
    [ 62.784755] icewm[3950]: segfault at 55a7fffffff8 ip 00007fac9d52b524 sp 00007fff489e61a8 error 4 in libc-2.24.so[7fac9d4b0000+195000]
    [ 62.814679] icewm[3951]: segfault at 557afffffff8 ip 00007f5f04817524 sp 00007ffcc22a8c38 error 4 in libc-2.24.so[7f5f0479c000+195000]
    [ 62.844265] icewm[3952]: segfault at 5643fffffff8 ip 00007f9b140e6524 sp 00007ffe4021e018 error 4 in libc-2.24.so[7f9b1406b000+195000]
    bobc@DellXPS15:~
    $ dmesg | grep udevd
    [ 1.701954] udevd[207]: starting version 3.2.5
    [ 1.702538] random: udevd: uninitialized urandom read (16 bytes read)
    [ 1.702993] random: udevd: uninitialized urandom read (16 bytes read)
    [ 1.703991] udevd[208]: starting eudev-3.2.5
    [ 1.709655] random: udevd: uninitialized urandom read (16 bytes read)
    [ 1.722671] random: udevd: uninitialized urandom read (16 bytes read)
    [ 2.817146] udevd[450]: starting version 3.2.5
    [ 2.824732] udevd[450]: specified group ‘render’ unknown
    [ 2.825414] udevd[450]: specified group ‘kvm’ unknown
    [ 2.849067] udevd[451]: starting eudev-3.2.5
    [ 3.074555] udevd[598]: failed to execute ‘/usr/sbin/tlp’ ‘/usr/sbin/tlp auto’: Exec format error
    [ 3.074957] udevd[603]: failed to execute ‘/usr/sbin/tlp’ ‘/usr/sbin/tlp auto’: Exec format error
    [ 3.102660] udevd[483]: ignoring invalid mode ‘@DEV_KVM_MODE@’
    [ 4.514604] udevd[486]: ignoring invalid mode ‘@GROUP_RENDER_MODE@’

    https://raw.githubusercontent.com/systemd/systemd/master/NEWS

    * The “uaccess” udev tag has been dropped from /dev/kvm and
    /dev/dri/renderD*. These devices now have the 0666 permissions by
    default (but this may be changed at build-time). /dev/dri/renderD*
    will now be owned by the “render” group along with /dev/kfd.

    https://git.busybox.net/buildroot/commit/?id=f208cf296c2c7c049d11d15b6d0546214c4d0357
    package/systemd: create groups required for udevd
    udevd needs extra groups for its bundled rules:

    Mar 03 12:21:30 buildroot systemd-udevd[732]: Specified group ‘render’ unknown
    Mar 03 12:21:30 buildroot systemd-udevd[732]: Specified group ‘kvm’ unknown

    Add those missing groups.

    I will add the inxi output
    bobc@DellXPS15:~
    $ inxi -Fxz
    System: Host: DellXPS15 Kernel: 4.9.87-antix.1-amd64-smp x86_64 bits: 64 compiler: gcc v: 6.3.0
    Desktop: JWM 2.3.6 Distro: antiX-17.1_x64-full Heather Heyer 17 March 2018
    Machine: Type: Laptop System: Dell product: Inspiron 7559 v: 1.2.2 serial: N/A
    Mobo: Dell model: 0H0CC0 v: A00 serial: N/A UEFI: Dell v: 1.2.2 date: 01/22/2017
    Battery: ID-1: BAT0 charge: 72.3 Wh condition: 72.3/74.0 Wh (98%) model: SIMPLO Dell status: Full
    CPU: Topology: Quad Core model: Intel Core i7-6700HQ type: MT MCP arch: Skylake-S rev: 3
    L2 cache: 6144 KB
    flags: lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx bogomips: 41488
    Speed: 900 MHz min/max: 800/3500 MHz Core speeds (MHz): 1: 900 2: 900 3: 900 4: 900 5: 900 6: 900
    7: 900 8: 900
    Graphics: Card-1: Intel HD Graphics 530 driver: i915 v: kernel bus ID: 00:02.0
    Card-2: NVIDIA GM107M [GeForce GTX 960M] driver: nvidiafb v: kernel bus ID: 02:00.0
    Display Server: X.Org 1.19.2 driver: modesetting unloaded: fbdev,vesa resolution: 1680×1050~60Hz
    OpenGL: renderer: Mesa DRI Intel HD Graphics 530 (Skylake GT2) v: 4.5 Mesa 13.0.6 direct render: Yes
    Audio: Card-1: Intel Sunrise Point-H HD Audio driver: snd_hda_intel v: kernel bus ID: 00:1f.3
    Sound Server: ALSA v: k4.9.87-antix.1-amd64-smp
    Network: Card-1: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet Controller driver: r8169
    v: 2.3LK-NAPI port: d000 bus ID: 04:00
    IF: eth0 state: down mac: <filter>
    Card-2: Intel Wireless 3165 driver: iwlwifi v: kernel bus ID: 05:00
    IF: wlan0 state: up mac: <filter>
    Drives: HDD Total Size: 1.14 TiB used: 3.41 GiB (0.3%)
    ID-1: /dev/sda model: MTFDDAV256MBF-1A size: 238.47 GiB
    ID-2: /dev/sdb model: ST1000LM014-1EJ1 size: 931.51 GiB
    Partition: ID-1: / size: 22.51 GiB used: 3.41 GiB (15.2%) fs: ext4 dev: /dev/sda4
    here
    Sensors: System Temperatures: cpu: 38.0 C mobo: 27.8 C sodimm: 43.0 C
    Fan Speeds (RPM): cpu: 2141
    Info: Processes: 217 Uptime: 10:06 Memory: 15.60 GiB used: 697.7 MiB (4.4%) Init: SysVinit runlevel: 5
    Compilers: gcc: 6.3.0 Shell: bash 4.4.12 inxi: 2.9.05
    bobc@DellXPS15:~

    • This reply was modified 1 year, 6 months ago by BobC.
    #8567
    Member
    Avatar
    BobC

    When I compared the MD5 checksum of linuxfs to what it was supposed to be, I found it was different. I reburned the 17.1 on a different flashdrive, and the checksum came out correct this time. I reinstalled from it and IceWM comes up fine.

    This problem is SOLVED!

    #8572
    Member
    Avatar
    DeepDayze

    Yep that happens with flash drives and not just with CD’s. Some flash drives can get a bit wacky when an image is written to them.

    Real men use Linux 🙂

Viewing 11 posts - 1 through 11 (of 11 total)

You must be logged in to reply to this topic.