(SOLVED) problems with installed minimal GUI

Forum Forums News Sid Upgraders (SOLVED) problems with installed minimal GUI

  • This topic has 2 replies, 2 voices, and was last updated Feb 19-6:44 pm by stevesr0.
Viewing 3 posts - 1 through 3 (of 3 total)
  • Author
    Posts
  • #54575
    Member
    Avatarstevesr0

    Hi all,

    I had a CLI install of Sid for several months and yesterday “upgraded” to a minimal GUI install, using Openbox, tint2, feh, uxterm and leafpad.

    I tried to install Firefox and (when that failed) Chromium as browsers, but aptitude said that three packages would have to be removed (elogind, liblogind0 and libpam-elogind) and 12 (i386) packages installed.

    The three packages seem necessary for the GUI and I have an amd64 version, so I don’t want to do that.

    I have been able to install gutebrowser without aptitude complaining.

    N.B. I have the dbus version available installed – I tried installing the nosystemd version which is “older”, but aptitude kept “refusing”.

    I am wondering if there is a known issue with elogind, liblogind0 and/or libpam-elogind. These are all version 246.9.1-1.0antix1.

    Appreciate any advice referral or comments.

    stevesr0

    • This topic was modified 1 week, 1 day ago by stevesr0.
    #54582
    Forum Admin
    anticapitalistaanticapitalista

    Can you post the exact message from the terminal and your repos list.

    Make sure you have (since firefox and Chromium demand it) dbus-x11 installed.
    Palemoon does not need dbus IIRC.

    • This reply was modified 1 week, 1 day ago by anticapitalista.

    Philosophers have interpreted the world in many ways; the point is to change it.

    antiX with runit - leaner and meaner.

    #54601
    Member
    Avatarstevesr0

    Hi anticapitalista,

    Thanks for the response.

    I didn’t have dbus-x11 installed. When I installed that, then firefox and lxterminal installed without complaint. LXterminal launched ok and works fine, but firefox displayed an error message complaining about a dbus-glib-1.so.2 file not being available.

    After installing dbus-glib-1-2, firefox launches without an error message.

    So, I have marked this as solved.

    stevesr0

Viewing 3 posts - 1 through 3 (of 3 total)
  • You must be logged in to reply to this topic.