[Solved] Pulseaudio autostart

Forum Forums Orphaned Posts antiX-17 “Heather Heyer, Helen Keller” [Solved] Pulseaudio autostart

  • This topic has 13 replies, 5 voices, and was last updated Jan 6-11:10 am by spaceman.
Viewing 14 posts - 1 through 14 (of 14 total)
  • Author
    Posts
  • #4725
    Member
    spaceman

      antiX 17 Core. I installed pulseaudio and it starts and works as expect. However, it does not auto-start and I have to issue a pulseaudio -D after every restart.

      I have once again Googled myself senile. I was unsure what information would be be appropriate and pertinent: please ask I will provide. I can also install a flat build, if necessary, to test fixes.

      As always, many thanks, in advance, for your help and expertise.

      • This topic was modified 6 years, 4 months ago by spaceman.

      ~ ASUS ROG Crosshair VIII Hero ~ AMD Ryzen 7 3700X 8-Core ~ Corsair Dominator Platinum 32 GB RAM ~ M.2 SSD Samsung NVMe Evo 970 Plus 500GB ~ SSD Samsung Evo 860 500GB ~ NVIDIA Geforce GTX 1650 Super ~

      Between social reforms and revolution there exists for the social democracy an indissoluble tie. The struggle for reforms is its means; the social revolution, its aim.

      #4726
      Forum Admin
      dolphin_oracle

        what desktop evironment or window manager are you using on your core installation?

        pulseaudio should but an autostart entry in /etc/xdg/autostart. But window managers are not likely to pick those up.

        in any case, the command to use should be

        pulseaudio --start

        or if in X

        start-pulseaudio-x11

        • This reply was modified 6 years, 4 months ago by dolphin_oracle.
        • This reply was modified 6 years, 4 months ago by dolphin_oracle.
        #4728
        Member
        spaceman

          Indeed pulseaudio –start does work too. However, pa does not reload at startup.

          I’m using Xfce4 (4.12.2), d_o, there is a pulseaudio.desktop in /etc/xdg/autostart…

          ~ ASUS ROG Crosshair VIII Hero ~ AMD Ryzen 7 3700X 8-Core ~ Corsair Dominator Platinum 32 GB RAM ~ M.2 SSD Samsung NVMe Evo 970 Plus 500GB ~ SSD Samsung Evo 860 500GB ~ NVIDIA Geforce GTX 1650 Super ~

          Between social reforms and revolution there exists for the social democracy an indissoluble tie. The struggle for reforms is its means; the social revolution, its aim.

          #4730
          Forum Admin
          dolphin_oracle

            Indeed pulseaudio –start does work too. However, pa does not reload at startup.

            I’m using Xfce4 (4.12.2), d_o, there is a pulseaudio.desktop in /etc/xdg/autostart…

            ok, so check in ~/.config/autostart

            and see if there is a desktop entry overriding the default. it would also be named pulseaudio.desktop.

            It may also be beneficial to check the contents of both files (if the second one exists), as I do not know how the antiX pulseaudio is set up.

            cat /etc/xdg/autostart/pulseaudio.desktop
            cat ~/.config/autostart/pulseaudio.desktop
            #4731
            Member
            spaceman

              In X I entered start-pulseaudio-x11 and got:

              Connection failure: Connection refused
              pa_context_connect() failed: Connection refused

              The end of cat /etc/xdg/autostart/pulseaudio.desktop is

              Exec=start-pulseaudio-x11
              Terminal=false
              Type=Application
              Categories=
              GenericName=
              X-GNOME-Autostart-Phase=Initialization
              X-KDE-autostart-phase=1'

              cat ~/.config/autostart/pulseaudio.desktop is

              [Desktop Entry]
              Hidden=false

              ~ ASUS ROG Crosshair VIII Hero ~ AMD Ryzen 7 3700X 8-Core ~ Corsair Dominator Platinum 32 GB RAM ~ M.2 SSD Samsung NVMe Evo 970 Plus 500GB ~ SSD Samsung Evo 860 500GB ~ NVIDIA Geforce GTX 1650 Super ~

              Between social reforms and revolution there exists for the social democracy an indissoluble tie. The struggle for reforms is its means; the social revolution, its aim.

              #4732
              Forum Admin
              dolphin_oracle

                hmmm…

                are you running dbus? I assume so but with you running a custom core I thought I would check.

                #4733
                Member
                spaceman

                  Yes, it appears that I am.

                  ps -ef | grep dbus | grep -v grep
                  message+  2075     1  0 21:08 ?        00:00:00 /usr/bin/dbus-daemon --system
                  lightdm   2334     1  0 21:08 ?        00:00:00 dbus-launch --autolaunch 4bd2febd5bb6cdc66f935e555a385201 --binary-syntax --close-stderr
                  lightdm   2335     1  0 21:08 ?        00:00:00 /usr/bin/dbus-daemon --syslog-only --fork --print-pid 5 --print-address 7 --session
                  spaceman  2386     1  0 21:08 ?        00:00:00 dbus-launch --autolaunch 4bd2febd5bb6cdc66f935e555a385201 --binary-syntax --close-stderr
                  spaceman  2387     1  0 21:08 ?        00:00:00 /usr/bin/dbus-daemon --syslog-only --fork --print-pid 5 --print-address 7 --session
                  spaceman  2408     1  0 21:08 ?        00:00:00 /usr/bin/dbus-launch --exit-with-session --sh-syntax
                  spaceman  2410     1  0 21:08 ?        00:00:00 /usr/bin/dbus-daemon --syslog --fork --print-pid 5 --print-address 7 --session

                  ~ ASUS ROG Crosshair VIII Hero ~ AMD Ryzen 7 3700X 8-Core ~ Corsair Dominator Platinum 32 GB RAM ~ M.2 SSD Samsung NVMe Evo 970 Plus 500GB ~ SSD Samsung Evo 860 500GB ~ NVIDIA Geforce GTX 1650 Super ~

                  Between social reforms and revolution there exists for the social democracy an indissoluble tie. The struggle for reforms is its means; the social revolution, its aim.

                  #4734
                  Anonymous

                    In X I entered start-pulseaudio-x11 and got:

                    Connection failure: Connection refused
                    pa_context_connect() failed: Connection refused

                    try adding this line (or uncomment, if already present) in /etc/pulse/default.pa
                    load-module module-native-protocol-tcp auth-ip-acl=127.0.0.1
                    ^——- alternatively, you might may want to specify
                    load-module module-native-protocol-tcp auth-ip-acl=127.0.0.1;192.168.0.0/24

                    if the above doesn’t fix, check the suggestions offered in this askubuntu page: http://askubuntu.com/questions/70560/why-am-i-getting-this-connection-to-pulseaudio-failed-error/80090

                    #4736
                    Member
                    spaceman

                      Thanks skidoo. I have seen this post and looked at some of these solutions. On your suggestion I worked through each suggested fix in turn.

                      
                      "delet[e] ~/.pulse/* and restarting the sound server

                      Check (multiple).

                      check /etc/pulse/client.conf in /etc/pulse, as suggested in the warning. Make sure everything is set to its default value by commenting out every line with a leading semicolon.
                      Check. I have previous uncommented two lines:

                      autospawn = yes
                      daemon-binary = /usr/bin/pulseaudio

                      start pulseaudio in system mode, by changing the value of PULSEAUDIO_SYSTEM_START in /etc/default/pulseaudio to 1.
                      there is no /etc/default/pulseaudio file…

                      Open etc/pulse/default.pa and try commenting out all these lines:
                      .ifexists module-jackdbus-detect.so
                      load-module module-jackdbus-detect
                      .endif

                      Check. No change.

                      I’ll toss it out there as it was mentioned in passing elsewhere. Do I need the recommended package pulseaudio-module-x11?

                      I hope not because:

                      The following packages have unmet dependencies:
                       pulseaudio-module-x11 : Depends: libpulse0 (= 9.0-1.1.0nosystemd1) but 11.1-4.0nosystemd1 is to be installed
                                               Depends: pulseaudio (= 9.0-1.1.0nosystemd1)
                      E: Unable to correct problems, you have held broken packages.

                      Thanks all off to bed with pulseaudio working perfectly but still having to run pulseaudio –start.

                      • This reply was modified 6 years, 4 months ago by spaceman.

                      ~ ASUS ROG Crosshair VIII Hero ~ AMD Ryzen 7 3700X 8-Core ~ Corsair Dominator Platinum 32 GB RAM ~ M.2 SSD Samsung NVMe Evo 970 Plus 500GB ~ SSD Samsung Evo 860 500GB ~ NVIDIA Geforce GTX 1650 Super ~

                      Between social reforms and revolution there exists for the social democracy an indissoluble tie. The struggle for reforms is its means; the social revolution, its aim.

                      #4739
                      Forum Admin
                      anticapitalista

                        pulseaudio-module-x11 is only in jessie repo. It is not needed for testing/sid.

                        http://packages.debian.org/sid/pulseaudio-module-x11

                        Philosophers have interpreted the world in many ways; the point is to change it.

                        antiX with runit - leaner and meaner.

                        #4750
                        Member
                        spaceman

                          OK, I’m using testing so I don’t need it, that’s good.

                          I don’t have /etc/default/pulseaudio, perhaps we have it another location, though I did a search and came up empty? Or can I create one, from a default file? I’m in a single user environment so I suppose there’s no reason I can’t run in system mode…whatever works at this point. 😀

                          Once again thanks all.

                          • This reply was modified 6 years, 4 months ago by spaceman.

                          ~ ASUS ROG Crosshair VIII Hero ~ AMD Ryzen 7 3700X 8-Core ~ Corsair Dominator Platinum 32 GB RAM ~ M.2 SSD Samsung NVMe Evo 970 Plus 500GB ~ SSD Samsung Evo 860 500GB ~ NVIDIA Geforce GTX 1650 Super ~

                          Between social reforms and revolution there exists for the social democracy an indissoluble tie. The struggle for reforms is its means; the social revolution, its aim.

                          #4776
                          Forum Admin
                          dolphin_oracle

                            if it works, you could add a “Session and Startup” entry for “pulseaudio –start”.

                            #4780
                            Forum Admin
                            Dave

                              Why not change the exec line in the desktop file? It is still trying to use the x11 plug-in. Maybe change it to the pulseaudio -start command if the plug-in is not needed?

                              Computers are like air conditioners. They work fine until you start opening Windows. ~Author Unknown

                              #4791
                              Member
                              spaceman

                                Dave, many thanks, I did try as you suggested and there was no change.

                                dolphin_oracle you nailed it (sorta) I had check and confirmed this was the case in Session and Startup:

                                However I couldn’t edit the entry to check what it was…or find a config file…so I disabled it and created my own:
                                Ɨ
                                This appears to have nailed a small, but irritating problem.

                                Thank you guys!

                                Ɨ Actually just pulseaudio is adequate.

                                • This reply was modified 6 years, 4 months ago by spaceman.
                                • This reply was modified 6 years, 4 months ago by spaceman.
                                • This reply was modified 6 years, 4 months ago by spaceman.

                                ~ ASUS ROG Crosshair VIII Hero ~ AMD Ryzen 7 3700X 8-Core ~ Corsair Dominator Platinum 32 GB RAM ~ M.2 SSD Samsung NVMe Evo 970 Plus 500GB ~ SSD Samsung Evo 860 500GB ~ NVIDIA Geforce GTX 1650 Super ~

                                Between social reforms and revolution there exists for the social democracy an indissoluble tie. The struggle for reforms is its means; the social revolution, its aim.

                              Viewing 14 posts - 1 through 14 (of 14 total)
                              • You must be logged in to reply to this topic.