qjackctl freezes desktop

  • This topic has 9 replies, 6 voices, and was last updated May 3-12:44 pm by Xecure.
Viewing 10 posts - 1 through 10 (of 10 total)
  • Author
    Posts
  • #51221
    Member
    Avatarraf32

    Hello,

    When I open a terminal and type “qjackctl”, my desktop freezes. Mouse moves but the video freezes (conky freezes too) and I can’t click anything. I can access the console at ctrl+alt+F1, login and kill qjackctl. This happens with both the original kernel and liquorix kernel. It happens in icewm, jwm and fluxbox. But it does not happen in another machine I have with Debian Buster + LXDE.

    I have found these old posts describing this exact problem with qjackctl, but I could not understand them:
    http://linux-audio.4202.n7.nabble.com/qjackctl-freezing-desktop-td104541.html
    https://sourceforge.net/p/qjackctl/tickets/27/

    Is there some configuration I can do to fix this? Is it a bug in qjackctl? I could also not find a way to configure MIDI and audio hardware without qjackctl.

    The system is antix 19.3 base and apt says everything is up to date.

    #51231
    Moderator
    capreacaprea

    Could you try from terminal
    dbus-launch qjackctl

    #58276
    Member
    Avataramirt

    Exact same issue here, the dbus-launch qjackctl runs qjackctl without freezing the system!

    #58354
    Member
    Avatarseriousness

    This also happens to me when I try to start QJackCtl from the menu.

    Should I edit qjackctl.desktop that way?

    • This reply was modified 1 week, 4 days ago by seriousness.
    #58357
    Member
    XecureXecure

    Should I edit qjackctl.desktop that way?

    I would create a copy of qjackctl.desktop and add those dbus-launch insturctions there, and rename the Name to something like “QjackCtl with dbus” or similar.
    This way, if there are any updates, it will not override your .desktop launcher.

    #58363
    Member
    Avatarseriousness

    I placed a copy in ~/.local/share/applications/ and edited it, like I do in Ubuntu (Studio).

    How do i get to make it show in the applications menu instead of the original?

    #58364
    Member
    XecureXecure

    Try to see if this works

    The “.desktop” files that you added in ~/.local/share/applications, to be displayed in the menu and sub menu, you need to apply the command in the terminal: $ sudo desktop-menu --write-out-global and press the Enter key.

    #58371
    Member
    Avatarskidoo

    (nitpicking, for accuracy) let’s strikeout “you need to” and replace “you can”.
    That exact commandstring can be invoked by clicking the “Refresh Menu” desktop menu item.

    #58494
    Member
    Avatarseriousness

    I tried both ways with no result.

    Now I did “Menu Manager” –> Applications –> Show –> QjackCtl –> OK

    and it works – but why?

    Edit: after installing Guitarix, I had to repeat this procedure.

    • This reply was modified 1 week, 2 days ago by seriousness.
    #58521
    Member
    XecureXecure

    If the .desktop name matches, I think it will not appear in the menu except if you enable/show with menu manager.

    Probably @ModdIt can explain what he does on his system if he sees this post, as he also adds .desktop launchers to ~/.local/share/applications/

    What I usually do instead is create a copy with a different .desktop name inside /usr/share/applications instead, so that all the users in the system can use this launcher.

Viewing 10 posts - 1 through 10 (of 10 total)
  • You must be logged in to reply to this topic.