qjackctl freezes on antiX but not MX

Forum Forums General Software qjackctl freezes on antiX but not MX

  • This topic has 8 replies, 4 voices, and was last updated Oct 9-2:35 pm by strobez2017.
Viewing 9 posts - 1 through 9 (of 9 total)
  • Author
    Posts
  • #10320
    Anonymous

      I am officially stumped on this one.

      Install qjackctl. Start qjackctl. System hang. Have to switch tty and kill the process. Starting from terminal it hangs before I can even get any useful info for troubleshooting.
      In MX-Linux, qjackctl works fine.

      In antiX, I have tried installing qjackctl with –recommends, with –suggests, with both, with PulseAudio, etc. Nothing seems to work to get qjackctl to run under antiX.
      Searching the interwebs, I have found virtually nothing. Anything I could turn up is outdated, circa 2010 or older. Only things I could find had to do with QT. Tried that (changing the global theme and such).

      Any help would be much appreciated.

      This problem exists in both 32bit and 64bit. Fresh install, default repos.

      I’ll post hardware info and such when I’m at the computer with antiX currently installed.

      #10322
      Forum Admin
      anticapitalista

        If you want to run jackd with realtime priorities, the user starting jackd needs realtime permissions. Accept this option to create the file /etc/security/limits.d/audio.conf, granting realtime │
        │ priority and memlock privileges to the audio group. │
        │ │
        │ Running jackd with realtime priority minimizes latency, but may lead to complete system lock-ups by requesting all the available physical system memory, which is unacceptable in multi-user │
        │ environments. │
        │ │
        │ Enable realtime process priority?

        What did you answer to this?
        maybe the kernel is the issue?

        Philosophers have interpreted the world in many ways; the point is to change it.

        antiX with runit - leaner and meaner.

        #10325
        Anonymous

          I chose yes “enable realtime process priority” (I have chosen both yes and no on various installations on this same system; bad habit of reinstalling when I bork my system)

          Interestingly, I have no trouble running jackd on its own, real-time or otherwise, in antiX, from the a Terminal.

          I have also, on previous installations, installed the KXStudio repos and used Cadence without issue. But, the KX repos are a cluster-f**k of PPA’s and such. I would much rather use vanilla antiX/Debian if possible.

          #10326
          Anonymous
            System:    Host: delinsmin Kernel: 4.9.87-antix.1-486-smp i686 bits: 32 compiler: gcc v: 6.3.0 
                       Desktop: IceWM 1.4.2 Distro: antiX-17.1_386-full Heather Heyer 17 March 2018 
            Machine:   Type: Portable System: Dell product: Inspiron 1011 v: A06 serial: N/A 
                       Mobo: Dell model: CN0Y53 v: A06 serial: N/A BIOS: Dell v: A06 date: 07/29/2009 
            Battery:   ID-1: BAT1 charge: 52.0 Wh condition: 52.0/57.7 Wh (90%) model: SDI DELL N533P98A status: Full 
            CPU:       Topology: Single Core model: Intel Atom N270 bits: 32 type: MT arch: Bonnell rev: 2 
                       L2 cache: 512 KiB 
                       flags: nx pae sse sse2 sse3 ssse3 bogomips: 6383 
                       Speed: 1600 MHz min/max: 800/1600 MHz Core speeds (MHz): 1: 1600 2: 1600 
            Graphics:  Card-1: Intel Mobile 945GSE Express Integrated Graphics driver: i915 v: kernel bus ID: 00:02.0 
                       Display: server: X.Org 1.19.2 driver: intel unloaded: fbdev,modesetting,vesa 
                       resolution: 1024x600~60Hz 
                       OpenGL: renderer: Mesa DRI Intel 945GME x86/MMX/SSE2 v: 2.1 Mesa 13.0.6 direct render: Yes 
            Audio:     Card-1: Intel NM10/ICH7 Family High Definition Audio driver: snd_hda_intel v: kernel bus ID: 00:1b.0 
                       Sound Server: ALSA v: k4.9.87-antix.1-486-smp 
            Network:   Card-1: Broadcom Limited BCM4312 802.11b/g LP-PHY driver: wl v: kernel bus ID: 03:00.0 
                       IF: wlan0 state: up mac: <filter> 
                       Card-2: Realtek RTL8101/2/6E PCI Express Fast/Gigabit Ethernet driver: r8169 v: 2.3LK-NAPI 
                       port: 2000 bus ID: 04:00.0 
                       IF: eth0 state: down mac: <filter> 
            Drives:    HDD Total Size: 171.85 GiB used: 11.19 GiB (6.5%) 
                       ID-1: /dev/sda vendor: Seagate model: ST9120315AS size: 111.79 GiB 
                       ID-2: /dev/sdb type: USB vendor: Generic model: Flash Disk size: 60.06 GiB 
            Partition: ID-1: / size: 105.60 GiB used: 3.87 GiB (3.7%) fs: ext4 dev: /dev/sda2 
                       ID-2: swap-1 size: 4.00 GiB used: 268 KiB (0.0%) fs: swap dev: /dev/sda1 
            Sensors:   System Temperatures: cpu: 57.0 C mobo: N/A 
                       Fan Speeds (RPM): N/A 
            Info:      Processes: 147 Uptime: 4h 48m Memory: 993.8 MiB used: 405.5 MiB (40.8%) Init: SysVinit runlevel: 5 
                       Compilers: gcc: 6.3.0 Shell: bash v: 4.4.12 inxi: 3.0.08 
            #10675
            Anonymous

              Well, I tried 4 different kernels from the repos. None of them made a difference in running qjackctl. As best as I can tell, it has something to do with QT. Exactly what, I have no idea.

              For now, I am throwing this on the back-burner, as I have no idea where to go from here. If anyone has some idea or a fix, that’d be great.

              #12213
              Member
              strobez2017

                Hiya Jesse

                I do not actually have a fix for this but I think the issue is related to a package called “libreadline6”

                If you Google “libreadline6 jack

                or “libreadline6 kxstudio

                or “qjackctl freezes libreadline6

                you will see some of these results below

                http://www.reddit.com/r/linuxaudio/comments/6ah1x4/debian_testing_kxstudio_repository/
                this page doesn’t mention the freezing issue but the fix suggested is to “manually” install libreadline6. I tried that but it didn’t fix the freezing issue. The user has since been deleted but it was flaktx if I remember correctly. He must have deleted that Reddit account for some reason

                http://github.com/KXStudio/Repository/issues/170
                discussion of libreadline6 dependency

                http://packages.ubuntu.com/xenial/sound/jackd2
                mentions libreadline6

                http://bugs.bareos.org/view.php?id=941
                suggests creating a “fake” package

                The results above are not all related to AntiX but you’ll see lots of stuff to do with Debian Stretch if you keep Googling.

                I’ve been trying to find another link that said the issue is related to the Window manager. I was using icewm, I tried other Window Managers but the issue persisted.

                I’ve kind of given up on the the issue but maybe these links above will help you – or the issue has been resolved now.

                tl;dr – jack needs a package which is not available

                Good luck to you!

                Steve

                "Futh is stranger than triction"

                #12215
                Anonymous

                  Wow! That is far more information than I had been able to gather myself. Much obliged.

                  I, too, still can’t seem to get qjackctl to run in antiX. Runs fine in MX. Seems to be an odd combination of factors causing the issue for most people. Only thing in common I have found is not using a “standard” distro and not using a “standard” WM, though one bug report I found the person was using stock ubuntu.

                  One of these days when the stars align, perhaps qjackctl will run in antiX on one of my machines. Hahaha. Until then, I’ll just use MX.

                  Thank you for sharing what you’ve learned. I may just dive into this deeper when I get a spare moment.

                  #12232
                  Forum Admin
                  Dave

                    Have you checked the forum archive? I know it has been run on antix before, in particular the user that set it up the most (iirc) was Eino.
                    I might even have his respins on my server still

                    Edit: Yes they appear quite old but here they are
                    http://antixlinux.com/music/
                    They are probably a little old to be running but maybe between them and the forum archive posts enough info can be gleaned to make things work.

                    • This reply was modified 5 years, 10 months ago by Dave.

                    Computers are like air conditioners. They work fine until you start opening Windows. ~Author Unknown

                    #12470
                    Member
                    strobez2017

                      Note: this has now been raised here too:
                      https://www.antixforum.com/forums/topic/qjackctl-freezes-system/

                      "Futh is stranger than triction"

                    Viewing 9 posts - 1 through 9 (of 9 total)
                    • You must be logged in to reply to this topic.