qjackctl freezes my system

Forum Forums New users New Users and General Questions qjackctl freezes my system

Tagged: , ,

  • This topic has 6 replies, 3 voices, and was last updated Oct 9-2:31 pm by strobez2017.
Viewing 7 posts - 1 through 7 (of 7 total)
  • Author
    Posts
  • #12392
    Member
    parsiplo

      Hi everyone I’ve had no luck to run qjackctl. When i try i have to go tty and kill it. I’ve just tried on cli and everithing seems ok but… I don’t know probably an old misconfiguration? ANyone knows what could be the cause?

      • This topic was modified 5 years, 9 months ago by parsiplo.
      Attachments:
      #12400
      Forum Admin
      rokytnji

        Howdy and Welcome. Post a inxi -Fxz

        So members here can have more info on what you have AntiX running on.

        Sometimes I drive a crooked road to get my mind straight.
        I don't suffer from insanity. I enjoy every minute of it.
        Motorcycle racing is rocket science.

        Linux Registered User # 475019
        How to Search for AntiX solutions to your problems

        #12437
        Member
        parsiplo

          It’s just a miserable eepc but the fact is that it runs so faster with this distro I can’t give it I had tried antix17 live on my desktop (even if it’s not more than a pentium 4) and it show the same exact problem.

          To me it seems that “connect call to ……………. (no such file…) But really I don’t know I’m just an average user.

          System:    Host: parsipleee Kernel: 4.10.1-antix.1-686-smp-pae i686 bits: 32 gcc: 6.3.0
                     Desiktop: IceWM 1.3.12+mod+20170325.1
                     Distro: antiX-16_386-full Berta Cáceres 26 June 2016
          Machine:   Device: laptop System: ASUSTeK product: 1011PX v: x.x serial: N/A
                     Mobo: ASUSTeK model: 1015PE v: x.xx serial: N/A
                     BIOS: American Megatrends v: 1401 date: 08/30/2011
          Battery    BAT0: charge: 36.2 Wh 100.0% condition: 36.2/47.5 Wh (76%)
                     model: ASUS 1015PE status: Full
          CPU:       Dual core Intel Atom N570 (-HT-MCP-) arch: Bonnell rev.10 cache: 512 KB
                     flags: (lm nx pae sse sse2 sse3 ssse3 vmx) bmips: 6666
                     clock speeds: max: 1667 MHz 1: 1667 MHz 2: 1667 MHz 3: 1667 MHz 4: 1333 MHz
          Graphics:  Card: Intel Atom Processor D4xx/D5xx/N4xx/N5xx Integrated Graphics Controller
                     bus-ID: 00:02.0
                     Display Server: X.Org 1.19.3 drivers: intel (unloaded: modesetting,fbdev,vesa)
                     Resolution: 1024x600@60.00hz
                     OpenGL: renderer: Mesa DRI Intel Pineview M x86/MMX/SSE2
                     version: 2.1 Mesa 13.0.6 Direct Render: Yes
          Audio:     Card Intel NM10/ICH7 Family High Def. Audio Controller
                     driver: snd_hda_intel bus-ID: 00:1b.0
                     Sound: Advanced Linux Sound Architecture v: k4.10.1-antix.1-686-smp-pae
          #12447
          Forum Admin
          rokytnji

            Thanks.

            Maybe? Open your terminal. Try this to go to a certain section of your install

            cd /dev/shm/jack-1000/default

            After the terminal prompt takes you into that room
            Look around with this

            ls -l

            Sometimes I drive a crooked road to get my mind straight.
            I don't suffer from insanity. I enjoy every minute of it.
            Motorcycle racing is rocket science.

            Linux Registered User # 475019
            How to Search for AntiX solutions to your problems

            #12449
            Member
            parsiplo

              It points to /run/and/thesameof/the-error but it is empty

              I tried to tweek something in ~/.config/rncbc.org/QjackCtl.conf with still no luck

              [Splitter]
              AudioConnectView\sizes=266, 88, 266
              MidiConnectView\sizes=34, 20, 34
              AlsaConnectView\sizes=34, 20, 34
              PatchbayView\sizes=34, 20, 34
              InfraClientSplitter\sizes=12, 12
              [Settings]
              Server=jackd
              ServerName=
              Realtime=true
              SoftMode=false
              Monitor=false
              Shorts=false
              NoMemLock=false
              UnlockMem=false
              HWMon=false
              HWMeter=false
              IgnoreHW=false
              Priority=0
              Frames=256
              SampleRate=96000
              Periods=6
              WordLength=16
              Wait=21333
              Chan=0
              Driver=alsa
              Interface="hw:Intel,0"
              Audio=0
              Dither=0
              Timeout=500
              InDevice=
              OutDevice=
              InChannels=0
              OutChannels=0
              InLatency=0
              OutLatency=0
              StartDelay=2
              Verbose=false
              PortMax=256
              MidiDriver=nessuno
              ServerSuffix=
              [History]
              ServerPrefixComboBox\Item1=jackd
              ServerPrefixComboBox\Item2=jackdmp
              ServerPrefixComboBox\Item3=jackstart
              ServerNameComboBox\Item1=(predefinito)
              XrunRegexComboBox\Item1=xrun of at least ([0-9|\\.]+) msecs
              XrunRegexComboBox\Item2=XRUN di ([0-9|\\.]+) msecs al massimo
              MessagesLogPathComboBox\Item1=qjackctl.log
              ServerConfigNameComboBox\Item1=.jackdrc
              PostStartupScriptShellComboBox\Item1=/usr/bin/pajackconnect start &
              ShutdownScriptShellComboBox\Item1=/usr/bin/pajackconnect stop &
              PostShutdownScriptShellComboBox\Item1=/usr/bin/pajackconnect reset &
              [Program]
              Version=0.3.12
              [Presets]
              DefPreset=(predefinito)
              [Options]
              Singleton=true
              StartJack=false
              StopJack=true
              StartupScript=false
              StartupScriptShell=
              PostStartupScript=false
              PostStartupScriptShell=
              ShutdownScript=false
              ShutdownScriptShell=
              PostShutdownScript=false
              PostShutdownScriptShell=
              StdoutCapture=true
              XrunRegex=xrun of at least ([0-9|\\.]+) msecs
              ActivePatchbay=false
              ActivePatchbayPath=
              MessagesLog=true #it was false
              MessagesLogPath=qjackctl.log
              BezierLines=false
              TimeDisplay=0
              TimeFormat=0
              MessagesFont="Tribun ADF Med Std,10,-1,5,50,0,0,0,0,0"
              MessagesLimit=true
              MessagesLimitLines=1000
              DisplayFont1="Tribun ADF Med Std,14,-1,5,75,0,0,0,0,0"
              DisplayFont2="Tribun ADF Med Std,8,-1,5,50,0,0,0,0,0"
              DisplayEffect=true
              DisplayBlink=true
              JackClientPortAlias=0
              JackClientPortMetadata=false
              ConnectionsIconSize=0
              ConnectionsFont="Tribun ADF Med Std,10,-1,5,50,0,0,0,0,0"
              QueryClose=true
              KeepOnTop=false
              SystemTray=false
              StartMinimized=false
              DelayedSetup=false
              ServerConfig=true
              ServerConfigName=.jackdrc
              ServerConfigTemp=false
              QueryShutdown=true
              AlsaSeqEnabled=true
              DBusEnabled=false
              AliasesEnabled=false
              AliasesEditing=false
              LeftButtons=true
              RightButtons=true
              TransportButtons=true
              TextLabels=true
              BaseFontSize=0
              [Defaults]
              PatchbayPath=
              MessagesStatusTabPage=0
              ConnectionsTabPage=0
              SessionSaveVersion=true
              [Geometry]
              qjackctlMessagesStatusForm\x=1
              qjackctlMessagesStatusForm\y=155
              qjackctlMessagesStatusForm\width=569
              qjackctlMessagesStatusForm\height=279
              qjackctlMessagesStatusForm\visible=false
              qjackctlSessionForm\x=0
              qjackctlSessionForm\y=0
              qjackctlSessionForm\width=566
              qjackctlSessionForm\height=400
              qjackctlSessionForm\visible=false
              qjackctlConnectionsForm\x=0
              qjackctlConnectionsForm\y=0
              qjackctlConnectionsForm\width=718
              qjackctlConnectionsForm\height=287
              qjackctlConnectionsForm\visible=false
              qjackctlPatchbayForm\x=0
              qjackctlPatchbayForm\y=0
              qjackctlPatchbayForm\width=874
              qjackctlPatchbayForm\height=369
              qjackctlPatchbayForm\visible=false
              qjackctlMainForm\x=427
              qjackctlMainForm\y=383
              qjackctlMainForm\width=577
              qjackctlMainForm\height=106
              qjackctlMainForm\visible=true
              

              Did not find any log useful, I give up for now, it is not crucial to have qj. If anybody has news i’ll check on those days

              • This reply was modified 5 years, 9 months ago by rokytnji.
              #12461
              Forum Admin
              rokytnji

                And dmesg has no info on the freezes?

                dmesg | tail

                I am kinda a limited trouble shooter and am slow on the take sometimes. Sound and jack are not my strong points.

                I kinda wish Eino was in this thread.

                Sometimes I drive a crooked road to get my mind straight.
                I don't suffer from insanity. I enjoy every minute of it.
                Motorcycle racing is rocket science.

                Linux Registered User # 475019
                How to Search for AntiX solutions to your problems

                #12467
                Member
                strobez2017

                  Hi all

                  I’ve been battling this for a while now too (launch qjackctl then the system freezes).

                  I’m going to try some of the suggestions on this page:

                  http://github.com/rncbc/qjackctl/issues/13

                  Also, it’s been discussed on this forum before (but not solved). See below link:
                  https://www.antixforum.com/forums/topic/qjackctl-freezes-on-antix-but-not-mx/

                  I had given up on it but now I’m determined to get this solved.

                  Good luck and I’ll try let you know if I get anywhere with this.

                  • This reply was modified 5 years, 9 months ago by strobez2017.
                  • This reply was modified 5 years, 9 months ago by strobez2017.

                  "Futh is stranger than triction"

                Viewing 7 posts - 1 through 7 (of 7 total)
                • You must be logged in to reply to this topic.