Qt5 Settings

  • This topic has 3 replies, 2 voices, and was last updated Nov 6-1:02 pm by seriousness.
Viewing 4 posts - 1 through 4 (of 4 total)
  • Author
    Posts
  • #70376
    Member
    seriousness

      Hello, qt5ct complains that “The QT_QPA_PLATFORMTHEME environment variable is not set (required value: qt5ct )”.

      But:

      $ cat /etc/environment
      QT_QPA_PLATFORMTHEME=qt5ct
      $ echo $QT_QPA_PLATFORMTHEME
      (empty)

      Why is the variable not set?

      #70380
      Member
      Xecure

        You are right. I will investigate to see if this was a Debian thing or if it is related to any of the changes in antiX21 (be it the login manager, services or something else).

        I will provide a temporal workaround after some investigation.

        antiX Live system enthusiast.
        General Live Boot Parameters for antiX.

        #70382
        Member
        Xecure

          The bug is extremely stupid and easy to fix.
          1. edit /etc/environment
          sudo geany /etc/environment
          2. Add a new line after QT_QPA_PLATFORMTHEME=qt5ct
          3. Save and reboot.

          For some reason the missing line under the variable gives errors.

          antiX Live system enthusiast.
          General Live Boot Parameters for antiX.

          #70402
          Member
          seriousness

            Thanks, Xecure! Sometimes it’s the little things…

          Viewing 4 posts - 1 through 4 (of 4 total)
          • You must be logged in to reply to this topic.