Re-starting machine from inactivity since 2020

Forum Forums New users New Users and General Questions Re-starting machine from inactivity since 2020

  • This topic has 13 replies, 6 voices, and was last updated Oct 8-3:31 pm by Budgie.
Viewing 14 posts - 1 through 14 (of 14 total)
  • Author
    Posts
  • #116459
    Member
    Budgie

      I am returning to Antix as a prodigal after a period of no use. I have antiX-19.2.1_386-base Hannie Schaft 29 March 2020 installed on my IBM T42 (32 bit) laptop which has not even been turned on since Covid.

      I have just charged and turned on my system and to the great credit of IBM & Antix, after a bios warning of requiring some checks after nearly 900 days inactivity, it has started, allowed log in, connected to LAN, started myKeePassXC password manager and allowed me to re-connect to pCloud. In fact it is working well as far as I can recall.

      Purpose of this post is to ask if there are any updates I should do to keep my system healthy. I would like to update before embarking on any system upgrade as I need to read up on developments since 2020. Any advice, do’s or dont’s would be welcome.

      Also saying Hi to all my previous correspondents who have helped me so much in the past after a long time away.
      Regards,
      Budgie.

      #116467
      Member
      Budgie

        Further to my post above I have a problem with some of the repo sites being used in my existing system. How may I refresh these to use the correct repo. I am getting 404 errors as in:-

        alastair@T42antix1:~
        $ sudo apt-get update
        Hit:1 http://ftp.uk.debian.org/debian buster-updates InRelease
        Hit:2 http://deb.debian.org/debian buster-backports InRelease                  
        Hit:3 http://security.debian.org buster/updates InRelease                      
        Hit:4 http://ftp.uk.debian.org/debian buster InRelease                         
        Ign:5 http://anorien.csc.warwick.ac.uk/mxlinux/packages/antix/buster buster InRelease
        Err:6 http://anorien.csc.warwick.ac.uk/mxlinux/packages/antix/buster buster Release
          404  Not Found [IP: 137.205.124.72 443]
        Reading package lists... Done
        E: The repository 'http://anorien.csc.warwick.ac.uk/mxlinux/packages/antix/buster buster Release' no longer has a Release file.
        N: Updating from such a repository can't be done securely, and is therefore disabled by default.
        N: See apt-secure(8) manpage for repository creation and user configuration details.
        

        I have forgotten everything so better I ask than mess up my system,
        Budgie

        #116504
        Member
        abc-nix

          Change the antiX repos with the repo-manager program (Control Centre, Software, Repo Manager).

          #116536
          Member
          mcpderez

            Welcome back! I’ve used a T42 and T43 while testing antiX-23 and they run it (no pun intended) quite well.

            #117005
            Member
            Budgie

              Hi and many thanks for the replies. I have changed repo site and all is well so far.

              What I am now considering is the upgrade. I assume this may need to be one step at a time or can I just do it at once.
              Still reading/catching up but are there any specific dos’ and dont’s?

              Budgie.

              #117007
              Member
              PPC

                If by “upgrade” you mean, antiX 23, I would suggest trying it live, to check out it’s compatibility with your hardware (you may expect audio problems, with the Full version, because it uses a non ideal way to start pipewire and it may fail on some devices, but there’s a fix here on the forum for that).
                If you like antiX 23 and it runs well on your hardware, I would recommend to back up important files and simply install it (do not try to update your old version of antiX to it, it may cause problems).
                antiX 23 is much easier to configure and use than antiX 19, it also has a more modern base, so you can install newer version of most packages, but other than that you are not missing much- if antiX 19 works for you, stick with it until it’s EOL.

                Edit: On my 32bits laptop I still run antiX 22. I use seamonkey as Web browser, but also Firefox 115ESR that runs great (I’m using it right now to write this), for my office needs, I usually use OpenOffice’s 32bits appimage (that a forum user makes available here)- because it still has the quick-launcher. I created a toolbar entry to start the quick-launcher and use it all the time. If I want to make sure the documents are as compatible as possible (i.e. meant to be used by someone, on MS Office or LibreOffice, I open then on LibreOffice and export them to a more modern version of the Open Document format or to MS format- docx, etc). For web browsing and office work, this old laptop works almost as fast as any modern computer. To stream YouTube videos I suggest using Smtube (or hunting down and installing the last 32bits .deb of “Min” browser, that is outdated, but it’s the best way to stream YouTube videos on this old 32bits hardware, inside a browser). To watch videos, I use Xine media player (available in Package Installer) that, on some hardware, works wonders. It allows me to play some full HD videos in a fully watchable way (I do not even notice the frames it skips).
                So antiX, even on 32bits hardware can be used for Web Browsing, Youtube Streaming, E-mail, Office work, listening to music, watching local videos, etc. Unfortunately, video streaming services (like Netflix, Max, Disney+, etc do not work on 32bits hardware).

                P.

                • This reply was modified 9 months, 1 week ago by PPC.
                • This reply was modified 9 months, 1 week ago by PPC.
                #117013
                Moderator
                caprea

                  If you didn’t update your antiX19 nearly three years now, I would first carefully run
                  sudo apt update
                  followed by a
                  sudo apt upgrade

                  Your main focus should be on whether packages shall be removed.Then maybe better ask here first. If the upgrade went well you can do a
                  sudo apt full-upgrade
                  to follow.

                  Edit: And like PPC said, we are already on antiX23, it sure worth a try on a live stick.

                  • This reply was modified 9 months, 1 week ago by caprea.
                  #119350
                  Member
                  Budgie

                    Hi and very many thanks for all the help. About half a dozen boots later with all working well and starting the machine on a new day I ran into a problem. After a couple of failed startups the hard drive gave up entirely.

                    Not wanting to junk the faithful machine I bought a new drive for GBP10.00 which is now installed and I have just booted it using the antiX-23_386-full.iso on an USB stick. The boot worked and I was presented with a bunch of network tabs. Enabled a wifi connection and I now have a working machine but…

                    I cannot see any option to install on hard drive.

                    I have no idea what the default passphrase is for getting superuser privileges.

                    And the new website does not appear to have a button to create a new thread so it is a good job I found this!!!

                    Not urgent but would appreciate some help please until I get back in the swing of things antiX.

                    #119352
                    Forum Admin
                    rokytnji

                      Installer should be applications menu or on desktop if running rox desktop or zzzfm desktop in icewm.

                      Edit. For passwords running live/ Try demo or root.

                      Was md5sum check done?

                      • This reply was modified 8 months, 3 weeks ago by rokytnji.

                      Sometimes I drive a crooked road to get my mind straight.
                      I don't suffer from insanity. I enjoy every minute off it.
                      Motorcycle racing is rocket science.

                      Linux Registered User # 475019
                      How to Search for AntiX solutions to your problems

                      #119370
                      Member
                      abc-nix

                        If not in the right-click menu-

                        Hi losterhoudt, the best kept secret of antiX, sudo minstall
                        should, if my foggy head is remembering correctly get you on your way.
                        Have used sudo -E /usr/sbin/minstall so if above does not work for you pls try it.

                        Remember to update before installing.
                        Also, check the antiX Tips to see correct user and password.

                        #119380
                        Member
                        Budgie

                          Installer should be applications menu or on desktop if running rox desktop or zzzfm desktop in icewm.

                          Edit. For passwords running live/ Try demo or root.

                          Was md5sum check done?

                          My screen shows I am running zzz-icewm.
                          I use sha256sum and yes.
                          I had problems with the USB so had to abort this and have burnt a base iso. I have been able to run this to the extent that I could format the new drive. After booting again I get the antiX starting screen it then starts me in a cli installation. Is that because the base iso is just that? If so is there a crib sheet to get me up to running a basic antiX from my hardrive and then do a full installation with my network connected?

                          Guidance would be appreciated please.

                          #119386
                          Member
                          abc-nix

                            Core and net: no graphical environment (fit in a CD)
                            Base and full: bring graphical environment (don’t fit in a CD, but yes in a DVD)

                            If you have issues reaching a graphical environment with antiX base, try one of the boot parameters that are related to xorg. Like:
                            nomodeset – Don’t use the kernel video driver and fallback to xorg driver
                            xorg=safe – use vesa driver
                            xorg=intel – specifically use the intel driver for intel graphics support

                            #119396
                            Member
                            Budgie

                              OK and thanks. I have turned up some older CDs with version 19.2 base butt even this gave me problems. I am beginning to suspect the bios and mobo and it is possible there was no problem with my original drive.
                              Will take a break and start over tomorrow.
                              Many thanks,
                              Budgie

                              #119525
                              Member
                              Budgie

                                All attempts at installing the latest version failed but I had a CD of 19.2 base which ran and also an older DVD of v 19 full and this ran too but none managed the new hard disk correctly. As I knew I could boot a DVD I burnt a 19.5 base and this has installed correctly and completely so a happy ending although the machine is definitely having some firmware issues with changing boot order etc. However since what I needed is all OK shall close this thread. Thanks for the moral support and encouragement; just having somebody on the other end of my questions helps.
                                Thanks again,
                                Budgie

                              Viewing 14 posts - 1 through 14 (of 14 total)
                              • You must be logged in to reply to this topic.