Recent NVIDIA changes?

Forum Forums New users New Users and General Questions Recent NVIDIA changes?

Tagged: 

  • This topic has 8 replies, 3 voices, and was last updated Oct 4-9:19 am by GeoffC.
Viewing 8 posts - 1 through 8 (of 8 total)
  • Author
    Posts
  • #68195
    Member
    GeoffC

      Since 19.3 was released last year, I have been happily using a live USB (full edition) on an ancient desktop (P4 CPU, 1G RAM, NVIDIA NV17 – GeForce4 MX 420) without too many issues. Yesterday I decided to boot into “safe video” mode to see what it was like. It gave me a dreadful low resolution screen (maybe 640 x 480?) with huge icons but tiny blurry/fuzzy font which was barely decipherable. So I rebooted, thinking it would return to normal – but alas, I landed at the console login.

      After many hours of trying to troubleshoot this, slim suddenly reappeared but I have no idea why. Unfortunately though, it is still stuck with the 640 x 480 resolution with the tiny blurry font like “safe video” mode – it is virtually unusable. Prior to AntiX booting (eg: in PLoP, the boot menu and the scrolling boot messages) the resolution and clarity is fine. The problem only happens from the slim login stage.

      Eventually, I tried swapping it for another AntiX live usb which I use on an old laptop, but this does exactly the same thing! However, when I put it back in the laptop (integrated graphics), it works fine with 1024 x 768. So I thought maybe the video hardware had somehow been reset on the desktop or something, since it did the same thing with both (unrelated) live usbs.

      Next I tried an old live usb of Lubuntu on the desktop, but that works fine! I noticed it is using the NOUVEAU driver, whereas the AntiX usbs keep using the VESA driver.

      So finally, I built a new AntiX live usb from an old snapshot (of the original usb above) taken last November. This also works fine on the desktop, and is using the NOUVEAU driver.

      This makes me wonder if an update has changed the modules recently, because my system worked fine until yesterday, and the older snapshot (which hasn’t been updated) still works fine. Maybe booting in “safe video” mode was a red herring that just happened to coincide with the problem? The one thing the two live usbs that fail have in common is they are both fully updated.

      I could start from scratch and build a new live usb for a clean start but that is not going to solve the problem if something has changed in the AntiX system, since it will break again as soon as I update it…

      Can anyone cast any light on this for me? (assume fairly minimal linux expertise please…)

      #68204
      Member
      GeoffC

        whoops

        #68205
        Member
        GeoffC

          Additionally, if I try to force use of the nouveau module with boot-parameters such as:

          xorg=nouveau nouveau.modeset=1

          … I still end up at the console login prompt. Following is an extract from /var/log/Xorg.0.log

          [    51.630] (II) LoadModule: "nouveau"
          [    51.630] (II) Loading /usr/lib/xorg/modules/drivers/nouveau_drv.so
          [    51.684] (II) Module nouveau: vendor="X.Org Foundation"
          [    51.684] 	compiled for 1.20.3, module version = 1.0.16
          [    51.684] 	Module class: X.Org Video Driver
          [    51.684] 	ABI class: X.Org Video Driver, version 24.0
          [    51.684] (II) NOUVEAU driver Date:   Mon Jan 28 23:25:58 2019 -0500
          [    51.684] (II) NOUVEAU driver for NVIDIA chipset families :
          [    51.684] 	RIVA TNT            (NV04)
          [    51.684] 	RIVA TNT2           (NV05)
          [    51.684] 	GeForce 256         (NV10)
          [    51.684] 	GeForce 2           (NV11, NV15)
          [    51.684] 	GeForce 4MX         (NV17, NV18)
          [    51.684] 	GeForce 3           (NV20)
          [    51.684] 	GeForce 4Ti         (NV25, NV28)
          [    51.684] 	GeForce FX          (NV3x)
          [    51.685] 	GeForce 6           (NV4x)
          [    51.685] 	GeForce 7           (G7x)
          [    51.685] 	GeForce 8           (G8x)
          [    51.685] 	GeForce 9           (G9x)
          [    51.685] 	GeForce GTX 2xx/3xx (GT2xx)
          [    51.685] 	GeForce GTX 4xx/5xx (GFxxx)
          [    51.685] 	GeForce GTX 6xx/7xx (GKxxx)
          [    51.685] 	GeForce GTX 9xx     (GMxxx)
          [    51.685] 	GeForce GTX 10xx    (GPxxx)
          [    51.836] (EE) [drm] Failed to open DRM device for pci:0000:01:00.0: -19
          [    51.982] (EE) [drm] Failed to open DRM device for pci:0000:01:00.0: -19
          [    51.982] (EE) No devices detected.
          [    51.982] (EE) 
          Fatal server error:
          [    51.982] (EE) no screens found(EE) 
          [    51.982] (EE) 
          
          #68208
          Moderator
          caprea

            Hi GeoffC, on the live usb for the desktop is there anything relevant blacklisted (nouveau or nvidia) in /etc/modprobe.d/ or /usr/lib/modprobe.d/ ?

            Is there might a /etc/X11/xorg.conf file ? What about leftovers in the bootparameters ?

            I think this is unlikely caused by updates, even though it is irritating that the live usb for the old laptop seems to do the same.

            #68251
            Member
            GeoffC

              Hi caprea, thanks for replying. Yes you’re right – there is a file /etc/modprobe.d/live-blacklist.conf which includes the following lines (among others):

              blacklist nouveau
              blacklist nvidia

              Also, /usr/lib/modprobe.d/no-mode-set.conf has a line:

              options nouveau modeset=0

              There is a /etc/X11/xorg.conf file, which changes depending on what I’ve been trying. At the moment it contains:

              Section "Device"
              	Identifier 	"Device0"
              	Driver		"vesa"
              	BusID		"PCI:01@0:00:0"
              EndSection

              I have tried using “nouveau” here instead of “vesa” but it has the same result as xorg=nouveau as a boot-parameter (as above).

              I’m not sure how to check for “leftovers in the bootparameters”. The run string in /var/log/Xorg.0.log seems to be as I would expect.

              I think this is unlikely caused by updates, even though it is irritating that the live usb for the old laptop seems to do the same.

              Yes, I guess it’s probably just because the laptop live usb was already using the VESA module anyway – it doesn’t have a graphics card to deal with.

              Should I try removing the blacklist items (and/or no-mode-set entry for nouveau) from those files?
              What is most puzzling is that it was all working fine yesterday until I tried “safe video” mode 🙂

              #68291
              Anonymous

                > how to check for “leftovers in the bootparameters”

                This terminal command will show the full bootline:
                cat /proc/cmdline

                #68303
                Member
                GeoffC

                  Hi caprea, thanks to your clever suggestion I now have my system back to normal – I’m so glad to see it functioning properly again and I have learnt all sorts of new things trying to get it sorted out. I now have a completely revised appreciation of the virtual consoles and fbcondecor!

                  I removed both the blacklist entries and the modeset entry, and returned the xorg.conf Driver to “nouveau” then rebooted, and dear old slim appeared in perfect resolution again! I am so happy to have this sorted out – thanks for your help! I also did the same on the laptop live usb in case I ever use it on the desktop again 🙂

                  It would be good to know where the blacklist entries originated, in case I have this issue again. Are they generated as part of the “safe video” mode startup? They presumably weren’t there before, since the system had no problems until I tried “safe video” mode. If so, shouldn’t they be removed on exit from “safe video” mode? Anyway, thanks again for your help – I’m most grateful.

                  #68309
                  Member
                  GeoffC

                    The other thing I would like to discover is why the VESA module was stuck in 640 x 480 mode even though I wasn’t using a “safe video” boot. ARandR only offered the one resolution 640 x 480 when VESA was being used, and xrandr wouldn’t let me set the output to use a different mode – it just gave an error each time.

                    The /var/log/Xorg.0.log shows the other resolutions being ignored:

                    [    30.275] (II) VESA(0): Total Memory: 1024 64KB banks (65536kB)
                    [    30.275] (II) VESA(0): <default monitor>: Using hsync range of 30.00-83.00 kHz
                    [    30.275] (II) VESA(0): <default monitor>: Using vrefresh range of 55.00-75.00 Hz
                    [    30.275] (II) VESA(0): <default monitor>: Using maximum pixel clock of 145.00 MHz
                    [    30.275] (WW) VESA(0): Unable to estimate virtual size
                    [    30.275] (II) VESA(0): Not using built-in mode "1024x768" (no mode of this name)
                    [    30.275] (II) VESA(0): Not using built-in mode "800x600" (no mode of this name)
                    [    30.275] (II) VESA(0): Not using built-in mode "640x400" (no mode of this name)
                    [    30.275] (II) VESA(0): Not using built-in mode "320x400" (no mode of this name)
                    [    30.275] (II) VESA(0): Not using built-in mode "320x240" (no mode of this name)
                    [    30.275] (II) VESA(0): Not using built-in mode "320x200" (no mode of this name)
                    [    30.275] (II) VESA(0): Virtual size is 640x480 (pitch 640)
                    [    30.275] (**) VESA(0): *Built-in mode "640x480"
                    [    30.275] (**) VESA(0): Display dimensions: (380, 300) mm
                    [    30.276] (**) VESA(0): DPI set to (42, 40)
                    [
                  Viewing 8 posts - 1 through 8 (of 8 total)
                  • You must be logged in to reply to this topic.