(SOLVED) Howto avoid the need to manually reconnect wifi every time I boot?

Forum Forums New users New Users and General Questions (SOLVED) Howto avoid the need to manually reconnect wifi every time I boot?

  • This topic has 11 replies, 9 voices, and was last updated Mar 1-3:10 pm by sleekmason.
Viewing 12 posts - 1 through 12 (of 12 total)
  • Author
    Posts
  • #1680
    Anonymous

      I connect to wifi, however I have to reconnect evert time I boot up?

      Joe

      #1681
      Forum Admin
      rokytnji

        What are you connecting with? Ceni or Wicd? Post a terminal readout before you reconnect of

        inxi -Fxz

        in your next reply and before you reconnect however you do it. Paste output from terminal into a text file. Then copy and paste readout from your saved text file in your next reply .

        sudo ifconfig -a

        will be needed also before you reconnect.

        Sometimes I drive a crooked road to get my mind straight.
        I don't suffer from insanity. I enjoy every minute off it.
        Motorcycle racing is rocket science.

        Linux Registered User # 475019
        How to Search for AntiX solutions to your problems

        #1686
        Forum Admin
        BitJam

          If you are connecting with wicd instead of ceni then you need to enable the wicd service. As root edit the file /etc/default/wicd and change one line to:

          START_DAEMON=yes

          If you use ceni then it reconnects automatically even when the wicd daemon is turned off.

          Context is worth 80 IQ points -- Alan Kay

          #1694
          Member
          fatmac

            I had the same problem on my Acer 11.6″ netbook, what fixed it for me was trying to connect with ceni as well as using wicd, next time I booted up I got my wifi automatically connecting, & it’s been working OK ever since.

            Linux (& BSD) since 1999
            Ultra Small Form Factor & thin client computers

            #1699
            Anonymous

              got is, ty

              #5642
              Member
              Fonsis

                Why is the wicd daemon turned off by default?

                And why do we have wicd AND ceni implemented in antix? Is there any good reason for having both?

                Best regards,
                Fonsis
                🙂

                #5643
                Moderator
                caprea

                  IIRC the 3 or 4 different programs that tried to bring up the network during boot caused some conflicts on antix17 during the test phase.
                  So the developers decided to go this way.
                  On the live iso you can use the F4 option and select wicd on.This will carry over to the installed system and wicd will autoconnect at bootup.
                  Anyway ceni is the default for wifi on antix.

                  For someone who is new to linux wicd certainly looks easier.

                  Some people prefer ceni and some wicd.It’s difficult to make everyone right.
                  I personally prefer ceni for desktops and wicd for laptops, which I use in different places.

                  • This reply was modified 6 years, 5 months ago by caprea.
                  #5645
                  Forum Admin
                  anticapitalista

                    ceni uses a lot less RAM than wicd. Both ceni and wicd use a lot less RAM than Network-manager.

                    As caprea says, both are useful depending on the task and experience of the user.
                    Personally, I use ceni all the time.

                    Philosophers have interpreted the world in many ways; the point is to change it.

                    antiX with runit - leaner and meaner.

                    #5861
                    Anonymous

                      If you are connecting with wicd instead of ceni then you need to enable the wicd service. As root edit the file /etc/default/wicd and change one line to:

                      START_DAEMON=yes

                      If you use ceni then it reconnects automatically even when the wicd daemon is turned off.

                      I’m a newbie and AntiX is my first Linux experience on my old computer. Would you please tell how to change START_DAEMON to “yes”. I use wicd and everytime I boot I need to reconnect to wifi manually.

                      Thank you.

                      #5862
                      Moderator
                      caprea

                        The easiest way maybe

                        Open a terminal and type
                        sudo leafpad /etc/default/wicd

                        This will open the file wicd, looking like this

                        # Start the daemon by default, let the user disable it.
                        # Use "no" (without quotes) to make /etc/init.d/wicd *NOT* start the WICD daemon.
                        START_DAEMON=no
                        # By default don't kill connections on daemon shutdown, see
                        # http://bugs.debian.org/816076 and
                        # http://bazaar.launchpad.net/~wicd-devel/wicd/experimental/revision/851
                        DAEMON_ARGS="--keep-connection"

                        There you can change START_DAEMON=no to START_DAEMON=yes
                        Close the file and save changes.

                        #5864
                        Anonymous

                          The easiest way maybe

                          Open a terminal and type
                          sudo leafpad /etc/default/wicd

                          Caprea, Thank you for smooth instructions. Done!

                          #7120
                          Member
                          sleekmason

                            Just changed to testing base. dist upgrade has messed with my network settings using ceni. The connection won’t stay on reboot. the message i get is:
                            configuring network interfaces if up: /run/network/wifistate.etho

                            My wireless is wlan0

                            looking in /run/network/ shows an ifstate.wlan0 as well. all have only a single entry even after running ceni.
                            I have 0 experience with this. guessing a line somewhere in /etc/?
                            In /etc/network/interfaces I have:
                            #——————————————————————————
                            # /etc/network/interfaces
                            #
                            # interfaces(5) file used by ifup(8) and ifdown(8)
                            # Used by ceni but not by wicd
                            #——————————————————————————

                            
                            auto lo
                            iface lo inet loopback
                            allow-hotplug eth0
                            iface eth0 inet dhcp
                            allow-hotplug eth1
                            iface eth1 inet dhcp
                            allow-hotplug eth2
                            iface eth2 inet dhcp
                            allow-hotplug eth3
                            iface eth3 inet dhcp
                            allow-hotplug wlan0
                            iface wlan0 inet dhcp
                            	wpa-psk xxxxxxxxxxxx
                            	wpa-ssid ATT234

                            (The x’s have been changed for my security)

                          Viewing 12 posts - 1 through 12 (of 12 total)
                          • You must be logged in to reply to this topic.