RE: Antix 16.2 USB Persistence Fails To Create rootfs and homefs

Forum Forums Official Releases antiX-16 “Berta Cáceres” RE: Antix 16.2 USB Persistence Fails To Create rootfs and homefs

  • This topic has 3 replies, 2 voices, and was last updated Nov 8-9:22 am by jono.
Viewing 4 posts - 1 through 4 (of 4 total)
  • Author
    Posts
  • #2101
    Member
    Avatarjono

    Continuation from https://www.tapatalk.com/groups/antix/antix-16-2-usb-persistence-fails-to-create-rootfs–t7061.html

    BitJam wrote:
    I tracked the problem down to a mismatch in libraries in the initrd versus the main file system. I fixed this mismatch which solved the segfault problem.

    You can fix an existing antiX-16.2_386 live-usb by downloading the file initrd-16.2.gz from this Dropbox folder and then using it to replace the file /antiX/initrd.gz on the live-usb. You can also replace /antiX/initrd.gz.md5 with initrd-16.2.gz.md5 from the Dropbox folder.

    I tried that several times with the 2b-versions of the files by renaming them after having deleted the original files. That didn’t work for me: I got always kernel panics.

    Questions:

    – If I update the kernel with live-kernel-updater to one of Stevo’s Liquorix-kernels from the opensuse repository, will the generated initrd be automatically fixed by such an update?

    – Would a dist-upgrade starting from 16.1 avoid the initrd-bug?

    Some background:

    a friend of mine is a musician and she wants to produce music using her old Acer netbook from 2009. So I would like to install on it some kxstudio packages using a Antix-frugal installation.

    I tried that on Antix 17. But the kxstudio-meta-audio package cannot be installed on 17. The additional packages for stretch were installed though.

    Any advice highly appreciated.

    I tried that several times with the 2b-versions of the files by renaming them after having deleted the original files. That didn’t work for me: I got always kernel panics.

    Questions:

    – If I update the kernel with live-kernel-updater to one of Stevo’s Liquorix-kernels from the opensuse repository, will the generated initrd be automatically fixed by such an update?

    – Would a dist-upgrade starting from 16.1 avoid the initrd-bug?

    Some background:

    a friend of mine is a musician and she wants to produce music using her old Acer netbook from 2009. So I would like to install on it some kxstudio packages using a Antix-frugal installation.

    I tried that on Antix 17. But the kxstudio-meta-audio package cannot be installed on 17. The additional packages for stretch were installed though.

    Any advice highly appreciated.

    • This topic was modified 2 years ago by jono.
    #2103
    Forum Admin
    anticapitalistaanticapitalista

    Could you edit your post to make it clear what you are asking. There is a lot of repetition.

    Philosophers have interpreted the world in many ways; the point is to change it.

    #2105
    Member
    Avatarjono

    Continuation from:
    Old forum

    BitJam wrote:
    I tracked the problem down to a mismatch in libraries in the initrd versus the main file system. I fixed this mismatch which solved the segfault problem. You can fix an existing antiX-16.2_386 live-usb by downloading the file initrd-16.2.gz from this Dropbox folder and then using it to replace the file /antiX/initrd.gz on the live-usb. You can also replace /antiX/initrd.gz.md5 with initrd-16.2.gz.md5 from the Dropbox folder.

    I tried that several times with the 2b-versions of the files by renaming them after having deleted the original files. That didn’t work for me: I got always kernel panics.

    Questions:

    – If I update the kernel with live-kernel-updater to one of Stevo’s Liquorix-kernels from the opensuse repository, will the generated initrd be automatically fixed by such an update?

    – Would a dist-upgrade starting from 16.1 avoid the initrd-bug?

    Some background:

    a friend of mine is a musician and she wants to produce music using her old Acer netbook from 2009. So I would like to install on it some kxstudio packages using a Antix-frugal installation.

    I tried that on Antix 17. But the kxstudio-meta-audio package cannot be installed on 17. The additional packages for stretch were installed though.

    Any advice highly appreciated.

    #2133
    Member
    Avatarjono

    After having live-updated the kernel of a in a live-usb installation of Antix 16.2 with Stevo’s Liquorix 4.13.11 I have extracted the newly generated initrd filesystem.
    @Bitjam Which one is the possibly mismatching library in initrd?

    • This reply was modified 2 years ago by jono.
    • This reply was modified 1 year, 11 months ago by skidoo.
Viewing 4 posts - 1 through 4 (of 4 total)
  • You must be logged in to reply to this topic.