Remmina RDP plugin failed to install Antix19.5 i386 32bit full

Forum Forums Official Releases antiX-19 “Marielle Franco, Hannie Schaft, Manolis Glezos, Grup Yorum, Wobblies” Remmina RDP plugin failed to install Antix19.5 i386 32bit full

Tagged: 

  • This topic has 4 replies, 3 voices, and was last updated May 18-12:40 pm by wastedyears.
Viewing 5 posts - 1 through 5 (of 5 total)
  • Author
    Posts
  • #142802
    Member
    wastedyears

      Hello all. Yesterday I’ve installed Antix 19.5 32bit on an ancient Thinkpad T43. It runs fast and smooth as opposed to Debian 10. BUT I’m bound to use remmina which has been installed with no support of rdp. I tried to add rdp into and failed cause its rdp plugin seems to have dependencies of systemd. Any suggestions, maybe I need to install older version.

      • This topic was modified 1 month, 1 week ago by wastedyears.
      • This topic was modified 1 month, 1 week ago by wastedyears.
      #142807
      Member
      abc-nix

        Hi.

        Please share the apt command and its output. We need to know what dependencies are problematic.

        Also, is there any reason to install antiX 19.5 instead of the newer 23.1 version? Building packages for newer versions is way easier than for older ones.

        #142809
        Member
        abigailthom

          I think since Antix is designed to be lightweight and may not include systemd, you might encounter difficulties with the default Remmina installation. One solution could be to try installing an older version of Remmina that doesn’t have dependencies on systemd. And you can explore alternative RDP clients that are compatible with Antix and don’t rely on systemd. This could help you access remote desktops without facing dependency issues.

          #142810
          Member
          wastedyears

            I supposed older version works better on a such ancient laptop.

            # apt-get install remmina remmina-plugin-vnc remmina-plugin-rdp
            Reading package lists… Done
            Building dependency tree
            Reading state information… Done
            Some packages could not be installed. This may mean that you have
            requested an impossible situation or if you are using the unstable
            distribution that some required packages have not yet been created
            or been moved out of Incoming.
            The following information may help to resolve the situation:

            The following packages have unmet dependencies:
            remmina-plugin-rdp : Depends: libfreerdp-client2-2 (>= 2.0.0~git20160317.1.75ae3f5+dfsg1) but it is not going to be installed
            Depends: libfreerdp2-2 (>= 2.0.0~git20160317.1.75ae3f5+dfsg1) but it is not going to be installed
            Depends: libwinpr2-2 (>= 2.0.0~git20160317.1.75ae3f5+dfsg1) but it is not going to be installed
            E: Unable to correct problems, you have held broken packages.

            # apt-get install libwinpr2-2
            Reading package lists… Done
            Building dependency tree
            Reading state information… Done
            Some packages could not be installed. This may mean that you have
            requested an impossible situation or if you are using the unstable
            distribution that some required packages have not yet been created
            or been moved out of Incoming.
            The following information may help to resolve the situation:

            The following packages have unmet dependencies:
            libwinpr2-2 : Depends: libsystemd0 but it is not installable
            E: Unable to correct problems, you have held broken packages.

            • This reply was modified 1 month, 1 week ago by wastedyears.
            #142812
            Member
            wastedyears

              The problem is solved< thanks to any. my fault.
              Just referred to a forum welcome page and discovered text in bold at top

              apt-get update –allow-insecure-repositories && apt-get install antix-archive-keyring –allow-unauthenticated

              However it came with install elogind, which is not recommended in FAQ

              WARNING: The following packages cannot be authenticated!
              libelogind0

              • This reply was modified 1 month, 1 week ago by wastedyears.
            Viewing 5 posts - 1 through 5 (of 5 total)
            • You must be logged in to reply to this topic.