repo has invalid signature

  • This topic has 4 replies, 4 voices, and was last updated May 7-5:18 am by skidoo.
Viewing 5 posts - 1 through 5 (of 5 total)
  • Author
    Posts
  • #58564
    Member
    Avatarkyew

    Heard a lot about Antix and trying it out but I’m getting this right out the gate. I haven’t knowingly changed anything before getting this error during updates. I used Repo Manager to change to 3 other repos in the US to see if another repo would have proper signatures but I feel that something is just wrong with my own settings or there must be an error in the original repo itself. I found some other similar reports from October that say “solved” but did not understand the solution if there was one given.

    $ sudo apt update
    Hit:1 http://security.debian.org buster/updates InRelease
    Hit:2 http://ftp.us.debian.org/debian buster-updates InRelease
    Hit:3 http://ftp.us.debian.org/debian buster InRelease
    Hit:4 http://deb.debian.org/debian buster-backports InRelease
    Get:5 http://www.gtlib.gatech.edu/pub/MX-Linux/workspace/antix/buster buster InRelease [27.4 kB]
    Err:5 http://www.gtlib.gatech.edu/pub/MX-Linux/workspace/antix/buster buster InRelease
    The following signatures were invalid: EXPKEYSIG DB36CDF3452F0C20 antiX (antix repo) <repo@antixlinux.com>
    Reading package lists… Done
    W: GPG error: http://www.gtlib.gatech.edu/pub/MX-Linux/workspace/antix/buster buster InRelease: The following signatures were invalid: EXPKEYSIG DB36CDF3452F0C20 antiX (antix repo) <repo@antixlinux.com>
    E: The repository ‘http://www.gtlib.gatech.edu/pub/MX-Linux/workspace/antix/buster buster InRelease’ is not signed.
    N: Updating from such a repository can’t be done securely, and is therefore disabled by default.
    N: See apt-secure(8) manpage for repository creation and user configuration details.

    • This topic was modified 1 week, 2 days ago by kyew. Reason: missing "not"
    #58566
    Member
    XecureXecure

    A recent signature update in the repos has made installing from them on new installs difficult. The solution is described in the first post here.

    EXPKEYSIG error and fix

    #58567
    Member
    Avatarkyew

    Thank you, the first “method” worked and I can now update again.

    Cheers.

    #58715
    Member
    Avatarseriousness

    After several attempts with Method 2 and different repos, Method 1 worked for me, too.

    Is this keyring valid until 2024 as it says?

    #58793
    Member
    Avatarskidoo

    Is this keyring valid until 2024 as it says?

    .

Viewing 5 posts - 1 through 5 (of 5 total)
  • You must be logged in to reply to this topic.