[Solved] Restore volume control on task bar

Forum Forums New users New Users and General Questions [Solved] Restore volume control on task bar

  • This topic has 18 replies, 4 voices, and was last updated Dec 1-2:04 pm by greyowl.
Viewing 15 posts - 1 through 15 (of 19 total)
  • Author
    Posts
  • #3150
    Member
    greyowl

      I am using antiX 17.

      I need some help to restore the volume control on the task bar.

      It stopped showing after I enabled “Session load xdg autostart” to true instead of its default false. I changed it to true so that one of my applications (MegaSync) would start on startup which worked.
      “Session load xdg autostart” is found in the control center > user desktop-session > desktop-session.conf > line 80.
      I also have “Session load startup” marked as default “true”.

      Sound still works but I have no control over the volume.

      • This topic was modified 6 years, 6 months ago by greyowl.

      Dell Latitude D620 laptop with antiX 22 (64 bit)

      #3161
      Moderator
      caprea

        You can try the following:
        For every desktop you use, there’s a hidden folder in home
        e.g. /.icewm
        In this folder theres a startup,
        Edit as root with the following line
        volumeicon &

        Restart icewm ,or which desktop you use.

        #3162
        Member
        greyowl

          It worked.

          Thank you so much.

          Dell Latitude D620 laptop with antiX 22 (64 bit)

          #3164
          Forum Admin
          Dave

            Did you disable the the startup file in desktop-session.conf when you enabled the xdg autostart?

            Computers are like air conditioners. They work fine until you start opening Windows. ~Author Unknown

            #3165
            Moderator
            caprea

              I dont think he does.

              #3167
              Member
              greyowl

                Did you disable the the startup file in desktop-session.conf when you enabled the xdg autostart?

                Here are the startup entries:

                #Startup Dialog
                #This is where to enable / disable the session startup dialog
                #Options: true | false
                STARTUP_DIALOG=”false”

                #Startup Dialog Command
                #This is where to set the startup dialog command
                #Examples:
                #STARTUP_DIALOG_CMD=”leafpad ~/.startup-text
                #STARTUP_DIALOG_CMD=”yad –image=’info’ –text=’this is my startup dialog'”
                #STARTUP_DIALOG_CMD=”/usr/local/lib/desktop-session/startup-dialog.py”

                #Session load xdg autostart
                #This will load any application that is setup to autostart via xdg autostart directories /
                #.desktop files.
                #Options: true | false
                LOAD_XDG_AUTOSTART=”true”

                #Session load startup
                #This will load any application that is setup to autostart via /etc/desktop-session/startup
                #Options: true | false
                LOAD_STARTUP_FILE=”true”

                Dell Latitude D620 laptop with antiX 22 (64 bit)

                #3168
                Forum Admin
                Dave

                  Hmm strange perhaps you have found a bug. What is the content of ~/.desktop-session/startup? And could you also post an ls of ~/.config/autostart?

                  Computers are like air conditioners. They work fine until you start opening Windows. ~Author Unknown

                  #3205
                  Member
                  greyowl

                    Hmm strange perhaps you have found a bug. What is the content of ~/.desktop-session/startup? And could you also post an ls of ~/.config/autostart?

                    Here is the content of .desktop-session/startup:

                    #!/bin/bash
                    # Puts a volume icon on the taskbar
                    volumeicon & 
                    # Enable/Disable automounting
                    automount-antix &
                    # Puts a flag on the taskbar to show which keyboard is being used if more than 1 keyboard layout is detected
                    fbxkb-start &
                    # Uncomment for easy search from the taskbar
                    #search-bar-icon &
                    # Uncomment the following line to mount Samba and/or NFS shares
                    #connectshares &
                    # Uncomment to show the configuration gui of a running ssh-conduit-x11vnc server
                    #ssh-conduit-x11vnc.sh gui &
                    # Uncomment to use clipboard manager
                    #clipit &
                    # Uncomment to show wicd networking monitor
                    #wicd-client -t &
                    grep -q "START_DAEMON=no" /etc/default/wicd || wicd-client -t &
                    # Create a bootchart image if bootchart was run
                    test -e /etc/live/config/bootchart \
                        && (sleep 6 && test -e /var/log/bootchart.tgz \
                            && ! test -e ~/bootchart.png \
                            && pybootchartgui)&
                    # Used on live system only
                    (sleep 5 && toram-eject) & 

                    Here is the contents of desktop session config:

                    #This is the desktop-session config file.
                    #This is structured in a bash script format, so all options must be option="desired-option
                    #Session service delay.
                    #This is to set how long to delay startup to give enough time for the wm to completely load.
                    #before starting to load other applications. This wait period will be started after the 
                    #window manager has been found running.
                    #TIME is expressed in seconds
                    #Options: 0-9...
                    STARTUP_DELAY="2"
                    #Session window manager check
                    #This is to set the amount of times desktop-session checks for a running window manager
                    #before giving up and denying the session to load.
                    #Options: 0-9...
                    TIMES_TO_CHECK="20"
                    #Session give up override
                    #This is to set the override if the window manager is never found to be running by 
                    #desktop-session. This will force the session to load if set to true.
                    #Options: true | false
                    FORCE_LOAD="false"
                    #Session Protect.
                    #This is how to protect the user from automatic updating of any file within desktop-session.
                    #Examples are the menu, any file compare within file_compare, etc
                    #Options for this are: 
                    #SESSION_PROTECT="true #Strictly protect the user, leave the user to deal with any of the updating
                    #SESSION_PROTECT="ask #Notify me at startup of any changes and allow me to choose what to update
                    #SESSION_PROTECT="false #Just update me, I dont want to worry about falling behind.
                    SESSION_PROTECT="false"
                    #Notification Dialog
                    #This is where to enable / disable the session loading dialog
                    #Options: true | false
                    NOTIFICATION_DIALOG="false"
                    #Notification text or program
                    #This is where the text is set for the notification that the session is loading.
                    #This can be a specified text string or a program that will return a text string
                    #Examples:
                    #NOTIFICATION_TEXT="Session is Loading, Please Wait....."
                    #NOTIFICATION_TEXT="/usr/games/fortune"
                    NOTIFICATION_TEXT="Session is Loading, Please Wait....."
                    #Startup Sound
                    #Play Sound when loading the desktop (uses terminal command play)
                    #Options: true | false
                    STARTUP_SOUND="true"
                    #Startup Sound File
                    #Location of the file for the startup sound 
                    STARTUP_SOUND_FILE="$HOME/.desktop-session/startup.ogg"
                    #Startup Dialog
                    #This is where to enable / disable the session startup dialog
                    #Options: true | false
                    STARTUP_DIALOG="false"
                    #Startup Dialog Command
                    #This is where to set the startup dialog command
                    #Examples: 
                    #STARTUP_DIALOG_CMD="leafpad ~/.startup-text
                    #STARTUP_DIALOG_CMD="yad --image='info' --text='this is my startup dialog'"
                    #STARTUP_DIALOG_CMD="/usr/local/lib/desktop-session/startup-dialog.py"
                    #Session load conky
                    #This will load a window manager specific conky from ~/.conky
                    #There must be a corresponding conkyrc in ~/.conky in the form of windowmanager-conkyrc
                    #Else we will load conky without the -c parameter
                    #Options: true | false
                    LOAD_CONKY="false"
                    #Session load xdg autostart
                    #This will load any application that is setup to autostart via xdg autostart directories /
                    #.desktop files.
                    #Options: true | false
                    LOAD_XDG_AUTOSTART="true"
                    #Session load startup
                    #This will load any application that is setup to autostart via /etc/desktop-session/startup
                    #Options: true | false
                    LOAD_STARTUP_FILE="true"
                    #Session screen blank
                    #This is to set the amount of time that the screen stays visible.
                    #Desktop-session sets the dpms settings according to the screen blank value set here.
                    #TIME expressed in seconds
                    #Options: 0-9...
                    SCREEN_BLANK_TIME="3600"

                    I do not know where to find config autostart. Please direct me.
                    Is there anything else that you need?
                    Thanks

                    Dell Latitude D620 laptop with antiX 22 (64 bit)

                    #3210
                    Forum Admin
                    Dave

                      Hmm seems ok.
                      I am not sure what is different than how it is set up here.

                      Out of curiosity (and may or may not be related) do you have two wicd icons in the system tray?
                      I ask because you have it enabled in the startup file and it also has a .desktop file for xdg startup (I get two using your posted configs).

                      Edit:
                      I did notice that your desktop-session.conf uses different ” ” marks for the values. Example is STARTUP_DELAY
                      I am not sure if this is because of posting it in the forum or not. I had to change them all so they were the same after copying your configs from the forum. Maybe this is really a problem on your computer?

                      Also if you could post the contents of $HOME/.desktop-session/log

                      • This reply was modified 6 years, 6 months ago by Dave.
                      • This reply was modified 6 years, 6 months ago by Dave.

                      Computers are like air conditioners. They work fine until you start opening Windows. ~Author Unknown

                      #3240
                      Member
                      greyowl

                        Hmm seems ok.
                        I am not sure what is different than how it is set up here.

                        Out of curiosity (and may or may not be related) do you have two wicd icons in the system tray?
                        I ask because you have it enabled in the startup file and it also has a .desktop file for xdg startup (I get two using your posted configs).[quote]

                        [quote]
                        Edit:
                        I did notice that your desktop-session.conf uses different ” ” marks for the values. Example is STARTUP_DELAY
                        I am not sure if this is because of posting it in the forum or not. I had to change them all so they were the same after copying your configs from the forum. Maybe this is really a problem on your computer? [quote]

                        In the actual desktop-session.conf all the ” ” marks look the same to me.

                        [quote]

                        Also if you could post the contents of $HOME/.desktop-session/

                        ————————————————————————————————————————-
                        Yes, there is a problem with wicd. Since I changed xcg startup from false to true, I have been getting a popup of wicd stating “wicd needs to access your computer’s network cards” and requesting a password–I put in the computer password, then I get two icons in the sys tray. I initially used ceni to setup wireless, and I don’t want to use wicd for wireless. How do I stop getting the popup and wicd?

                        ————————————————————————————————————————

                        In the actual desktop-session.conf all the ” ” marks look the same to me.

                        ———————————————————————————————————————–

                        Here is the .desktop-session/log:

                        desktop-session: started Tue Nov 28 19:39:23 EST 2017 start_time: 153.08
                        desktop-session: pid: 2417
                        desktop-session: logging to: /home/user/.desktop-session/log
                        desktop-session: launch @ 15331
                        desktop-session: icewm
                        desktop-session: display_alt_desktop_window=false
                        desktop-session: look up executable for icewm
                        desktop-session: save desktop code: space-icewm
                        desktop-session: Exporting desktop Variables:
                        desktop-session: DESKTOP_SESSION_CODE=space-icewm
                        desktop-session: DESKTOP_SESSION_WM=icewm
                        desktop-session: DESKTOP_SESSION_IM=space
                        desktop-session: run: /usr/bin/icewm-session
                        icewm-session: Warning: File still open: fd=3, target=’/var/log/slim.log’ (missing FD_CLOEXEC?)
                        icewm-session: Warning: Closing file descriptor: 3
                        icewm-session: Warning: File still open: fd=3, target=’/var/log/slim.log’ (missing FD_CLOEXEC?)
                        icewm-session: Warning: Closing file descriptor: 3
                        desktop-session: Checking for running window manager @ 15374
                        desktop-session: Window manager running or setup forced, setting up desktop @ 15447
                        desktop-session: Delaying session startup by 2 seconds
                        desktop-session: run: spacefm –desktop &
                        icewm-session: Warning: File still open: fd=3, target=’/var/log/slim.log’ (missing FD_CLOEXEC?)
                        icewm-session: Warning: Closing file descriptor: 3
                        icewm-session: Warning: File still open: fd=3, target=’/var/log/slim.log’ (missing FD_CLOEXEC?)
                        icewm-session: Warning: Closing file descriptor: 3
                        /usr/local/bin/desktop-session: line 188: /etc/desktop-session/file_compare: No such file or directory
                        desktop-session: run: desktop-session-wallpaper
                        desktop-session: run: eval /usr/lib/at-spi2-core/at-spi-bus-launcher –launch-immediately
                        desktop-session: run: eval clipit
                        desktop-session: run: eval /usr/bin/gnome-keyring-daemon –start –components
                        gnome-keyring-daemon: Missing argument for –components
                        desktop-session: run: eval /usr/bin/gnome-keyring-daemon –start –components
                        gnome-keyring-daemon: Missing argument for –components
                        SSH_AUTH_SOCK=/home/user/.run/keyring/ssh
                        SSH_AUTH_SOCK=/home/user/.run/keyring/ssh
                        desktop-session: run: eval /usr/bin/gnome-keyring-daemon –start –components
                        gnome-keyring-daemon: Missing argument for –components
                        SSH_AUTH_SOCK=/home/user/.run/keyring/ssh
                        desktop-session: run: eval gsettings-data-convert
                        desktop-session: run: eval /usr/lib/notify-osd/notify-osd
                        /usr/local/lib/desktop-session/lib-desktop-session.sh: line 72: /usr/lib/notify-osd/notify-osd: No such file or directory
                        desktop-session: run: eval system-config-printer-applet

                        ** (clipit:2511): WARNING **: Binding ‘<Ctrl><Alt>H’ failed!

                        desktop-session: run: eval wicd-gtk –tray

                        (clipit:2511): GLib-GObject-WARNING **: /build/glib2.0-YYXhFA/glib2.0-2.50.3/./gobject/gsignal.c:2523: signal ‘child-added’ is invalid for instance ‘0x819d00a0’ of type ‘GtkMenu’

                        (spacefm:2513): SpaceFM-WARNING **: No root settings found in /etc/spacefm/ Setting a root editor in Preferences should remove this warning on startup. Otherwise commands run as root may present a security risk.
                        qt5ct: using qt5ct plugin
                        qt5ct: using qt5ct plugin
                        palemoon
                        lxterminal -e sudo ceni
                        EXIT=”abort”
                        1511916471510 addons.update-checker WARN Update manifest for {972ce4c6-7e08-4474-a285-3208198ce6fd} did not contain an updates property
                        1511916471582 addons.update-checker WARN Update manifest for uBlock0@raymondhill.net did not contain an updates property
                        07:57:09 PM: Warning: Mismatch between the program and library build versions detected.
                        The library used 3.0 (wchar_t,compiler with C++ ABI 1010,wx containers,compatible with 2.8),
                        and your program used 3.0 (wchar_t,compiler with C++ ABI 1009,wx containers,compatible with 2.8).
                        /usr/bin/xdg-mime: 912: local: Moon-ZX359Y.desktop: bad variable name

                        (clipit:2511): GLib-GObject-WARNING **: /build/glib2.0-YYXhFA/glib2.0-2.50.3/./gobject/gsignal.c:2523: signal ‘child-added’ is invalid for instance ‘0x819d01a0’ of type ‘GtkMenu’
                        leafpad
                        Clipboard is null, recovering …
                        lxterminal

                        (clipit:2511): GLib-GObject-WARNING **: /build/glib2.0-YYXhFA/glib2.0-2.50.3/./gobject/gsignal.c:2523: signal ‘child-added’ is invalid for instance ‘0x819d02a0’ of type ‘GtkMenu’
                        desktop-defaults-run -fm –follow
                        spacefm

                        Thanks for the help.

                        • This reply was modified 6 years, 6 months ago by greyowl.
                        • This reply was modified 6 years, 6 months ago by greyowl.
                        • This reply was modified 6 years, 6 months ago by greyowl.

                        Dell Latitude D620 laptop with antiX 22 (64 bit)

                        #3244
                        Member
                        greyowl

                          Hmm seems ok.
                          I am not sure what is different than how it is set up here.

                          Out of curiosity (and may or may not be related) do you have two wicd icons in the system tray?
                          I ask because you have it enabled in the startup file and it also has a .desktop file for xdg startup (I get two using your posted configs).

                          Edit:
                          I did notice that your desktop-session.conf uses different ” ” marks for the values. Example is STARTUP_DELAY
                          I am not sure if this is because of posting it in the forum or not. I had to change them all so they were the same after copying your configs from the forum. Maybe this is really a problem on your computer?

                          Also if you could post the contents of $HOME/.desktop-session/log

                          ———————————————————————————————————————–

                          Yes, there is a problem with wicd. Since I changed xcg startup from false to true, I have been getting a popup of wicd stating “wicd needs to access your computer’s network cards” and requesting a password–I put in the computer password, then I get two icons in the sys tray. I initially used ceni to setup wireless, and I don’t want to use wicd for wireless. How do I stop getting the popup and wicd?

                          ————————————————————————————————————————

                          In the actual desktop-session.conf all the ” ” marks look the same to me.

                          ———————————————————————————————————————–

                          Here is the .desktop-session/log:

                          desktop-session: started Tue Nov 28 19:39:23 EST 2017 start_time: 153.08
                          desktop-session: pid: 2417
                          desktop-session: logging to: /home/user/.desktop-session/log
                          desktop-session: launch  @ 15331
                          desktop-session: icewm
                          desktop-session: display_alt_desktop_window=false
                          desktop-session: look up executable for icewm
                          desktop-session: save desktop code: space-icewm
                          desktop-session: Exporting desktop Variables:
                          desktop-session: DESKTOP_SESSION_CODE=space-icewm
                          desktop-session: DESKTOP_SESSION_WM=icewm
                          desktop-session: DESKTOP_SESSION_IM=space
                          desktop-session: run: /usr/bin/icewm-session
                          icewm-session: Warning: File still open: fd=3, target='/var/log/slim.log' (missing FD_CLOEXEC?)
                          icewm-session: Warning: Closing file descriptor: 3
                          icewm-session: Warning: File still open: fd=3, target='/var/log/slim.log' (missing FD_CLOEXEC?)
                          icewm-session: Warning: Closing file descriptor: 3
                          desktop-session: Checking for running window manager @ 15374
                          desktop-session: Window manager running or setup forced, setting up desktop @ 15447
                          desktop-session: Delaying session startup by 2 seconds
                          desktop-session: run: spacefm --desktop &
                          icewm-session: Warning: File still open: fd=3, target='/var/log/slim.log' (missing FD_CLOEXEC?)
                          icewm-session: Warning: Closing file descriptor: 3
                          icewm-session: Warning: File still open: fd=3, target='/var/log/slim.log' (missing FD_CLOEXEC?)
                          icewm-session: Warning: Closing file descriptor: 3
                          /usr/local/bin/desktop-session: line 188: /etc/desktop-session/file_compare: No such file or directory
                          desktop-session: run: desktop-session-wallpaper
                          desktop-session: run: eval /usr/lib/at-spi2-core/at-spi-bus-launcher --launch-immediately
                          desktop-session: run: eval clipit
                          desktop-session: run: eval /usr/bin/gnome-keyring-daemon --start --components
                          gnome-keyring-daemon: Missing argument for --components
                          desktop-session: run: eval /usr/bin/gnome-keyring-daemon --start --components
                          gnome-keyring-daemon: Missing argument for --components
                          SSH_AUTH_SOCK=/home/user/.run/keyring/ssh
                          SSH_AUTH_SOCK=/home/user/.run/keyring/ssh
                          desktop-session: run: eval /usr/bin/gnome-keyring-daemon --start --components
                          gnome-keyring-daemon: Missing argument for --components
                          SSH_AUTH_SOCK=/home/user/.run/keyring/ssh
                          desktop-session: run: eval gsettings-data-convert
                          desktop-session: run: eval /usr/lib/notify-osd/notify-osd
                          /usr/local/lib/desktop-session/lib-desktop-session.sh: line 72: /usr/lib/notify-osd/notify-osd: No such file or directory
                          desktop-session: run: eval system-config-printer-applet
                          ** (clipit:2511): WARNING **: Binding '<Ctrl><Alt>H' failed!
                          desktop-session: run: eval wicd-gtk --tray
                          (clipit:2511): GLib-GObject-WARNING **: /build/glib2.0-YYXhFA/glib2.0-2.50.3/./gobject/gsignal.c:2523: signal 'child-added' is invalid for instance '0x819d00a0' of type 'GtkMenu'
                          (spacefm:2513): SpaceFM-WARNING **: No root settings found in /etc/spacefm/  Setting a root editor in Preferences should remove this warning on startup.   Otherwise commands run as root may present a security risk.
                          qt5ct: using qt5ct plugin
                          qt5ct: using qt5ct plugin
                          palemoon   
                          lxterminal -e  sudo ceni
                          EXIT="abort"
                          1511916471510	addons.update-checker	WARN	Update manifest for {972ce4c6-7e08-4474-a285-3208198ce6fd} did not contain an updates property
                          1511916471582	addons.update-checker	WARN	Update manifest for uBlock0@raymondhill.net did not contain an updates property
                          07:57:09 PM: Warning: Mismatch between the program and library build versions detected.
                          The library used 3.0 (wchar_t,compiler with C++ ABI 1010,wx containers,compatible with 2.8),
                          and your program used 3.0 (wchar_t,compiler with C++ ABI 1009,wx containers,compatible with 2.8).
                          /usr/bin/xdg-mime: 912: local: Moon-ZX359Y.desktop: bad variable name
                          (clipit:2511): GLib-GObject-WARNING **: /build/glib2.0-YYXhFA/glib2.0-2.50.3/./gobject/gsignal.c:2523: signal 'child-added' is invalid for instance '0x819d01a0' of type 'GtkMenu'
                          leafpad   
                          Clipboard is null, recovering ...
                          lxterminal  
                          (clipit:2511): GLib-GObject-WARNING **: /build/glib2.0-YYXhFA/glib2.0-2.50.3/./gobject/gsignal.c:2523: signal 'child-added' is invalid for instance '0x819d02a0' of type 'GtkMenu'
                          desktop-defaults-run -fm --follow  
                          spacefm  

                          Thanks for the help.

                          Dell Latitude D620 laptop with antiX 22 (64 bit)

                          #3265
                          Member
                          greyowl

                            Hi Dave,

                            I have answered your questions and provided the information that you requested above.

                            Dell Latitude D620 laptop with antiX 22 (64 bit)

                            #3266
                            Forum Admin
                            Dave

                              Thanks, when I have a few moments to digest the information and try again to replicate the problem I should be able to write back a better response. For the moment Wicd can be stopped by commenting out the grep….. wicd-client -t line. And then copying Wicd desktop file from /etc/xdg/autostart/ to ~/.config/autostart, editing the file and setting hidden=false to hidden=true iirc.

                              Computers are like air conditioners. They work fine until you start opening Windows. ~Author Unknown

                              #3267
                              Member
                              greyowl

                                Thanks, when I have a few moments to digest the information and try again to replicate the problem I should be able to write back a better response. For the moment Wicd can be stopped by commenting out the grep….. wicd-client -t line. And then copying Wicd desktop file from /etc/xdg/autostart/ to ~/.config/autostart, editing the file and setting hidden=false to hidden=true iirc.

                                Thanks for this information.
                                While I prefer to use ceni for network connection, I may on occasion still want to use Wicd manually. If I make these changes in Wicd, will I still be able to use Wicd manually.?

                                Alternatively, I could just use Wicd instead of ceni. How would I go about doing that so that the Wicd icon would be on the sys tray all the time?

                                Thanks

                                • This reply was modified 6 years, 6 months ago by greyowl.

                                Dell Latitude D620 laptop with antiX 22 (64 bit)

                                #3303
                                Forum Admin
                                Dave

                                  Hmm. I cannot seem to replicate the issue. I have a theory that it may be from a program you have installed but I do not that is starting with xdg startup. Could you post the output of
                                  ls /etc/xdg/autostart/
                                  and
                                  ls ~/.config/autostart/

                                  So I can see if there are any other programs in the startup that I do not have installed on my system?
                                  If my theory is correct and I can replicate it by installing an application then I should be able to fix it fairly easily and you would see it in an update.

                                  As to more detail on Wicd.
                                  To enable Wicd
                                  as root:
                                  nano /etc/default/wicd
                                  change: START_DAEMON=no
                                  to: START_DAEMON=yes
                                  as user either:
                                  nano ~/.desktop-session/startup
                                  uncomment: wicd-client -t &
                                  or
                                  nano ~/.desktop-session/desktop-session.conf
                                  change: LOAD_XDG_AUTOSTART=”false”
                                  to: LOAD_XDG_AUTOSTART=”true”

                                  being that you have xdg autostart enabled and startup enabled I would say to comment out (disable) the wicd line in the startup file so you only have one instance of wicd.
                                  as user:
                                  nano ~/.desktop-session/startup
                                  comment: #grep -q “START_DAEMON=no” /etc/default/wicd || wicd-client -t &

                                  To disable wicd in xdg autostart
                                  as user:
                                  cp /etc/xdg/autostart/wicd-tray.desktop ~/.config/autostart
                                  nano ~/.config/autostart/wicd-tray.desktop
                                  change: Exec=wicd-gtk –tray
                                  to: Exec=

                                  Computers are like air conditioners. They work fine until you start opening Windows. ~Author Unknown

                                Viewing 15 posts - 1 through 15 (of 19 total)
                                • You must be logged in to reply to this topic.