[Solved] Restore volume control on task bar

Forum Forums New users New Users and General Questions [Solved] Restore volume control on task bar

  • This topic has 18 replies, 4 voices, and was last updated Dec 1-2:04 pm by greyowl.
Viewing 4 posts - 16 through 19 (of 19 total)
  • Author
    Posts
  • #3311
    Member
    greyowl

      Hmm. I cannot seem to replicate the issue. I have a theory that it may be from a program you have installed but I do not that is starting with xdg startup. Could you post the output of
      ls /etc/xdg/autostart/
      and
      ls ~/.config/autostart/

      So I can see if there are any other programs in the startup that I do not have installed on my system?
      If my theory is correct and I can replicate it by installing an application then I should be able to fix it fairly easily and you would see it in an update.

      Below is the output of ls /etc/xdg/autostart/ and ls ~/.config/autostart/ :

      user@antix1:~
      $ ls /etc/xdg/autostart/
      at-spi-dbus-bus.desktop gnome-keyring-secrets.desktop notify-osd.desktop
      clipit-startup.desktop gnome-keyring-ssh.desktop print-applet.desktop
      gnome-keyring-pkcs11.desktop gsettings-data-convert.desktop wicd-tray.desktop
      user@antix1:~
      $ ls ~/.config/autostart/
      megasync.desktop
      user@antix1:~
      $
      ———————————————————————————————————————–
      These issues all started when I initially changed the xdg autostart from false to true in order to get Megasync to show on the sys tray, and it worked. The change also made Clipit show up on the sys tray. I also started getting the Wicd dialog boxes coming up.

      Since I last posted, I have dealt with the issue by changing xdg autostart back to false and adding “Megasync &” to icewm/startup. Now, I no longer get the Wicd dialog boxes, and I have Megasync in the sys tray. I don’t have Clipit in the sys tray and this is OK because I don’t use it. What do you think of this solution? Are there any drawbacks to this arrangement?

      I will study the stuff you sent on Wicd.

      Thanks for the help.

      Dell Latitude D620 laptop with antiX 22 (64 bit)

      #3312
      Member
      greyowl

        As to more detail on Wicd.
        To enable Wicd
        as root:
        nano /etc/default/wicd
        change: START_DAEMON=no
        to: START_DAEMON=yes
        as user either:
        nano ~/.desktop-session/startup
        uncomment: wicd-client -t &
        or
        nano ~/.desktop-session/desktop-session.conf
        change: LOAD_XDG_AUTOSTART=”false”
        to: LOAD_XDG_AUTOSTART=”true”

        being that you have xdg autostart enabled and startup enabled I would say to comment out (disable) the wicd line in the startup file so you only have one instance of wicd.
        as user:
        nano ~/.desktop-session/startup
        comment: #grep -q “START_DAEMON=no” /etc/default/wicd || wicd-client -t &

        To disable wicd in xdg autostart
        as user:
        cp /etc/xdg/autostart/wicd-tray.desktop ~/.config/autostart
        nano ~/.config/autostart/wicd-tray.desktop
        change: Exec=wicd-gtk –tray
        to: Exec=

        I not very clear on how to proceed with some of the above instructions on Wicd:
        -when you say “uncomment: wicd-client -t &amp”, does this mean to remove the “#” from the beginning of the line? Does this then enable the process?
        -when you say “comment out (disable) the wicd line”, does this mean to add a “#” to the beginning of the line so that it is disables?

        Dell Latitude D620 laptop with antiX 22 (64 bit)

        #3313
        Anonymous

          remove the “#” from the beginning of the line? Does this then enable the process?

          add a “#” to the beginning of the line so that it is disabled?

          Yes.

          Said differently: presence of # at start of a line causes the line to be ignored

          #3314
          Member
          greyowl

            Thanks

            Dell Latitude D620 laptop with antiX 22 (64 bit)

          Viewing 4 posts - 16 through 19 (of 19 total)
          • You must be logged in to reply to this topic.