Right click not working, what do I do?

Forum Forums Official Releases antiX-21/22 “Grup Yorum” Right click not working, what do I do?

  • This topic has 7 replies, 5 voices, and was last updated Feb 17-6:23 pm by Brian Masinick.
Viewing 8 posts - 1 through 8 (of 8 total)
  • Author
    Posts
  • #99784
    Member
    RockZombie4

      Hello everyone, I’m fairly new to the forums and the OS, so this might be a stupid question, but I just installed antix 22. This has happened to me in the past with the same PC on linux mint as well. In linux mint, it was just a driver issue, and once I installed the drivers, right-clicking started working again. But what are the drivers I need for right-clicking in AntiX? Is this even a driver issue?

      Thanks!
      (PS: I use a 4GB RAM HP Pavillion x360 convertible)

      #99808
      Member
      sybok

        Hi, I never experiences such an issue.
        You may try the following:
        1) Try a different antiX kernel (4.4 past EOL, 4.9 past EOL, 4.19, 5.10) – newer or older depending on your HW.
        2) Search for Debian and the mouse/notebook model you have – the driver is probably the same in antiX as in Debian and you could find it this way.
        My guess is the drivers are the same as in Linux mint assuming it was the Debian edition.

        In any case, post output of ‘inxi -Fxz’ which will give more information to anyone who decides to help.

        #99811
        Member
        PPC

          Sometimes, common sense is the way to go- you had the same exact problem using another Linux distribution… And you found out it was a driver’s problem… so….
          You did not say it, so we are assuming you are talking about problems with the trackpad, not a mouse connected to the computer, right?
          Like sybok said – try different Kernels (you can choose, at boot time between the 2 kernels installed by defaul) and see if that helps.
          How did you solve the problem in Mint? What did you install? Probably, like sybok also suggests, the same drivers you used in Mint may work in antiX…

          P.

          #99874
          Member
          RockZombie4

            So I tried installing the drivers that worked for me in linux mint, but APT can’t find them.

            Also, here is the output that came from inxi -Fxz:

            $ inxi -Fxz
            System:
              Kernel: 5.10.142-antix.2-amd64-smp arch: x86_64 bits: 64 compiler: gcc
                v: 10.2.1 Desktop: IceWM v: 3.0.1
                Distro: antiX-22_x64-full Grup Yorum 18 October 2022
                base: Debian GNU/Linux 11 (bullseye)
            Machine:
              Type: Laptop System: HP product: HP Pavilion x360 Convertible
                v: Type1ProductConfigId serial: <superuser required>
              Mobo: HP model: 8074 v: 66.35 serial: <superuser required> UEFI: Insyde
                v: F.33 date: 07/31/2015
            Battery:
              ID-1: BAT0 charge: 24.5 Wh (92.8%) condition: 26.4/26.4 Wh (100.0%)
                volts: 8.0 min: 7.6 model: 333-54-2A HV02032XL status: discharging
            CPU:
              Info: quad core model: Intel Pentium N3700 bits: 64 type: MCP arch: Airmont
                rev: 3 cache: L1: 224 KiB L2: 2 MiB
              Speed (MHz): avg: 2072 high: 2408 min/max: 480/2400 cores: 1: 2400
                2: 2408 3: 1523 4: 1957 bogomips: 12800
              Flags: ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx
            Graphics:
              Device-1: Intel Atom/Celeron/Pentium Processor x5-E8000/J3xxx/N3xxx
                Integrated Graphics
                vendor: Hewlett-Packard driver: i915 v: kernel arch: Gen8 bus-ID: 00:02.0
              Device-2: Chicony HP Truevision HD type: USB driver: uvcvideo
                bus-ID: 1-5.2:5
              Display: server: X.Org v: 1.20.11 driver: X: loaded: modesetting
                unloaded: fbdev,vesa gpu: i915 resolution: 1366x768~60Hz
              OpenGL: renderer: Mesa DRI Intel HD Graphics 405 (BSW) v: 4.6 Mesa 20.3.5
                direct render: Yes
            Audio:
              Device-1: Intel Atom/Celeron/Pentium Processor x5-E8000/J3xxx/N3xxx Series
                High Definition Audio
                vendor: Hewlett-Packard driver: snd_hda_intel v: kernel bus-ID: 00:1b.0
              Sound Server-1: ALSA v: k5.10.142-antix.2-amd64-smp running: yes
            Network:
              Device-1: Realtek RTL810xE PCI Express Fast Ethernet
                vendor: Hewlett-Packard driver: r8169 v: kernel port: 3000 bus-ID: 02:00.0
              IF: eth0 state: down mac: <filter>
              Device-2: Realtek RTL8723BE PCIe Wireless Network Adapter
                vendor: Hewlett-Packard driver: rtl8723be v: kernel port: 2000
                bus-ID: 03:00.0
              IF: wlan0 state: up mac: <filter>
            Bluetooth:
              Device-1: Realtek Bluetooth Radio type: USB driver: btusb v: 0.8
                bus-ID: 1-5.1:4
              Report: hciconfig ID: hci0 rfk-id: 1 state: down bt-service: running
                rfk-block: hardware: no software: yes address: <filter>
            Drives:
              Local Storage: total: 465.76 GiB used: 4.37 GiB (0.9%)
              ID-1: /dev/sda vendor: Seagate model: ST500LT012-1DG142 size: 465.76 GiB
            Partition:
              ID-1: / size: 220.03 GiB used: 4.36 GiB (2.0%) fs: ext4 dev: /dev/sda3
              ID-2: /boot/efi size: 512 MiB used: 4.7 MiB (0.9%) fs: vfat
                dev: /dev/sda2
            Swap:
              Alert: No swap data was found.
            Sensors:
              System Temperatures: cpu: 47.0 C mobo: N/A
              Fan Speeds (RPM): N/A
            Info:
              Processes: 159 Uptime: 32m Memory: 3.7 GiB used: 1.2 GiB (32.3%)
              Init: SysVinit runlevel: 5 Compilers: gcc: 10.2.1 Packages: 1569
              Shell: Bash v: 5.1.4 inxi: 3.3.19
            
            #99875
            Forum Admin
            anticapitalista

              Is it a secret what those drivers are called?

              Philosophers have interpreted the world in many ways; the point is to change it.

              antiX with runit - leaner and meaner.

              #99876
              Member
              PPC

                @RockZombie4 – I know you are new here… But you need to provide details about your situation.
                Asking for help here is like going to a doctor: you don’t just sit there and say: “I have a pain” and expect the doctor, magically to guess where you have that pain, what’s causing it and how to cure it, right? You have to provide details…
                In this case, please do tell us what driver are you trying to install, or no one can help you- trust me, we do this for free, no one is going to buy a computer like yours, install antiX on in to see what’s the problem and find out how to solve it… You have to be proactive and give as much relevant details as possible- no one can guess what that driver is…

                P.

                #99877
                Moderator
                Brian Masinick

                  @rockzombie4: Based on the inxi -Fxz report, it appears that your hardware is Intel Pentium N3700 based, also noted with Intel Atom/Celeron peripheral components.

                  It does appear that you reached here successfully with the 5.10.142-antix.2-amd64-smp kernel; I’ve had mixed results with that particular kernel, while others find it to be their favorite.

                  All the devices are recognized by the information report, so which driver or drivers are NOT providing you with the expected features?
                  What features don’t work as you prefer or expect, and what evidence suggests that it’s a driver issue?
                  Is the “right click” the only “problem”?

                  http://unix.stackexchange.com/questions/543704/how-do-i-enable-two-finger-right-click-in-ubuntu-gnome
                  http://itsfoss.com/fix-right-click-touchpad-ubuntu/
                  http://forums.linuxmint.com/viewtopic.php?t=264392

                  --
                  Brian Masinick

                  #99878
                  Moderator
                  Brian Masinick
                  Viewing 8 posts - 1 through 8 (of 8 total)
                  • You must be logged in to reply to this topic.