Rox-panel options – how to access?

Forum Forums New users New Users and General Questions Rox-panel options – how to access?

This topic contains 10 replies, has 3 voices, and was last updated by 736b69646f6f Jun 19-4:22 pm.

Viewing 11 posts - 1 through 11 (of 11 total)
  • Author
    Posts
  • #10881
    Member

    rej

    The drop down menu in the Rox-panel for IceWM has a selection named “options”, yet does not open on any of my devices.

    I would like to change the height of the panel, if that is possible. Could not find anything in the manual, the Rox Filer options, the IceWM “preferences” file, or online search.

    On some of my computers, the panel runs a bit below the top of the screen with a gap at the top – can it be anchored to the top of the screen?

    Is there a way to open the “options” entry?

    Thank you.

    #10885
    Member
    azrielle
    azrielle

    I found ROX File Manager to be frustrating. Fortunately, Right-clicking anywhere on the desktop brings up a menu with “desktops” about 3/4 down. Left-clicking, and then again on the result brings up 12 different filemanager-desktop options. If you’re in love with IceWM (I am not, prefer either Fluxbox or JWM), just click on the “SpaceFM-IceWM” option! I think you will find that Space File Manager is worlds apart from ROX for basic functionality, and builds in fixes for what you are irritated about with ROX.

    Lenovo T430 i5/3220M 8GB 14.1" MX17.1/AntiX 17.1 Fluxbox/Win7SP1 180GB SSD+128GB mSATA
    Lenovo X230 i7/3520M 12GB 12.5" MX17.1/Win7SP1 500GB SSD
    Lenovo X131e i3/3227u 8GB 11.6" MX17.1/AntiX 17.1 Fluxbox/Win7SP1 500GB SSD
    #10887
    Member

    736b69646f6f

    When I right click a rox panel and click “Panel Options” as shown in your screenshot, I see this
    s
    so something has become “broken” on your system if that dialog window isn’t available. I would try: apt-get remove then reinstall rox, and if that does not fix then apt-get purge and reinstall rox.

    “On some of my computers, the panel runs a bit below the top of the screen with a gap at the top”

    Some? Is icewm window manager is running on all of the “some”? That gap may be something which is being specified and enforced via the window manager configuration, or via the window manager theme. With same theme in effect across all machines…. is the (gap) result identical? If so, try selecting a different theme and test again. If not, would need to track down what is causing the affected machines to behave “broken”. I don’t know of a way to specify via ROX options “I want a 50px top gap, a 0px bottom gap, etc”. Given the wording shown in the settings dialog “left EDGE” I don’t expect gappiness (margin?) is configurable within rox.

    #10926
    Member

    rej

    736b69646f6f-

    Thanks for posting the Panel-options screenshot.

    You are right about “some”. In checking to see which PCs where the panel was not fully at the top of the screen, it was only in devices with installed Mate or Xfce desktops, yet not occurring in IceWM and Fluxbox sessions on the same PC. Also, some computers with Mate or Xfce installed, did not have this display issue or so slight that it was completely unnoticeable. Likely due to the various screen sizes. Definitely has to do with installed desktops though.

    As far as the menu, checked in devices that are running IceWM only, and the Rox-Panel will not display the Panel options.

    Purged rox and installed w/ apt-get. When reinstalled, there was no Rox-panel at all. It was not in the applications file or menus. Rebooted – no panel. Checked synaptic to see if it could be installed and did not see it there. Not knowing what else might be missing, reinstalled the system with a recent snapshot.

    To try to determine where the menu options begin not showing up, downloaded the final AntiX I.S.O. x64-full and made a bootable live-USB – no Panel options menu in that either. Tried different brand PCs with different graphics cards – no menu.

    Could not find a settings configuration file for Rox-panel. Is it possible to adjust the transparency and panel dimensions through command-line?

    _________________________
    Azrielle-

    Thank you for your reply.

    Being used to another file manager, the Rox-filer seemed to pale in comparison, however, after watching Dolphin’s videos, found it to be fast for transferring files and way more configurable than I was aware of. SpaceFM is also very good – especially the “File search” function.

    I gave SpaceFM-IceWM a try and I agree – very nice.

    #10927
    Member

    736b69646f6f

    rox helpdocs mention something like “if your windows have transparency (meaning: a compositor is running) the rox panel can have transparency”.

    Maybe your rox configuration files are corrupted? To rule out that possibility, try this: create another fresh user account then login as that new user. If the new user’s rox panel menu is (yes) broken, reinstall the desktop-defaults-rox package. Afterward create yet another user account, login, and check whether his rox panel menu is alright.
    If working for other user accounts, overwrite youruser’s config files with fresh copies
    cp /etc /skel /.config /rox.sourceforge.net /ROX-Filer/* ~/.config/rox.sourceforge.net/ROX-Filer
    chown yourusername:yournusername cp /etc /skel /.config /rox.sourceforge.net /ROX-Filer/*
    and afterward try launching rox panel and recheck availability of the panel menu

    The desktop menus provided by Xfce and mate environments probably do not respect or recognize all of the entries in the stock antiX desktop menu. The desktop menu entry “toggle rox panel” might be absent, but you can still start it manually but you might still wind up with some confusing hassle running it in those environments so better to just install some other panel app or dock app (docky?)(fbpanel?)

    #10937
    Member

    rej

    I made a bootable live-usb from the AntiX 17.1 Final x64 I.S.O. at sourceforge and without installing it on my hard drive just looked in it to see if the panel options menu was present to determine if it was something that I was interfering with as a user.
    ———–

    This is the same I.S.O. used for the hard drive installations on 11 different PCs (some old, some purchased new last year) and one external USB hard drive, plus several Live-USB sticks.

    The menu is not present in the I.S.O. installation media or the actual installations.

    ———————
    I do not, and never had any other desktop installed on the computer I am looking at right now, only rox-icewm and fluxbox (which would be where I could enable transparency if the options menu was provided). This install has, of course been updated and upgraded, with no appearance of that menu.

    [Fresh un-updated un-upgraded I.S.O. or installed with updates and upgrade – no menu.]

    There is no rox-panel options menu here.

    On my devices with AntiX xfce or mate, the rox-panel works otherwise flawlessly. I use rox-panel a lot on all devices.

    Like all other devices and desktops, even those with [only] icewm, do not include the rox-panel options menu.

    This is quite puzzling.

    Is it possible you have a different AntiX I.S.O. version than I have installed or applications that would add files that would produce the menu?

    Do you get that [screenshot]panel options menu in rox-icewm session also?

    #10938
    Member

    736b69646f6f

    Hi. You are right, I was not using the stock version of rox-filer when I tested.
    So I retested after booting fresh ISO and confirmed the result you reported. Panel context for options is unresponsive.

    When launched from terminal:
    $ killall rox
    $ rox -p Default -left=pb_antiX-fluxbox
    we can notice error output reported
    “** (rox:5264): WARNING **: Failed to load builder file /usr/share/rox/Templates.ui: Failed to open file “/usr/share/rox/Templates.ui”: No such file or directory”

    The antiX (debian) package is missing an expected file.
    I found a copy online:
    https://raw.githubusercontent.com/rox-desktop/rox-filer/master/ROX-Filer/Templates.ui
    (is it correct for the rox-filer version installed in antiX? I don’t know, didn’t check)

    $sudo touch /usr/share/rox/Templates.ui
    then pasted that that github content into the file
    and again from lxterminal
    $ killall rox
    $ rox -p Default -left=pb_antiX-fluxbox
    Now the “panel options” menu item opens the expected dialog
    but
    transparency is not supported as an option in the stock version of rox-filer
    and
    even when using the customized (forked) version of rox-filer, activating the “pseudo transparency” feature of fluxbox did not trigger transparency in the rox panel,

    $ rox -p Default -left=pb_antiX-fluxbox
    d

    so I guess panel transparency must require a true compositor like xcompmgr or compton

    #10958
    Member

    rej

    Thanks!! Tried this on a live-usb in case anything went wrong. Works – got the menu.

    The ability to edit as root in the Rox-filer is gone. However, SpaceFM can be set to do this.

    I appreciate your having spent the time and effort to look into this.

    Thanks again.

    #10960
    Member

    736b69646f6f

    “ability to edit as root in the Rox-filer is gone”

    Replacing your user’s rox config files with fresh copies may fix. Copy the contents of /etc/skel/.config/rox.sourceforge.net/ROX-Filer/
    into your ~/.config/rox.sourceforge.net/ROX-Filer/
    and sudo chown -R youruser:youruser ~/.config/rox.sourceforge.net/ROX-Filer/*
    (spot check to verify this suggested command has also changed the permissions on any .dotted filenames)

    #10967
    Member

    rej

    Thank you again!

    The /etc/skel directory was empty before and after installing the panel-options-menu. Hope I did not do something wrong…Your instructions were perfect.

    When I did the same configuration on the actual Hard Drive and not the Live-USB, I found that I do have the option of editing files as root in Rox-filer.

    So it is all good!

    #10974
    Member

    736b69646f6f

    ok, thumbs up !

Viewing 11 posts - 1 through 11 (of 11 total)

You must be logged in to reply to this topic.