rpcbind (1.2.6-8.1.0nosystemd1) Errror Solved

Forum Forums News Sid Upgraders rpcbind (1.2.6-8.1.0nosystemd1) Errror Solved

  • This topic has 3 replies, 3 voices, and was last updated Jun 14-9:17 am by Xunzi_23.
Viewing 4 posts - 1 through 4 (of 4 total)
  • Author
    Posts
  • #145423
    Member
    Xunzi_23

      This error came up today.

      rpcbind (1.2.6-8.1.0nosystemd1) wird eingerichtet …
      cp: der Aufruf von stat für ‘/usr/share/runit/sv/rpcbind’
      ist nicht möglich: Datei oder Verzeichnis nicht gefunden

      rpcbind has no service files.

      • This topic was modified 1 month ago by Xunzi_23.
      #145449
      Member
      ChPol

        I have three root:root files in my rcpbind directory:

        check

        #!/bin/sh
        # (cloux@rote.ch)
        # check if rpcbind service responds on localhost
        rpcinfo -p >/dev/null 2>/dev/null && exit 0
        exit 1

        finish

        #!/bin/sh
        set -e
        . /lib/runit/finish-default "$@

        run

        #!/usr/bin/env /lib/runit/invoke-run
        set -e
        NAME="rpcbind"
        DAEMON=/sbin/rpcbind
        # Exit service if DAEMON is not installed
        if [ ! -x $DAEMON ]; then
        	exit 161
        fi
        # Load defaults
        if [ -r /etc/default/rpcbind ]; then
            . /etc/default/rpcbind
        elif [ -r /etc/rpcbind.conf ]; then
            . /etc/rpcbind.conf
        fi
        exec 2>&1
        exec $DAEMON -f ${OPTIONS}

        Now you need to find out why these three files have disappeared.

        #145459
        Forum Admin
        anticapitalista

          Thanks for the bug report – new rpcbind debs should hit the repos soon.

          http://repo.antixlinux.com/uploads/sid/nosystemd/

          Philosophers have interpreted the world in many ways; the point is to change it.

          antiX with runit - leaner and meaner.

          #145465
          Member
          Xunzi_23

            @anticapitalista, many thanks for quick response.
            The deb from https://repo.antixlinux.com/uploads/sid/nosystemd/
            installed fine for me

            @ChPol, Thanks for info, before update today I had no issues.

            • This reply was modified 1 month ago by Xunzi_23.
          Viewing 4 posts - 1 through 4 (of 4 total)
          • You must be logged in to reply to this topic.