(solved) disabled screen blanking… but upon reboot it reverts to ON

Forum Forums New users New Users and General Questions (solved) disabled screen blanking… but upon reboot it reverts to ON

  • This topic has 9 replies, 4 voices, and was last updated Nov 17-7:19 am by meurglys.
Viewing 10 posts - 1 through 10 (of 10 total)
  • Author
    Posts
  • #2432
    Member
    meurglysmeurglys

    I’m in the Control Center, under Session, Set Screen Blanking and turn the function to OFF, set the counter to Zero, and save it, but every time I reboot my laptop it reverts back to ON. What file do I edit to disable it and make persistent?

    Thanks,
    Robert

    • This topic was modified 3 years, 5 months ago by skidoo.
    • This topic was modified 3 years, 5 months ago by skidoo. Reason: moved to general question (was posted to Tips-n-Tricks)
    • This topic was modified 3 years, 4 months ago by skidoo.
    #2465
    Forum Admin
    DaveDave

    Set screen blank should change the SCREEN_BLANK_TIME=”****” setting in ~/.desktop-session.conf which should be checked and set by desktop-session on startup.
    It seems that I have some fixing to do with the app.
    IIRC Off is the same as setting the time value to 0. SCREEN_BLANK_TIME=”0″

    Computers are like air conditioners. They work fine until you start opening Windows. ~Author Unknown

    #2505
    Member
    meurglysmeurglys

    So if I edit the SCREEN_BLANK_TIME=”0000” setting in ~/.desktop-session.conf will this rectify the problem until you fix it?

    #2508
    Forum Admin
    DaveDave

    I have not fully looked at the issue but I think it should. It is worth giving it a try and would take less time.

    • This reply was modified 3 years, 5 months ago by Dave.

    Computers are like air conditioners. They work fine until you start opening Windows. ~Author Unknown

    #2652
    Member
    meurglysmeurglys

    No joy. When I edit the SCREEN_BLANK_TIME=”0000” it works until I reboot, then I goes to “600”, or 10 minutes. I tried editing the file as both user and admin but still have to manually turn it off via the Control Center every time I restart my laptop.

    Not a big deal, but I just wanted to bring it to your attention.

    Robert

    #2656
    Forum Admin
    BitJamBitJam

    For now you could try adding the following line to your ~/.desktop-session/startup file:

    xset -dpms ; xset s off ; xset s noexpose

    I use this on my Gentoo system to disable screen blanking.

    Context is worth 80 IQ points -- Alan Kay

    #2658
    Forum Admin
    DaveDave

    There is a new app in the antiX github as well which should work a little better than the current one.

    I have yet to update desktop-session to match the new app. I am debating to keep it internal and update it or to make it more like a plug-in style.

    Computers are like air conditioners. They work fine until you start opening Windows. ~Author Unknown

    #2660
    Member
    meurglysmeurglys

    Thanks guys for the help. Seems the ~/.desktop-session.confr file was set to “600” and the ~/.desktop-session.conf file was set to “3600”. If that helps.

    What is the difference between the two files?

    @Bitjam, I added that line you suggested to the startup, but doesn’t seem to work for me.

    Regards,
    Robert

    • This reply was modified 3 years, 4 months ago by meurglys.
    • This reply was modified 3 years, 4 months ago by meurglys.
    • This reply was modified 3 years, 4 months ago by meurglys.
    #2673
    Moderator
    capreacaprea

    Today after an update and upgrade to version 0.2.2 the set- screen- blanking is working here.Thank you!

    #2677
    Member
    meurglysmeurglys

    Upgraded, and working now. Thanks Dave for the help.

    Regards,
    Robert

Viewing 10 posts - 1 through 10 (of 10 total)
  • You must be logged in to reply to this topic.