[SOLVED] Screen doesn’t lock on suspend. antiX 19.2.1_base

Forum Forums Official Releases antiX-19 “Marielle Franco, Hannie Schaft, Manolis Glezos, Grup Yorum, Wobblies” [SOLVED] Screen doesn’t lock on suspend. antiX 19.2.1_base

  • This topic has 4 replies, 2 voices, and was last updated May 3-11:11 pm by betman.
Viewing 5 posts - 1 through 5 (of 5 total)
  • Author
    Posts
  • #35544
    Member
    betman

      Hello!
      Where will I find the file to enable screen-lock while suspending? This option is not there in control centre.
      Thanks.

      I have tried changing the suspend command in ~/.icewm/preferences from
      SuspendCommand="/usr/bin/suspend"
      to
      SuspendCommand="xlock" && "/usr/bin/suspend"
      and it doesn’t work.
      Any help would be appreciated.

      • This topic was modified 4 years, 1 month ago by betman.
      • This topic was modified 4 years, 1 month ago by betman. Reason: path correction
      • This topic was modified 4 years, 1 month ago by betman. Reason: marked as solved
      #35572
      Member
      Xecure

        Normally, installing acpi-support and editing /etc/default/acpi-support with root privileges so that LOCK_SCREEN=true option is not commented ahould make it work, but there is a problem with getXuser that I don’t know how to solve.

        As a dirty fix, you could edit /usr/local/bin/desktop-session-exit and change the suspend option so it executes
        sudo pm-suspend && xlock

        This way, using the option “Logout” (or something similar) in the IceWM menu, and selecting “Suspend” option, should make it work.

        There is a problem with it that it has a lag of 1 or 2 seconds after it powers on before the screen is locked. I have no idea how to solve this roght now.

        • This reply was modified 4 years, 1 month ago by Xecure. Reason: correct path for desktop-session-exit

        antiX Live system enthusiast.
        General Live Boot Parameters for antiX.

        #35584
        Member
        betman

          There isn’t any file in /usr/local/bin named as desktop-session-exit.

          • This reply was modified 4 years, 1 month ago by betman.
          #35587
          Member
          Xecure

            There isn’t any file in /usr/local/bin named as desktop-session-exit.

            locate desktop-session-exit in terminal

            antiX Live system enthusiast.
            General Live Boot Parameters for antiX.

            #35619
            Member
            betman

              It works!
              But first of all I apologise. The file was there. Instead of looking inside /usr/local/bin, I was looking inside /usr/bin. Then per your instruction I changed the suspend option to ‘sudo pm-suspend && xlock’ and it works (with that lag as you said).
              Thank you a lot @Xecure !

            Viewing 5 posts - 1 through 5 (of 5 total)
            • You must be logged in to reply to this topic.