Screen resolution and wireless

Forum Forums General Hardware Screen resolution and wireless

This topic contains 17 replies, has 5 voices, and was last updated by Some1 Sep 19-8:12 pm.

Viewing 3 posts - 16 through 18 (of 18 total)
  • Author
    Posts
  • #27305
    Member
    caprea
    caprea

    BOOT_IMAGE=/boot/vmlinuz-4.9.189-antix.1-486-smp root=UUID=6984cd35-2adc-44c1-81c7-7e05c2ca377f ro acpi=off vga=788 nomodeset quiet

    It is very possible that the wlan is turned off because of the boot parameter acpi=off.
    If you say every linux has to be booted with it, then you might have to update your bios.
    Or you may need to find another boot parameter that works.
    acpi=off is not a solution for an installed system.
    Have you tried acpi_osi=
    or acpi_osi=Linux ?
    https://askubuntu.com/questions/918744/wifi-not-working-in-fresh-ubuntu-16-04-with-acpi-off

    BTW, did you try antiX17 already ?

    #27306
    Member
    VW
    VW

    I find it weird also that vesa cannot handle 1024×768 on intel chip either.

    My laptop has that problem; something about it being ‘depreciated’.

    Whenever you find yourself on the side of the majority, it is time to pause and reflect.

    Mark Twain

    #27314
    Member
    Avatar
    Some1

    First of all, I found the culprit, the faul, the big issue and yes, it was me.

    Someone has to say, Linux kernel it doesn’t bring support by default to laptops or any portable device (at least when it comes from debian build, its seen also on rpm based as far as I saw through net). So, learning about acpi made me feel less newbie. If u just installed linux in a laptop and it didn’t boot, give it a chance with this:

    https://01.org/linux-acpi/documentation/debug-how-isolate-linux-acpi-issues

    It consumes lot of time but once you manage to pull the correct acpi to boot with most of functions (fan, proccessor cores, wireless, bluetooth, graphics, etc.); the issues problem listed onto this topic can dissapear once you add the correct acpi command then be added to the kernel boot parameter.

    I run a live system from antix 17 with no issue and installed works even better but laptops seems to work very different and need to be handled with care, with the acpi off on a laptop, its a matter of time till it faint.

    Now someone can mark this thread as solved. I can’t boot with the slim manager with the graphic card activated, I’m wondering if I should reinstall all the OS or xserver again, if I put again the nomodeset on the boot parameter it loads the configuration already installed but the graphic driver is not detected. Gonna have to research again but this issue is solved. Thanks all of joinning and giving feedback that appoints me to picking up kernel parameters for boot.

    This is a signature.

Viewing 3 posts - 16 through 18 (of 18 total)

You must be logged in to reply to this topic.