Screen tearing/flickering while scrolling (Intel card)

Forum Forums Official Releases antiX-17 “Heather Heyer” Screen tearing/flickering while scrolling (Intel card)

This topic contains 1 reply, has 1 voice, and was last updated by wolfen Apr 11-11:41 am.

Viewing 2 posts - 1 through 2 (of 2 total)
  • Author
    Posts
  • #20201
    Member
    wolfen
    wolfen

    Hello!

    While I posted what I tought it was a permanent solution to screen tearing or flickering while scrolling in Google Chromium/Chrome, it seems that the problem was somewhat harder. Yes, creating the /usr/share/X11/xorg.conf.d/20-intel.conf archive with the content I posted there solved the problem with Chromium/Chrome indeed. But after that, I installed Palemoon browser, and it was even worse: not just tearing, but some lines were permanently drawn on the borders of the page when scrolling up or down. At first I tought it must be a Palemoon problem, but after a while I tried to erase the 20-intel.conf archive and… the lines in said browser dissapeared, but the tearing/flickering is back in Chromium, and a little less, but present, in Firefox & Palemoon. So now I thing there is something wrong not with browsers, but with something related to my gpu drivers or else. So, I tried again with changing to new kernels (the two newer ones in stretch repos, 4.19 and 4.20 if I’m not wrong); nothing, so I turned back to first install stretch default, 4.9.160.

    I own two identical notebooks. One of them, the one I’m using daily, has antiX 17.4 installed into HD (an eMMC, actually; a very low end machine, you know). The other, which my family is using, mostly, has the last (or a very recent at least) MX Linux version. The thing is, I don’t see this problem when using the MX Linux notebook; same hardware, so it must be a software trouble, I think. I tried inxi -b with both machines, and here’s the output for the antiX one:

    Host: antix1 Kernel: 4.9.160-antix.1-amd64-smp x86_64 bits: 64 Desktop: JWM 2.3.6 
      Distro: antiX-17.4_x64-full Helen Keller 6 March 2019 
    Machine:
      Type: Laptop System: Acer product: Aspire A114-31 v: V1.12 serial: <root required> 
      Mobo: APL model: Bulbasaur_AP_S v: V1.12 serial: <root required> UEFI: Insyde 
      v: 1.12 date: 03/02/2018 
    Battery:
      ID-1: BAT1 charge: 16.4 Wh condition: 34.8/37.0 Wh (94%) 
    CPU:
      Dual Core: Intel Celeron N3350 type: MCP speed: 1564 MHz min/max: 800/2400 MHz 
    Graphics:
      Device-1: Intel driver: i915 v: kernel 
      Display: server: X.Org 1.19.2 driver: modesetting unloaded: fbdev,vesa 
      resolution: 1366x768~60Hz 
      OpenGL: renderer: Mesa DRI Intel HD Graphics 500 (Broxton 2x6) v: 4.5 Mesa 13.0.6 
    Network:
      Device-1: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet driver: r8169 
      Device-2: Qualcomm Atheros QCA9377 802.11ac Wireless Network Adapter 
      driver: ath10k_pci 
    Drives:
      Local Storage: total: 58.24 GiB used: 10.46 GiB (18.0%) 
    Info:
      Processes: 160 Uptime: 1h 14m Memory: 3.71 GiB used: 696.5 MiB (18.4%) Shell: bash 
      inxi: 3.0.29 

    Results were mostly the same for “graphics” output: same X.Org 1.19.2, modesetting… Only difference was Mesa version: on MX, it was 18.2.6. I don’t know if this is really a clue, but this is all I have. As I’m just a random user (I don’t know how to write code or anything) who loves Linux because of its stability, security, functionality, personalization, freedom…, when I’m in any trouble I just duckduckgo or google it and try to find a solution myself, but this time I had no luck, so that’s why I’m posting here.

    [EDIT] I forgot to say that unabling GPU acceleration with the browser-in option solves the problem… But I’m not sure it solves the thing. If I can’t use my GPU, what do I have it for?)

    Please tell me if you need any more details. Thank you for reading this, any help will be really appreciated.

    • This topic was modified 2 weeks ago by wolfen.
    • This topic was modified 2 weeks ago by wolfen.
    #20402
    Member
    wolfen
    wolfen

    Hello again. I think I finally found a workaround. If I undertood it OK, the trick is changing acceleration method from sna to uxa. I’m assuming this is a safe move; so far, so good. As I posted the thing in the tips and tricks section, I’ve added a comment with the how-to there.

    As days pass, I’m happier with antiX. Rock solid, useful, light and fast. As always, thank you devs, community and all.

Viewing 2 posts - 1 through 2 (of 2 total)

You must be logged in to reply to this topic.