Session Manager Quit working

Forum Forums New users New Users and General Questions Session Manager Quit working

  • This topic has 15 replies, 4 voices, and was last updated Apr 26-4:41 pm by dukester.
Viewing 15 posts - 1 through 15 (of 16 total)
  • Author
    Posts
  • #58051
    Member
    dukesterdukester

    Again after apt upgrade, my session manager quit working.
    I’m using plain fluxbox WM.
    The exit” menu item is dead!!

    How does that get fixed? TIA

    --
    dukester

    #58056
    Member
    XecureXecure

    Please provide first
    inxi -Frxz

    #58062
    Member
    dukesterdukester

    See attached file please!

    Attachments:

    --
    dukester

    #58069
    Member
    XecureXecure

    As I explained in the other post, you need to enable at least the antix bullseye repo, and then see if updating and upgrading in terminal will fix the log-in issue.
    sudo nano /etc/apt/sources.list.d/antix.list
    replace “buster” with “bullseye”, so that your repo looks like
    deb http://mirror.it.ubc.ca/mxlinux/antix/bullseye/ bullseye main nonfree nosystemd
    save and exit. Then try

    sudo apt update && sudo apt upgrade
    sudo apt install --reinstall desktop-session-antix

    Reboot and see if you can log in in SLIm (use F1 keys to switch between the different available desktops until you see fluxbox).

    #58087
    Member
    dukesterdukester

    Ran all the commands you suggested! Then:

    sudo apt install --reinstall desktop-session-antix
    Reading package lists... Done
    Building dependency tree... Done
    Reading state information... Done
    Reinstallation of desktop-session-antix is not possible, it cannot be downloaded.
    0 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.

    --
    dukester

    #58089
    Member
    XecureXecure
    apt policy fluxbox
    apt policy desktop-session-antix

    I suspect I gave you an incorrect antix repo. Could you share again
    inxi -r

    #58097
    Member
    dukesterdukester

    Here it is, but it doesn’t make sense because I edited /etc/apt/sources.list.d/antix.list as you suggested!!

    `inxi -r
    Repos:
    No active apt repos in: /etc/apt/sources.list
    Active apt repos in: /etc/apt/sources.list.d/antix.list
    1: deb http://la.mxrepo.com/antix/testing testing main nosystemd nonfree
    Active apt repos in: /etc/apt/sources.list.d/buster-backports.list
    1: deb http://deb.debian.org/debian/ buster-backports main contrib non-free
    Active apt repos in: /etc/apt/sources.list.d/debian-stable-updates.list
    1: deb http://ftp.ca.debian.org/debian/ buster-updates main contrib non-free
    Active apt repos in: /etc/apt/sources.list.d/debian.list
    1: deb http://ftp.us.debian.org/debian/ testing main contrib non-free
    2: deb http://security.debian.org testing-security main contrib non-free
    No active apt repos in: /etc/apt/sources.list.d/onion.list
    No active apt repos in: /etc/apt/sources.list.d/various.list`

    However, your suggestions worked because I now can exit gracefully from an antix session! But I’d still like to fix this repo thing! Thanks for all your help!

    --
    dukester

    #58098
    Member
    XecureXecure

    You are right. I see no trouble in the repos you reported (apart fro buster-backports and buster-updates, but that should not influence at all).

    See http://la.mxrepo.com/antix/testing/pool/main/d/desktop-session-antix/
    desktop-session-antix is there, but for some reason it isn’t found by your system.

    At least now login/out seems to work for basic fluxbox session. Try to update a few times more and see if you can get everything else to work.

    #58100
    Member
    dukesterdukester
    apt policy desktop-session-antix
    desktop-session-antix:
      Installed: 2.0.1
      Candidate: 2.0.1
      Version table:
     *** 2.0.1 100
            100 /var/lib/dpkg/status

    I’ll update again soon like you suggest, and see what happens. Thx!!

    • This reply was modified 2 weeks, 2 days ago by dukester.

    --
    dukester

    #58103
    Forum Admin
    anticapitalistaanticapitalista

    Did you want to run testing/bullseye from an installed antiX buster iso (19.3)?
    Your first inxi output shows you using a debian sid repo.

    Philosophers have interpreted the world in many ways; the point is to change it.

    antiX with runit - leaner and meaner.

    #58107
    Member
    dukesterdukester

    LOL – I don’t know what I want for sure!

    Generally speaking, just a stable system, but with the option somehow of installing newer versions of software – not bleeding edge but newer than the standard Debian stuff.

    --
    dukester

    #58109
    Forum Admin
    anticapitalistaanticapitalista

    Well you now have a franken-antiX which means it is near on impossible to get support since we have no idea what you have installed from the Debian sid/unstable repo (I see you have gcc from sid, not from buster/stable).

    Philosophers have interpreted the world in many ways; the point is to change it.

    antiX with runit - leaner and meaner.

    #58110
    Member
    dukesterdukester

    So what’s the solution? Backup $HOME and re-install?

    --
    dukester

    #58111
    Member
    AvatarPPC

    So what’s the solution? Backup $HOME and re-install?

    That’s always a good advice to follow, when we have a very messed up system. Probably, you can back everything up and reinstall wayyyy faster than following complex procedures needed to “fix” your system…
    TIP: check also all the apps you have installed, if you installed any, so you can reinstall everything you need after reinstalling antiX…

    In my case, on my home pc, installing antiX took about 10-15 minutes…

    #58112
    Forum Admin
    anticapitalistaanticapitalista

    So what’s the solution? Backup $HOME and re-install?

    AS PPC says, it will probably be quicker to do so.

    Philosophers have interpreted the world in many ways; the point is to change it.

    antiX with runit - leaner and meaner.

Viewing 15 posts - 1 through 15 (of 16 total)
  • You must be logged in to reply to this topic.