Setting Fluxbox doesn't change WM

Forum Forums New users New Users and General Questions Setting Fluxbox doesn't change WM

Tagged: 

  • This topic has 6 replies, 5 voices, and was last updated May 2-4:06 pm by Anonymous.
Viewing 7 posts - 1 through 7 (of 7 total)
  • Author
    Posts
  • #21014
    Anonymous

      I’ve searched the forums and was unable to find anything similar.

      When I set Fluxbox, or fluxbox & rox, etc, It changes the Desktop and the RMB Fluxbox menu appears, however the Windows are still decorated by IceWM or JWM (Whichever I was running last.) I have been unable to set Fluxbox as the WM at all, even tried restarting. Is anyone else running into this issue? This is a fresh install / update. I’m pretty used to Fluxbox and other *boxes, and not really digging any of the IceWM or JWM themes lol. Please advise.

      #21015
      Moderator
      caprea

        Nope, I’ve never seen that. Did you check the md5sum of the download ?

        #21017
        Member
        fatmac

          Fluxbox is my regular WM, I’ve never had any problems with it when selected when installing, nor when, if ever, I change to another WM, an extremely rare occurrence, I must admit. 🙂

          (As above, check your download was good.)

          Linux (& BSD) since 1999
          Ultra Small Form Factor & thin client computers

          #21022
          Anonymous

            A day late and a dollar short to check my download lol. I’ve installed to my hard-drive and updated!

            Anyone know which configuration file that I should check on this? a session file or xorg.conf? It’s been awhile.

            #21025
            Forum Admin
            anticapitalista

              Did you choose to save /home when installing? If so, what was already in /home?

              • This reply was modified 5 years, 1 month ago by anticapitalista.

              Philosophers have interpreted the world in many ways; the point is to change it.

              antiX with runit - leaner and meaner.

              #21038
              Anonymous

                the RMB Fluxbox menu appears

                screenshot?
                You should check htop to ensure that fluxbox is, in fact, running.
                Almost certainly, in the scenario you described, fluxbox is not running (and what you’re seeing is not the fluxbox menu).

                Even if (somehow) a keybind existed in ~/.icewm/keys attempting to invoke
                fluxbox-remote RootMenu
                the call, from within the context of an iceWM session, would fail

                =====================

                In the event that “autologin” is enabled, the system recalls, and reapplies the last-used session type.
                I suspect that is what’s afoot here (autologin)

                #21049
                Anonymous

                  Well, I did a restart and it’s working now. Odd that it seemed to work half way. I’ll do some tests later and see if I can recreate it or if I was just going insane… Thanks to everyone for the replies!

                  I should have checked htop, like I said it’s just been awhile since I’ve used linux\bsd.

                  What I remember is that I could change the Fluxbox theme of the RMB menu and it would update but the window of space-fm wouldn’t change the window borders.

                  PS. This communities speed in replies is amazing! I hope to add to the helpful users.

                Viewing 7 posts - 1 through 7 (of 7 total)
                • You must be logged in to reply to this topic.