Sid. QT5 Transition not going smoothly.

Forum Forums News Sid Upgraders Sid. QT5 Transition not going smoothly.

  • This topic has 3 replies, 2 voices, and was last updated Oct 2-7:44 am by ModdIt.
Viewing 4 posts - 1 through 4 (of 4 total)
  • Author
    Posts
  • #89952
    Member
    ModdIt

    Todays updates and issues break torbrowser-Launcher.

    Starts with held packages
    libqt5core5a libqt5dbus5 libqt5designer5 libqt5gui5 libqt5network5
    libqt5positioning5 libqt5printsupport5 libqt5qml5 libqt5qmlmodels5
    libqt5quick5 libqt5sensors5 libqt5sql5 libqt5sql5-sqlite libqt5svg5
    libqt5test5 libqt5webchannel5 libqt5webkit5 libqt5widgets5 libqt5xml5
    qt5-gtk-platformtheme

    Try to fix:
    $ sudo apt install libqt5core5a
    Paketlisten werden gelesen… Fertig
    Abhängigkeitsbaum wird aufgebaut… Fertig
    Statusinformationen werden eingelesen… Fertig
    Die folgenden Pakete wurden automatisch installiert und werden nicht mehr benötigt:
    Following was automaticaly installed and no longer needed.
    libpython3.10 libqt5designer5 libqt5help5 libqt5test5 python3-gpg
    python3-packaging python3-pyparsing python3-pyqt5.sip
    qt5-style-plugin-cleanlooks qt5-style-plugin-motif
    Verwenden Sie »sudo apt autoremove«, um sie zu entfernen.
    Following packages will be installed:
    libqt5dbus5 libqt5designer5 libqt5gui5 libqt5network5 libqt5positioning5
    libqt5printsupport5 libqt5qml5 libqt5qmlmodels5 libqt5quick5 libqt5sensors5
    libqt5sql5 libqt5sql5-sqlite libqt5svg5 libqt5test5 libqt5webchannel5
    libqt5webkit5 libqt5widgets5 libqt5xml5 qt5-gtk-platformtheme
    Recommended Pakets:
    qt5-image-formats-plugins qtwayland5 qt5-qmltooling-plugins
    Empfohlene Pakete:
    qttranslations5-l10n geoclue-2.0
    FOLLOWING PACKAGES WILL BE REMOVED.
    python3-pyqt5 qt5-gtk2-platformtheme qt5-style-plugin-plastique
    qt5-style-plugins qt5ct torbrowser-launcher

    FOLLOWING PACKAGES will be upgraded
    libqt5core5a libqt5dbus5 libqt5designer5 libqt5gui5 libqt5network5
    libqt5positioning5 libqt5printsupport5 libqt5qml5 libqt5qmlmodels5
    libqt5quick5 libqt5sensors5 libqt5sql5 libqt5sql5-sqlite libqt5svg5
    libqt5test5 libqt5webchannel5 libqt5webkit5 libqt5widgets5 libqt5xml5
    qt5-gtk-platformtheme
    20 upgraded, 0 neu installiert, 6 to remove und 0 nicht aktualisiert.

    Tor Browser Launcher from sid is at present uninstallable.
    I pulled latest Tor browser from the website.

    #90000
    Member
    ModdIt
    Helpful
    Up
    0
    ::

    Seems the QT dependancy problem has been around on and off for years.
    The offending library is a virtual package within libqt5core5a.

    Below quick and effective dirty hack found on a KDE Neon page and
    updated, it gets things working, up to now I see no untoward effects.
    That is not a garantee. :-)…
    Users should keep a copy of changes made just in case it is needed later.
    Easy to remove any packages as long as console access is available. AND
    you know what to remove.
    That is generaly applicable.

    Better fix needed upstream, this is more an easily reverted workaround.
    This time I have not posted a bug report, last one left me with an
    unusable EMail account to to massive spam. EMail is openly displayed
    with the bug report.

    #!/bin/bash
    
    $(mkdir -p ./qtbase-abi-5-15-4-fix/DEBIAN)
    echo 'Package: qtbase-abi-5-15-4-fix
    Version: 1.0
    Section: custom
    Priority: optional
    Provides: qtbase-abi-5-15-4
    Depends: libqt5core5a
    Architecture: amd64
    Essential: no
    Installed-Size: 0
    Maintainer: custom
    Description: Fix lack of qtbase-abi-5-15-4 in antiX21 sid
    ' > ./qtbase-abi-5-15-4-fix/DEBIAN/control

    dpkg-deb --build ./qtbase-abi-5-15-4-fix

    sudo dpkg -i ./qtbase-abi-5-15-4-fix.deb

    RE INSTALL: Torbrowser-launcher

    $ sudo apt install torbrowser-launcher
    Paketlisten werden gelesen… Fertig
    Abhängigkeitsbaum wird aufgebaut… Fertig
    Statusinformationen werden eingelesen… Fertig
    Die folgenden zusätzlichen Pakete werden installiert:
    libpython3.10 libqt5designer5 libqt5help5 libqt5test5 python3-gpg python3-packaging
    python3-pyparsing python3-pyqt5 python3-pyqt5.sip
    Vorgeschlagene Pakete:
    python-pyparsing-doc apparmor
    Empfohlene Pakete:
    tor
    Die folgenden NEUEN Pakete werden installiert:
    libpython3.10 libqt5designer5 libqt5help5 libqt5test5 python3-gpg python3-packaging
    python3-pyparsing python3-pyqt5 python3-pyqt5.sip torbrowser-launcher
    0 aktualisiert, 10 neu installiert, 0 zu entfernen und 0 nicht aktualisiert.

    Subsequent full-upgrade gave no warnings. No more held packages.

    • This reply was modified 2 months, 1 week ago by ModdIt.
    #90020
    Member
    stevesr0
    Helpful
    Up
    0
    ::

    Hi Moddit,

    Although I am not currently using the Tor browser, knowing the problem and the fix is something I will make note of.

    Thanks.

    stevesr0

    #90047
    Member
    ModdIt
    Helpful
    Up
    0
    ::

    To clarify, as i already noted, TorBrowser bundle from Tor website works fine.

    The issue affected torbrowser-launcher, a debian application which is intended
    to make installation of torbrowser easier.

    We have very troubled times well knowing tor will be watched by interested services,
    cia nsa ghcq etc it may still help some to save their ass in countrys like Ru or Iran.

    Note: I have seen the issue reported as affecting other applications, the script to
    create a dummy package which I modified came from old posts regarding KDE Neon.

    • This reply was modified 2 months, 1 week ago by ModdIt.
    • This reply was modified 2 months, 1 week ago by ModdIt.
Viewing 4 posts - 1 through 4 (of 4 total)
  • You must be logged in to reply to this topic.