signature could not be verified

Forum Forums New users New Users and General Questions signature could not be verified

  • This topic has 10 replies, 4 voices, and was last updated Apr 28-6:32 pm by epitaxial.
Viewing 11 posts - 1 through 11 (of 11 total)
  • Author
    Posts
  • #116691
    Member
    jeffmernier

      Hi Folks,

      I am not sure how many things I got wrong here, I changed mirrors but still “signature could not be verified”.

      Get:5 http://mirror.math.princeton.edu/pub/mxlinux/antix/bookworm bookworm InRelease [27.4 kB]
      Err:5 http://mirror.math.princeton.edu/pub/mxlinux/antix/bookworm bookworm InRelease
        The following signatures couldn't be verified because the public key is not available: NO_PUBKEY DB36CDF3452F0C20
      Reading package lists... Done
      W: GPG error: http://mirror.math.princeton.edu/pub/mxlinux/antix/bookworm bookworm InRelease: The following signatures couldn't be verified because the public key is not available: NO_PUBKEY DB36CDF3452F0C20
      E: The repository 'http://mirror.math.princeton.edu/pub/mxlinux/antix/bookworm bookworm InRelease' is not signed.
      N: Updating from such a repository can't be done securely, and is therefore disabled by default.
      N: See apt-secure(8) manpage for repository creation and user configuration details.
      

      I tried:

      apt-key adv --recv-keys --keyserver keys.gnupg.net DB36CDF3452F0C20
      Warning: apt-key is deprecated. Manage keyring files in trusted.gpg.d instead (see apt-key(8)).
      Executing: /tmp/apt-key-gpghome.SGHUJleyYP/gpg.1.sh --recv-keys --keyserver keys.gnupg.net DB36CDF3452F0C20
      gpg: key DB36CDF3452F0C20: "antiX Linux repo <repo@antixlinux.com>" not changed
      gpg: Total number processed: 1
      gpg:              unchanged: 1
      

      but no success with that. Can this may be fixed?

      • This topic was modified 10 months, 1 week ago by jeffmernier.
      #116692
      Moderator
      caprea

        Please try to change the repo with Repo Manager
        control-centre > software > Repo Manager

        #116696
        Member
        jeffmernier

          I said:

          I changed mirrors

          does not made any diff.

          Get:5 http://mxlinux.mirrors.uk2.net/packages/antix/bookworm bookworm InRelease [27.4 kB]
          Err:5 http://mxlinux.mirrors.uk2.net/packages/antix/bookworm bookworm InRelease
            The following signatures couldn't be verified because the public key is not available: NO_PUBKEY DB36CDF3452F0C20
          Reading package lists... Done
          W: GPG error: http://mxlinux.mirrors.uk2.net/packages/antix/bookworm bookworm InRelease: The following signatures couldn't be verified because the public key is not available: NO_PUBKEY DB36CDF3452F0C20
          E: The repository 'http://mxlinux.mirrors.uk2.net/packages/antix/bookworm bookworm InRelease' is not signed.
          N: Updating from such a repository can't be done securely, and is therefore disabled by default.
          N: See apt-secure(8) manpage for repository creation and user configuration details.
          
          • This reply was modified 10 months, 1 week ago by jeffmernier.
          #116708
          Moderator
          caprea

            The mirror http://mxlinux.mirrors.uk2.net/packages/antix/bookworm works for me.Do you have the antix-archive-keyring.gpg in etc/apt/keyrings ?
            Please try this
            https://www.antixforum.com/expkeysig-error-and-fix/

            #116713
            Member
            jeffmernier

              No I do not have any keyrings in /etc/apt/keyrings.
              I tried:
              Method 1. keyring not found
              Method 2. there is no antix-archive-keyring_20019.3.13_all.deb but antix-archive-keyring_20019.3.14_all.deb downloaded this OK and installed with dpkg `dpkg -i antix-archive-keyring_20019.3.14_all.deb

              dpkg -i antix-archive-keyring_20019.3.14_all.deb
              (Reading database ... 177285 files and directories currently installed.)
              Preparing to unpack antix-archive-keyring_20019.3.14_all.deb ...
              Unpacking antix-archive-keyring (20019.3.14) over (20019.3.14) ...
              Setting up antix-archive-keyring (20019.3.14) ...
              

              apt update
              but still missing

              and recheck /etc/apt/keyrings – empty. Why is still empty if the installing/setting had no errors? The keyring actually is in /etc/apt/trusted.gpg.d

              • This reply was modified 10 months, 1 week ago by jeffmernier.
              • This reply was modified 10 months, 1 week ago by jeffmernier.
              • This reply was modified 10 months, 1 week ago by jeffmernier.
              #116743
              Moderator
              caprea

                Which version of antiX is this? On my antiX23 64bit runit version the /etc/apt/keyrings folder contains the antix-archive-keyring.gpg and liquorix-keyring.gpg.
                Indeed the antix-archive-keyring deb gets installed to /etc/apt/trusted.gpg.d
                But the antix.list is looking for the /etc/apt/keyrings folder
                You could simply copy the file from /etc/apt/trusted.gpg.d to /etc/apt/keyrings
                But I would like to know why its not in both folders on your system.

                #116749
                Member
                jeffmernier

                  Yesterday I upgraded – following anticapitalista tips – from 22 to 23. IDNK why /etc/apt/keyrings was empty, but I have a snapshot before upgrading and I will check /etc/apt/keyrings.

                  Yes, that’s exactly what I did and then signature issue solved.

                  #116788
                  Member
                  jeffmernier

                    I restored the snapshot and there is no keyrings:

                    $ cat /etc/antix-version
                    antiX-22_x64-full Grup Yorum 18 October 2022
                    brad@antix:~
                    $ lsb_release -a
                    No LSB modules are available.
                    Distributor ID:	Debian
                    Description:	Debian GNU/Linux 11 (bullseye)
                    Release:	11
                    Codename:	bullseye
                    brad@antix:~
                    $ uname -a
                    Linux antix 5.10.142-antix.2-amd64-smp #1 SMP PREEMPT Fri Sep 9 21:15:01 EEST 2022 x86_64 GNU/Linux
                    brad@antix:~
                    $ ls -la /etc/apt
                    total 40
                    drwxr-xr-x   7 root root  4096 Sep 14 09:06 .
                    drwxr-xr-x 135 root root 12288 Sep 14 09:02 ..
                    -rw-r--r--   1 root root   114 Oct 18  2022 apt.conf
                    drwxr-xr-x   2 root root  4096 May  8 16:06 apt.conf.d
                    drwxr-xr-x   2 root root  4096 Jun 10  2021 auth.conf.d
                    drwxr-xr-x   2 root root  4096 Oct 18  2022 preferences.d
                    drwxr-xr-x   2 root root  4096 Feb 13  2023 sources.list.d
                    drwxr-xr-x   2 root root  4096 May  8 15:37 trusted.gpg.d
                    brad@antix:~
                    

                    Let me know if that help.

                    #140677
                    Member
                    grunthos

                      The mirror http://mxlinux.mirrors.uk2.net/packages/antix/bookworm works for me.Do you have the antix-archive-keyring.gpg in etc/apt/keyrings ?
                      Please try this
                      https://www.antixforum.com/expkeysig-error-and-fix/

                      Hello, my antiX23-runit says my antix-keyring expired:
                      Následující podpisy jsou neplatné: EXPKEYSIG DB36CDF3452F0C20 antiX Linux repo <repo@antixlinux.com>

                      I tried both methods from the link you suggested, but the keyring from https://repo.antixlinux.com/antix-archive-keyring-2021-2024.asc as well as from antix-archive-keyring_20019.3.14_all.deb expired on 2024-04-25.
                      Are there any newer antix-keyrings available?

                      Thank you for reply.

                      #140679
                      Member
                      grunthos

                        Sorry for bothering you, I found newer version of antix-keyring in https://repo.antixlinux.com/bullseye/pool/main/a/antix-archive-keyring/antix-archive-keyring_20019.5.0_all.deb so it works now.
                        I suppose users got new version through regular updates, but since I did not use my comp for about month and half the keyring expired.
                        Might be useful to update keyring in https://repo.antixlinux.com/ since the fix in https://www.antixforum.com/expkeysig-error-and-fix/ points to that location.
                        Anyway thank you and good bye

                        #140766
                        Member
                        epitaxial

                          Thanks. I was having the same problem and your solution worked.

                        Viewing 11 posts - 1 through 11 (of 11 total)
                        • You must be logged in to reply to this topic.