Slimjet-cannot get it set as my default browser–Solved

Forum Forums General Software Slimjet-cannot get it set as my default browser–Solved

  • This topic has 24 replies, 5 voices, and was last updated Aug 4-3:45 pm by masinick.
Viewing 15 posts - 1 through 15 (of 25 total)
  • Author
    Posts
  • #39721
    Member
    Avatargreyowl

    I am running antiX 17, 32 bit.
    I recently started using Slimjet v.27.0.4.0
    I have Slimjet set as my default brower, but it does not work. My old browser, Firefox, remains the default browser.
    Each time I start Slimjet, it ask if I want to set it as default so I click the box to set it. But, it doesn’t actually get set.
    Any ideas on how to get this set correctly?

    • This topic was modified 1 week, 5 days ago by greyowl.
    • This topic was modified 1 week, 4 days ago by greyowl.

    Dell Latitude D610 laptop (1.86 GHz, 2G RAM, 32 bit) - antiX 17

    #39723
    Member
    XecureXecure

    Have you tried the antiX standard method to set Preferred Applications?

    Control Centre – Desktop – Preferred Applications – Click upward arrow to left of Web Browser – Select Chromium.desktop file – Open – OK
    (You might need to log out/login for the change to show)

    #39735
    Member
    Avatargreyowl

    Thanks for the suggestion. Yes, I set Preferred Applications to SlimJet.

    Dell Latitude D610 laptop (1.86 GHz, 2G RAM, 32 bit) - antiX 17

    #39736
    Member
    Avatarseaken64

    Thanks for the suggestion. Yes, I set Preferred Applications to SlimJet.

    And is it working now? Slimjet is now set as your default?

    Seaken64

    #39740
    Member
    Avatargreyowl

    No, it is not working as the default browser.
    If I use an application that uses the default browser, it opens Firefox.
    The problem seems to be with Slimjet. Slimjet keeps asking to be the default browser, even though I have clicked the button within Slimjet to set it as the default.
    I am wondering if there is a way to config Slimjet another way like you can with Firefox (using about:config).

    Dell Latitude D610 laptop (1.86 GHz, 2G RAM, 32 bit) - antiX 17

    #39746
    Member
    Avatarseaken64

    Hmm, strange. It works for me with SeaMonkey. Did you verify the .desktop file is set to launching slimjet correctly? There may be a .slimjet hidden file under your user?

    How about going into Firefox settings and specifically turn off as “default” browser?

    Seaken64

    • This reply was modified 1 week, 5 days ago by seaken64.
    • This reply was modified 1 week, 5 days ago by seaken64.
    #39754
    Member
    AvatarModdIt

    If not already done please give this a go, it is the system master switch setting.

    sudo update-alternatives –config x-www-browser

    that is minus minus before config. Forum always mangles that.

    • This reply was modified 1 week, 4 days ago by ModdIt. Reason: forum mangled command
    #39774
    Member
    Avatargreyowl

    If not already done please give this a go, it is the system master switch setting.

    sudo update-alternatives –config x-www-browser

    that is minus minus before config. Forum always mangles that.

    I set Slimjet as default using this method–see below:

    user@antix1:~
    $ sudo update-alternatives –config x-www-browser
    There are 8 choices for the alternative x-www-browser (providing /usr/bin/x-www-browser).

    Selection Path Priority Status
    ————————————————————
    0 /usr/bin/flashpeak-slimjet 200 auto mode
    1 /usr/bin/antix-viewer 20 manual mode
    2 /usr/bin/chromium 40 manual mode
    3 /usr/bin/dillo 50 manual mode
    4 /usr/bin/firefox 100 manual mode
    * 5 /usr/bin/flashpeak-slimjet 200 manual mode
    6 /usr/bin/mx-viewer 20 manual mode
    7 /usr/bin/palemoon 71 manual mode
    8 /usr/bin/xlinks2 69 manual mode

    Press <enter> to keep the current choice[*], or type selection number:

    With this setting, when I use Password Safe to go to a url, it opens in Firefox even if Firefox is not set as the default browser.
    If I set the default as palemoon or firefox, then everything works correctly with them as default.

    The problem only happens with Slimjet.
    Whenever I start Slimjet, I get a pop up that says “Slimjet is not your default browser” Then, click the button that says “set as default”–But, it actually does not get set as default.

    • This reply was modified 1 week, 4 days ago by greyowl.
    • This reply was modified 1 week, 4 days ago by greyowl.

    Dell Latitude D610 laptop (1.86 GHz, 2G RAM, 32 bit) - antiX 17

    #39779
    Member
    XecureXecure

    Maybe passwordsafe is to blame. Can you change default browser in the program?
    Also, check Control Centre > System > Alternatives Configurator (change gnome-www-browser, www-browser, x-www-browser or any other if possible).

    It would be good to know how slimjet calls the browser. It seems that if the url has a [alt] tag, it will launch using the Alternate browser in settings. Maybe you can work with this meanwhile.

    #39781
    Member
    XecureXecure

    The problem only happens with Slimjet.
    Whenever I start Slimjet, I get a pop up that says “Slimjet is not your default browser” Then, click the button that says “set as default”–But, it actually does not get set as default.

    Based on:

    https://www.slimjet.com/en/forum/viewtopic.php?t=1537
    By chance, noticed that Slimjet (maybe Chromium too?) uses the ‘xdg-settings’ command to determine if Slimjet is the default browser.

    It probably does:
    xdg-settings get default-web-browser
    Check if slimjet is your default web-browser. If it isn’t, and you know the name of the slimjet .desktop file (check /usr/share/applications/ folder), you can set it yourself. I imagine it should be slimjet.desktop. If so, set it using
    xdg-settings set default-web-browser slimjet.desktop

    I always thought setting the browser using antiX Preferred Applications sets said browser to be used with the xdg-open command for links. I even tested this on antiX core, so maybe this has nothing to do with xdg-settings and more to do with how passwordsafe works.

    #39784
    Member
    Avatargreyowl

    Here is what I got–does this mean that slimjet is set as default? Or, should I proceed with the second command?

    user@antix1:~
    $ xdg-settings get default-web-browser
    /usr/bin/xdg-mime: 913: local: Moon-ZX359Y.desktop: bad variable name
    slimjet.desktop
    user@antix1:~
    $

    • This reply was modified 1 week, 4 days ago by greyowl.

    Dell Latitude D610 laptop (1.86 GHz, 2G RAM, 32 bit) - antiX 17

    #39785
    Member
    Avatargreyowl

    Maybe passwordsafe is to blame. Can you change default browser in the program?
    Also, check Control Centre > System > Alternatives Configurator (change gnome-www-browser, www-browser, x-www-browser or any other if possible).

    It would be good to know how slimjet calls the browser. It seems that if the url has a [alt] tag, it will launch using the Alternate browser in settings. Maybe you can work with this meanwhile.

    Password Safe works as expected when FF and Palemoon are set as default browser so I concluded that it is a problem with Slimjet since I cannot get it set as the default browser in the system as a whole.
    I did try the Alternate Browser and [alt] tag approach with Password Safe, and it works as expected so that could be an alternative for Password Safe.
    However, I would like to fix Slimjet which cannot be set as the default browser in spite of setting it as default by several methods.

    Dell Latitude D610 laptop (1.86 GHz, 2G RAM, 32 bit) - antiX 17

    #39788
    Member
    XecureXecure

    Here is what I got–does this mean that slimjet is set as default?

    Correct. It is set as the default browser.
    If in terminal you do:
    xdg-open https://www.google.com
    does slimjet open google.com? If it does, slimjet is not the problem.

    #39789
    Member
    Avatargreyowl

    Here is what I got with the second command:

    user@antix1:~
    $ xdg-settings set default-web-browser slimjet.desktop
    /usr/bin/xdg-mime: 913: local: Moon-ZX359Y.desktop: bad variable name
    /usr/bin/xdg-mime: 913: local: Moon-ZX359Y.desktop: bad variable name
    xdg-mime: application argument missing
    Try ‘xdg-mime –help’ for more information.
    user@antix1:~
    $

    Dell Latitude D610 laptop (1.86 GHz, 2G RAM, 32 bit) - antiX 17

    #39791
    Member
    Avatargreyowl

    Here is what I got–does this mean that slimjet is set as default?

    Correct. It is set as the default browser.
    If in terminal you do:
    xdg-open https://www.google.com
    does slimjet open google.com? If it does, slimjet is not the problem.

    It opened google in Firefox.

    Here is the terminal response:

    user@antix1:~
    $ xdg-open https://www.google.com
    /usr/bin/xdg-mime: 913: local: Moon-ZX359Y.desktop: bad variable name
    Please launch slimjet via the wrapper script: flashpeak-slimjet

    ###!!! [Child][MessageChannel] Error: (msgtype=0x3900C2,name=PContent::Msg_ScriptErrorWithStack) Channel closing: too late to send/recv, messages will be lost

    ###!!! [Child][MessageChannel] Error: (msgtype=0x3900C2,name=PContent::Msg_ScriptErrorWithStack) Channel closing: too late to send/recv, messages will be lost

    user@antix1:~

    Dell Latitude D610 laptop (1.86 GHz, 2G RAM, 32 bit) - antiX 17

Viewing 15 posts - 1 through 15 (of 25 total)
  • You must be logged in to reply to this topic.