solved cant login to xfce4 after sid or testing upgrade

Forum Forums News Sid Upgraders solved cant login to xfce4 after sid or testing upgrade

  • This topic has 1 reply, 2 voices, and was last updated Sep 28-2:54 pm by anticapitalista.
Viewing 2 posts - 1 through 2 (of 2 total)
  • Author
    Posts
  • #42330
    Member
    fungalnet

    Please don’t create threads and delete them when you solve your own personal problem, even if it was a dumb mistake others have an interest to avoid such a mistake. Also everyone notified of the creation of the thread missed any additional comments. So what is the story behind this.

    return of could be wrote:

    On three different computers recently, after sid or testing upgrades, I was unable to log in to xfce4. The login screen kept coming back after failing to start it. I found I was still able to start IceWM, fluxbox, etc., so from a terminal in fluxbox, I tried running xfce4-session. I got an error message about a missing file: libpolkit-gobject-1.so.0 I found out the file is part of the package libpolkit-gobject-1-0. That package seemed to be installed already, but somehow its main files were missing. There should have been these two, the first a link pointing to the second: /usr/lib/x86_64-linux-gnu/libpolkit-gobject-1.so.0 /usr/lib/x86_64-linux-gnu/libpolkit-gobject-1.so.0.0.0 So I installed them manually. In a temporary folder, as root, I ran: apt-get download libpolkit-gobject-1-0 (Apt complied, while muttering something about unsandboxed downloads.) Then I extracted the files and moved them where they go: dpkg -x libpolkit-gobject-1-0_0.105-29_amd64.deb . tar -xvf data.tar.xz mv usr/lib/x86_64-linux-gnu/libpolkit-gobject-1.so.0* /usr/lib/x86_64-linux-gnu/ After that, I can log in to xfce4.

    Topic Link: broken deleted link https://www.antixforum.com/forums/topic/solved-cant-login-to-xfce4-after-sid-or-testing-upgrade/

    #42331
    Forum Admin
    anticapitalista
    Helpful
    Up
    0
    :D

    It was a duplicate post of this one:

    https://www.antixforum.com/forums/topic/couldnt-log-in-to-xfce4-after-sid-or-testing-upgrade/

    Philosophers have interpreted the world in many ways; the point is to change it.

    antiX with runit - leaner and meaner.

Viewing 2 posts - 1 through 2 (of 2 total)
  • You must be logged in to reply to this topic.